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Exporting Subject Alias data
End Module 6. Subject Alias

Module 7. EDC Data Entry
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Overview
Tests & Requirements
Begin Module 7. EDC Data Entry
Login to DFexplore and inspect the list of sites, subjects and visits in the record list window
Enter and save new data using EDC data entry for Subject 99007
Add reasons to explain entered data values
Enter and save Plate 3, Subject 99007 as a pending record
Mark and save unavailable data as missed. Unmark available data as missed
Retrieve and modify existing data using a predefined task and save modifications to the database
Confirm audit trail information for entered and modified data
End Module 7. EDC Data Entry

Module 8. Image Data Entry
Overview
Tests & Requirements
Begin Module 8. Image Data Entry
Send PDF images to DFexplore
Login to DFexplore and confirm the receipt of new pages in the Status View
Login to the Image Router and route a misidentified page to the Acceptance Test Study new record queue
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Retrieve new images in DFexplore Image View
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Edit an existing query
Delete an existing query
Change data and record a reason for data change
Batch validate all opened pages for Subject 99002 to level 2
Confirm the status of entered pages in Status View
End Module 8. Image Data Entry

Module 9. User-defined Query Category Types
Overview
Tests & Requirements
Begin Module 9. User-defined Query Category Types
Retrieve an existing data record in DFexplore
Apply a user-defined Category query
 Add a reason for Data Value to explain entered data
Edit an existing query
Delete a user-defined Query Category that is used by an existing query
Delete a user-defined Category query
 End Module 9. User-defined Query Category Types

Module 10. Multiple Queries Per Field
Overview
Tests & Requirements
Begin Module 10. Multiple Queries Per Field
Submit PDF images to DFdiscover
Enable multiple queries per field in DFsetup
Retrieve submitted CRF in DFexplore Image View
Enter Plate 9 for Subject 99002
Apply multiple queries to a field
Select and edit an existing query in a field that has multiple queries
Select and reply to an existing query in a field that has multiple queries
Select and delete an existing query in a field that has multiple queries
End Module 10. Multiple Queries Per Field

Module 11. Data Review
Overview
Tests & Requirements
Begin Module 11. Data Review
 Retrieve all data for Site 99 that exists at level 3
Review and approve a pending reason for data value, and approve a selected query in a field that has multiple queries
Review and move approved reasons for data values to a higher workflow level, and review queries in a field that has multiple queries
Data review and add a query to inconsistent data
Review and complete pending data for Subject 99007
Confirm audit trail information for reviewed and modified data
Run batch edit checks to verify data integrity
Use a data expression to retrieve specific subject information
Use cross-plate data criteria to retrieve specific subject information
End Module 11. Data Review

Module 12. External Query Reports
Overview
Tests & Requirements
Begin Module 12. External Query Reports
Obtain database query metrics and details using Status and List Views to review all outstanding queries prior to query report creation
Run database integrity check report DF_XXkeys to export all key fields and visit dates from required plates in the database
Use Data View to check, and if necessary correct, illegal visit dates by retrieving the problems keys identified by DF_XXkeys
Execute DF_QCupdate to update the query database and lock all records for query report generation
Execute DF_QCreports to create a standard, 3-part external query report for a study site
Confirm the status of external queries following query report creation
Execute DF_QCstatus to verify that a new query report was created by listing all reports in the QC/NEW directory
Execute DF_QCview to display the newly created query report
Execute DF_QCprint to print the query report from the QC/NEW directory
Comparing several examples from the printed query report against their corresponding queries in the study database
Execute DF_QCfax to email the query report to a valid email account
Verify the status of the queries in the sent report
End Module 12. External Query Reports

Module 13. Replying to EDC Queries, eSignatures
Overview
Tests & Requirements
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Begin Module 13. Replying to EDC Queries, eSignatures
Determine a count of outstanding queries in Status View
Review outstanding queries in Queries View
Using EDC, locate and reply to outstanding clarification queries
Add an Electronic Signature (eSign) to a set of completed subject records
Verify removal and Re-applicaton of eSignatures
End Module 13. Replying to EDC Queries, eSignatures

Module 14. Re-submitting Query Corrections
Overview
Tests & Requirements
Begin Module 14. Re-submitting Query Corrections
Submit PDF images to DFdiscover
Verify that all CRFs have arrived successfully in Image view
Retrieve submitted CRFs using DFexplore Image View
Enter Form 2, Subject 99001, resolve outstanding queries, and save the corrected CRF to the database
Enter Form 2, Subject 99002, resolve outstanding queries, and save the corrected CRF to the database
Enter Form 4, Subject 99004
Enter Form 2, Subject 99004, resolve outstanding queries, and save the corrected CRF to the database
Select and resolve a query in a field that has multiple queries
Review and approve a pending query reply for Form 1 for Subject 99002
Review, correct and approve a pending query reply for Form 1, Subject 99007
Confirm query resolution by examining the database status
End Module 14. Re-submitting Query Corrections

Module 15. Data Export and DFsas
Overview
Tests & Requirements
Begin Module 15. Data Export and DFsas
Export date values in calender format and save the exported data to a file on the local computer
Export date values from the database and save the exported data to a file on the local computer
Examining data values according to user-specified criteria
 Query the database for specific data values
Create a DFsas job file according to user-specified criteria
Create a SAS job file and data files using the DFsas job file criteria
Compare the contents of SAS data files with the actual data in the database
End Module 15. Data Export and DFsas

Module 16. PDF File Creation
Overview
Tests & Requirements
Begin Module 16. PDF File Creation
Retrieve existing data according to user-specified criteria
Saving DFexplore data to a standard PDF document
Saving DFexplore blank CRF books to a standard PDF document
Viewing a standard PDF data file using a PDF viewer application
Saving DFexplore data to an encrypted bookmarked PDF file
Open and view an encrypted bookmarked PDF file using a PDF viewer application
Create a complete subject package PDF file that includes data records, CRF images and audit trail
Open and view a PDF subject package using a PDF viewer application
End Module 16. PDF File Creation

Module 17. DFweb Data Entry
Overview
Tests & Requirements
Begin Module 17. DFweb Data Entry
Resetting a user login password
Verify DFweb version information, logging into DFweb and DFweb site certificate verification
Copying URL and changing user passwords
Creating a new subject, entering subject data
Adding, modifying and resolving queries
Adding, reviewing and downloading subject documents
Add an Electronic Signature (eSign) to a set of completed subject records
 Verify removal and Re-application of eSignatures
Verify DFweb saves eSignature task data to the specified save level
End Module 17. DFweb Data Entry

Module 18. DFcollect Mobile Data Collection
Overview
Tests & Requirements
Begin Module 18. DFcollect Mobile Data Collection
Installation, App preferences
Resetting a user login password
Online data record creation
 Download subject data for offline use
Create data records in offline mode, query resolution and adding reasons for data values
Sync data collected offline to your DFdiscover server
Clearing DFcollect cache
Adding, reviewing and downloading subject documents
Confirming data sent to the server using DFexplore
Add an Electronic Signature (eSign) to a set of completed subject records
Verify removal and re-application of eSignatures
Verify DFcollect saves eSignature task data to the specified level
Verify no saved data remains upon uninstallation and reinstallation of DFcollect.
End Module 18. DFcollect Mobile Data Collection

Module 19. DFengage ePRO Data Entry
Overview
Tests & Requirements
Begin Module 19. DFengage ePRO Data Entry
Create DFengage users role in DFadmin
Add bulk DFengage users accounts to DFadmin
Installation and initial DFengage login
Complete a task in online mode
Complete a task in offline mode
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Sync data collected offline to your DFdiscover server
Resetting a user login password
Enter data in DFengage Web
Configure and receive DFengage notifications
Confirm logout of DFengage application clears data history
Confirm data sent to the server using DFexplore
End Module 19. DFengage ePRO Data Entry

ATK Worksheet
Using the Worksheet
Module 1. Installation and Initialization
Module 2. DFdiscover Client Applications
Module 3. Study Setup
Module 4. eCRF Creation for DFdiscover
Module 5. Custom Properties
Module 6. Subject Alias
Module 7. EDC Data Entry
Module 8. Image Data Entry
Module 9. User-defined Query Category Types
Module 10. Multiple Queries Per Field
Module 11. Data Review
Module 12. External Query Reports
Module 13. Replying to EDC Queries, eSignatures
Module 14. Re-submitting Query Corrections
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Module 16. PDF File Creation
 Module 17. DFweb Data Entry
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Module 19. DFengage ePRO Data Entry Data Entry

Discrepancy Report
Discrepancy Information
Signature and Date

Copyrights
External Software Copyrights
DCMTK software package
Jansson
Mimencode
RSA Data Security, Inc., MD5 message-digest algorithm
mpack/munpack
TIFF
PostgreSQL
OpenSSL License
Original SSLeay License
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QtAV
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Getting Help

For software support, Please contact the DFdiscover team:

via email, help@dfnetresearch.com.

Visit our website, https://www.dfnetresearch.com.

Conventions

A number of conventions have been used throughout this document.

Any freestanding sections of code are generally shown like this:
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If a line starts with # or %, this character denotes the system prompt and is not typed by the user.

Text may also have several styles:

Emphasized words are shown as follows: emphasized words.

Filenames appear in the text like so: dummy.c.

Code, constants, and literals in the text appear like so: main.c.

Variable names appear in the text like so: nBytes.

Text on user interface labels or menus is shown as: Printer name, while buttons in user interfaces are shown as Button .

Menus and menu items are shown as: File  > Exit .

Introduction

Objective

The objective of the Acceptance Test Kit (ATK) is to provide DFdiscover clients with an acceptance test plan which can be executed to:

Verify the correct installation of the DFdiscover software in their own environment.

Confirm the core DFdiscover functionality in their own environment.

Demonstrate, by means of passed tests, correct operation of tested functionality and core requirements of the DFdiscover software.

Approach

The Acceptance Test Kit has these features:

Functional approach - i.e., based on meeting data management objectives.

Follows a logical data flow and processing path from user's viewpoint.

Starts with a complete study already setup using the DFdiscover software.

A series of tests organized within modules, are linked to the core requirements of the DFdiscover software. These modules are core to the use of the ATK. Each module has a
start action, a detailed script of user steps and an end action.

User is given defined input and expected output for objective verification.

Not an exhaustive test of every button, menu or GUI in every DFdiscover application.

The Kit

The Acceptance Test Kit contains:

Manual: descriptions of tests, organized within functional modules.

Control Panel application and instructions for setting the study to base state. The Control Panel application controls the start, stop and interim states of all modules.

Study: simple blood pressure study already setup, which includes plate definitions, edit checks and look-up tables.

Database: includes several completed subject cases existing at various states (i.e., entered data, submitted and awaiting data entry, awaiting outbound transmission, or EDC data
entry).

Case Report Forms.

Instructions

To perform the Acceptance Test Kit:

Module 1 provides instructions on installation and initialization. Module 1 must be completed first.

The Control Panel application sets each module to a known base state. Use the Begin  button to start each module.

Modules are presented in logical order from study setup to data entry and reviews. Any module, beginning with module 2, can be skipped if it deals with topics that are not relevant
to your use of the software.

Within each module, tests must be executed in order.

Execute module completion, by clicking End once all module tests have been performed.

Complete test summary in the form of the ATK worksheet and, if necessary, discrepancy reports.

NOTE: The provided ATK worksheet provides a convenient checklist for each module allowing for a phsyical deliverable for documentation purposes. Included with this
checklist is the discrepancy report template, which can be used to track any unexpected issues or test discrepancies encountered while running the ATK. These forms are
able to be completed digitally using a web browser for interactive field inputs or supported Adobe PDF tool to fill in input fields, or manually using printed paper copies.

Notes

 # this is example code
 code = code + overhead;
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Every module uses DFATK and must be run as datafax. Refer to Module 1 (Installation & Initialization).

References to DFdiscover Server value will be the name of your DFdiscover server.

Images in this manual are of the applications running in the Windows 11 operating system. If you are running the applications on macOS, the appearance of the windows, dialogs
and default button layouts will differ slightly from those shown here.

Screen colors may appear as a black background with a white CRF foreground. These are the DFsetup default colors. The colors in illustrations have been modified (reversed) for
clarity.

If you do not have a printer connected to the DFdiscover server (e.g. if you are a hosted client), a valid email address is required for data_coordinator, data_manager, 
site_monitor or site_invest to receive all module specific PDF files. Refer to Creating a role and permissions for data_coordinator, data_manager, site_monitor or site_invest, Step
5.

How to start DFATK

Start DFATK. DFATK is also known as the Control Panel, in the DFATK login dialog, enter the name for DFdiscover Server that has been provided by your administrator. (This
will differ from the value shown here.). As the Control Panel must be run as datafax, the Username field cannot be edited. Enter the previously specified password for datafax and
click Login .

How to start DFexplore

1. Start DFexplore. In the DFexplore login dialog, enter the name for DFdiscover Server that has been provided by your administrator. (This will differ from the value shown here.)
Enter data_coordinator, data_manager, site_monitor or site_invest in the Username field and the previously assigned password in the Password field. Click Login  to login.

2. During the first login of data_coordinator, data_manager, site_monitor or site_invest a new password must be chosen. Choose and enter a new password in both the New
Password and Confirm Password fields. Click OK to set the new password and dismiss the dialog. Choose 254 Acceptance Test Study, click Continue. If your DFdiscover
server does not allow the re-use of previous passwords, you will be required to set either data_coordinator, data_manager, site_monitor or site_invest's password to something
other than the initial password chosen previously. The password you choose must satisfy the password requirements specific to your DFdiscover server and will be needed in the
remainder of the modules.

How to start DFsetup
DFdiscover 5.11.0 Acceptance Test Manual Page 6 of 313



1. Start DFsetup. In the DFsetup login dialog, enter the name for DFdiscover Server that has been provided by your administrator. (This will differ from the value shown here.)
Enter data_manager in the Username field and the previously assigned password in the Password field. Click Login  to login.

2. In the studies selection dialog, highlight the entry for 254 Acceptance Test Study. Click Continue to continue.

How to start DFsend

Start DFsend. In the DFsend login dialog, enter the name for DFdiscover Server that has been provided by your administrator. (This will differ from the value shown here.) Enter 
data_coordinator, data_manager, site_monitor or site_invest in the Username field and the previously assigned password in the Password field. Click Login  to login.
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NOTE: If an account with a 2-factor authentication method is used to login, then the you will need to enter the code sent to the 2-factor authentication method selected in
DFadmin upon logging in with a password.

Module 1. Installation and Initialization

Overview

Prerequisites:

Licensed and Configured DFdiscover 5.11.0 installed on Study Server
DFdiscover supported email service running on Study Server (Example: postfix)
DFdiscover 5.11.0 Client Tools Installation on Local Computer
Super-user level access on Study Server for Installation of DFATK Packages

Client Tools Used: DFATK, DFexplore, DFadmin

Purpose: This module installs the DFATK modules, defines and imports the Acceptance Test Study to the DFdiscover server, and configures the DFdiscover user accounts for all
following ATK Modules. This module is intended to be run by a systems administrator or IT staff due to server access requirements. This module is a prerequisite for all following
modules.

Tests & Requirements

1. Confirm version information can be obtained for DFdiscover.

2. Obtain super-user privileges and remove older Acceptance Test Study, if one exists.

3. Install the Acceptance Test Study.

4. Define Acceptance Test Study to the DFdiscover server.

5. Create a role and permissions for datafax.

6. Creating study roles and permissions.

7. Creating user accounts and assigning study permissions.

8. Enable high defintion imaging.

9. Start the Acceptance Test Study control panel application.

Estimate of Time Required: 30 Minutes

Confirm version information can be obtained for DFdiscover

1. Confirm the Acceptance Test Kit is installed on the following Linux operating system:

Red Hat / CentOS

SUSE

2. Confirm DFdiscover version information by starting DFexplore.
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3. In the login dialog, click About. Confirm that the version information in the dialog matches the installed software Version 5.11.0.

4. If the version is not DFdiscover 2026 Version 5.11.0, you must stop at this point. The Acceptance Test Kit is specifically designed for release DFdiscover 2026 Version 5.11.0.

5. Exit DFexplore.

Obtain super-user privileges and remove older Acceptance Test Study, if one exists

NOTE: This step is required only if 254 Acceptance Test Study already exists on your DFdiscover server. If it does not currently exist on your DFdiscover server, skip this
section and continue with Install the Acceptance Test Study.. If an earlier version does exist on your server, delete it prior to installation by following these steps.

1. Start DFadmin. Login to your DFdiscover Server as datafax.
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2. Specify a Username of datafax, and the assigned user password in the Password field. Click Login  to complete login and continue. Click Status Tab. The list of studies defined
on your DFdiscover Server will be displayed in the studies list.

3. Select the entry for 254 Acceptance Test Study from the list of studies. Select Action  > Disable study>. In the confirmation dialog, enter the text Study Removal.

4. Click Disable  to disable the Acceptance Test Kit.

5.  Click Studies tab. Select the entry for 254 Acceptance Test Study if it is not already highlighted. Click Delete . From the 3 delete options, choose Remove Study from
DFdiscover.

6. Click Delete  in the confirmation dialog to continue with the delete.
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7. In the Remove Study dialog, Uncheck (disable) Archive Study Permissions and click Continue.

8. To confirm, enter the password for datafax and click OK. Close the study removal confirmation dialog by clicking OK.

Install the Acceptance Test Study

NOTE: Existing Acceptance Test Kit directories, val254 and .val254_states, must be removed prior to installation of the DFdiscover 2026 Version 5.11.0 Acceptance Test Kit. This
is because the study directory structure and/or base states have changed with DFdiscover 2026 Version 5.11.0. 

If the directories are present at this time, installation of the DFdiscover 2026 Version 5.11.0 Acceptance Test Kit will create TAR file of the existing installation and re-install the
updated DFdiscover 2026 Version 5.11.0 val254 and .val254_states directories.

The DFATK-5.11-0.x86_64.rpm file can be found on www.dfnetresearch.com in the Support section. After downloading the DFATK-5.11-0.x86_64.rpm execute the installation
using rpm on OpenSUSE & RHEL operating systems. The installation defaults to the /opt/studies directory, this can be changed using the rpm --prefix=NEWPATH flag.

New installations using rpm, which will automatically download and install any dependencies required:

# rpm -ivh DFATK-5.11-0.x86_64.rpm

OR, specify an alternative installation location:

# rpm -ivh --prefix=NEWPATH DFATK-5.11-0.x86_64.rpm

NOTE: Use of rpm --prefix=NEWPATH does not alter current definitions of DFstudyspaces.db or DFstudies.db. These files must be manually updated to include the
specified prefix pathing.

Confirm the presence of 254 Acceptance Test Study with the command:

# ls -d /opt/studies/val254

Define Acceptance Test Study to the DFdiscover server

1. Return to DFadmin, select the Studies tab. Add a definition for 254 Acceptance Test Study. Click New and complete the dialog with the following values:

Study Number: 254

Study Name: Acceptance Test Study

Study Space: opt_studies (or the name of the Study Space for the /opt/studies directory)

Study Folder: val254

Select Restore previous Study at this location

NOTE: The name of your Study Space may differ from that shown here if the Study Space is something other than opt_studies on your DFdiscover server.

2. Click OK to confirm the action and add an entry for 254 Acceptance Test Study to the list of studies.

3. Verify configuration information and set the Preset Printer. Select the newly added 254 Acceptance Test Study entry from the list of studies. Click Configurations tab and enter
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the name of a networked printer in the Preset Printer field.

4. Choose All minor versions supported from the Version Strict drop-down.

5. Select File  > Save or click Save to save the configuration information.

Create a role and permissions for datafax

User datafax is already defined on your DFdiscover installation, however, you must grant user datafax a role and permissions to be able to access 254 Acceptance Test Study.

1. Click Users tab. Confirm that user datafax is present in the Username column for one user row.

2. Create a Role for user datafax. Begin this task by clicking the Roles tab.
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3. Within the list of studies, locate and choose the entry for 254 Acceptance Test Study. Click New to add a new user role. In the dialog, enter the role name Unrestricted.

4. Click Create  to create the new role Unrestricted.

5. Define Tools & Reports permissions for the Unrestricted role. Highlight Unrestricted in the Roles list to make it the active role. Enter Full Permissions in the Description field.
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6. Click Tools & Reports tab below the Description field. Check (enable) each of the following: DFexplore & API Clients, Server & DFsetup, DFdiscover Reports, and Study
Reports.

7. Click Auto Logout tab. If not already enabled, check (enable) the Inherit from Study box to override the default Auto Logout settings with those of the ATK study.

8. Click Permissions tab.

9. Set data permissions as follows:

Visits = ALL

Plates = ALL

Levels = ALL

Check (enable) Show Hidden Fields

Check (enable) Show Int. Queries

Modify = 0-7

Write Levels = 0-7

Data = Check (enable) CMDL (Create, Modify, Delete, Missed), but not P (Password)

Queries = Check (enable) CMDAR (Create, Modify, Delete, Approve, Reply)

Reasons = Check (enable) CMDA (Create, Modify, Delete, Approve)
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10. Select File  > Save or click Save to save settings for role Unrestricted.

11. Still as datafax and with the DFadmin application open, click Users tab.

12. Set permissions for datafax. Click the entry for datafax from the list of users to make it active. Click Permissions tab. Check (enable) Allow access to Image Router.

13. To assign a study to datafax, click the blank area below the Study heading. Select 254 Acceptance Test Study from the Study drop-down. Set:

Sites = All

Subjects = All

Role Name = Unrestricted
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14. Click Save to save the role and permissions for datafax.

Creating study roles and permissions

1. Create a Role for user data_coordinator. Begin this task by clicking the Roles tab.

NOTE: If the role already exists, confirm the permissions and settings described in Step 2 to Step 8 and make changes where necessary.

2. In the list of studies, locate and choose 254 Acceptance Test Study. Click New to add a new user role. In the confirmation dialog, enter the role name data_coordinator.

3. Click Create  in the New Role dialog to apply the role name.
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4. In the Description field enter: Levels 0-4, data entry and meta data.

5. Click Tools & Reports tab. Check (enable) each of the following: DFexplore & API Clients, Server & DFsetup, DFdiscover Reports, and Study Reports.
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6. Click Auto Logout tab. If not already checked (enabled), check Inherit from Study to override the default Auto Logout setting with the study setting.

7. Click Permissions tab.

8. Set data permissions with the following settings:

Visits = ALL

Plates = ALL

Levels = 0-4

Check (enable) Show Hidden Fields

Check (enable) Show Int. Queries

Modify Levels = 0-4

Write = 0-4

Data Check (enable) = CMDL (Create, Modify, Delete, Lost), but not P (Password).

Queries Check (enable) = CMDAR (Create, Modify, Delete, Approve, Reply)

Reasons Check (enable) = CMDA (Create, Modify, Delete, Approve)
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9. Click Save to save the role.

10. Click Copy then Paste , specify a role name of site_monitor. Click Create .

11. Click Restrictions tab.

12. Enter a Description of Monitor Permissions. Set query restrictions as follows:

Visits = ALL

Plates = ALL

No C = 1-30,32

No M = 32

No D = 1-30,32

No A = 32

No R = blank

Click Save.

13. Select data_coordinator role, click Copy then Paste , specify a role name of site_investigator. Click Create .

14. Click Permissions tab.

15. Enter a Description of eSignature Permissions. Set data permissions as follows:

Visits = ALL

Plates = 1,7

Levels = ALL
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Check (enable) Show Hidden Fields

Check (enable) Show Int. Queries

Modify = 0-7

Write Levels = 0-7

Data = Check (enable) CMDLP (Create, Modify, Delete, Lost, Password)

Queries = Check (enable) CMDAR (Create, Modify, Delete, Approve, Reply)

Reasons = Check (enable) CMDA (Create, Modify, Delete, Approve)

Click Save.

Creating user accounts and assigning study permissions

1. Still as datafax and with the DFadmin application open, click Users tab to open the user definition window.

2. Determine if user data_coordinator has already been defined. Review the list of users to determine if an entry exists for user data_coordinator.

NOTE: If an entry for data_coordinator cannot be located in the list of users, complete Step 3 to Step 12 inclusive.

3. Click New/Find  to add a DFdiscover account for user data_coordinator. In the dialog, select Create new user enter the Username data_coordinator as shown.

4. Click OK to add data_coordinator to the list of users. An empty icon represents data_coordinator, the status of data_coordinator is set to Inactive.

5. Choose the data_coordinator entry from the list of users if it is not already highlighted. Click User Profile tab. Enter these settings:

Full Name = data_coordinator

Affiliation = DFnet

Email = Your email address

NOTE: A valid email address is required to receive module specific PDF files if you have not specified a printer in the Master view.
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6. If your server is configured to support Azure SMS services, and your cell phone number is within the supported region, then additionally enter these settings into the User Profile
section, otherwise, skip to Step 7:

Telephone = Your Cell Phone Number

Two-factor authentication required = Checked (enabled)

Send code by = Azure SMS

NOTE: Phone numbers entered for Azure SMS services must match the format for the Azure SMS configuration and region for your Azure Instance. Phone numbers must
additionally include the country and area code of the designated number.

7. No further user profile information is needed. Click Save.

8. With user data_coordinator still as the active user, click Permissions tab. Check (enable) Allow access to Image Router.
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9. To assign a study to data_coordinator, click the blank area below the Study heading. Select 254 Acceptance Test Study from the Study drop-down. Set:

Sites = All

Subjects = All

Role Name = data_coordinator

10. Select Active from the Status drop-down list to change the status from Inactive to Active for user data_coordinator. 
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11. Assign a DFdiscover password for data_coordinator by clicking New Password. Enter a password of your choice in place of the auto-generated system password.

NOTE: Remember the password assigned in this step as it is needed in future tests.

12. Locate and choose the entry for user data_coordinator in the list of users. Click Permissions tab and confirm the following settings. If any of the following permissions do not
appear as shown below, set them now.

Allow access to Image Router box is checked (enabled)

254 Acceptance Test Study is assigned to user data_coordinator.

Sites = ALL

Subjects = ALL

Role Name = data_coordinator

13. Save all previously entered permissions, roles and password by clicking Save.

14. With data_coordinator as the active user, click Duplicate . In the dialog enter a username of data_manager. Click Create .

15. Specify a Full Name of data_manager. Click Permissions tab, then ...  within the Study or DFdiscover Administrator. Select Study Admin for Selected Studies, check
(enable) 254 Acceptance Test Study. Click OK.

16. Confirm the Study Roles permissions. If any of the following permissions do not appear as shown below, set them now.

Allow access to Image Router box is checked (enabled)

254 Acceptance Test Study is assigned to user data_manager.

Sites = ALL
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Subjects = ALL

Role Name = Unrestricted

17. Verify the status for data_manager. If data_manager is set to Inactive, select Active from the Status drop-down list.

18. Assign a DFdiscover password for data_manager by clicking New Password . Enter a password of your choice in place of the auto-generated system password. Click Save.

NOTE: Remember the password assigned in this test step as it is needed in future tests.

19. Click data_coordinator to make it the active user. Click Duplicate . In the dialog enter a username of site_monitor. Click Create

20. Specify a Full Name of site_monitor. Click Permissions tab and confirm the following settings. If any of the following permissions do not appear as shown below, set them now.

Allow access to Image Router box is unchecked (disabled)

254 Acceptance Test Study is assigned to user site_monitor.

Sites = 99

Subjects = ALL

Role Name = site_monitor

21. Verify the status for site_monitor. If site_monitor is set to Inactive, select Active from the Status drop-down list.

22. Assign a DFdiscover password for site_monitor by clicking New Password . Enter a password of your choice in place of the auto-generated system password. Click Save.

NOTE: Remember the password assigned in this test step as it is needed in future tests.

23. With site_monitor as the active user, click Duplicate . In the dialog enter a username of site_invest. Click Create
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24. Specify a Full Name of site_investigator. Check (enable) Two-factor authentication required. When 2-factor authentication is enabled, you will need to enter an email address.
Alternatively, if Azure SMS is configured and enabled on your server, you may enter a phone number in the supported region of your Azure SMS configuration in the telephone
field, and select Azure SMS in the Send code by field.

25. Click Permissions tab and confirm the following settings. If any of the following permissions do not appear as shown below, set them now.

Allow access to Image Router box is unchecked (disabled)

254 Acceptance Test Study is assigned to user site_invest.

Sites = 99

Subjects = ALL

Role Name = site_investigator

26. Verify the status for site_invest. If site_invest is set to Inactive, select Active from the Status drop-down list.

27. Assign a DFdiscover password for site_invest by clicking New Password . Enter a password of your choice in place of the auto-generated system password. Click Save.
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NOTE: Remember the password assigned in this test step as it is needed in future tests.

28. Click Studies tab followed by History tab. The study history is displayed in Simplified view.

29. Select Detailed history to view the detailed history of changes.

30. Click Save As... . In the resulting dialog specify a filename of module1_studyhistory.xlsx, click Save.

Enable high definition imaging

1. To enable high definition imaging, click the Traffic tab. Within that view, click the Inbound tab to display the Inbound view.

2. Check Enable High Definition Imaging. The Normal Colors checkbox is enabled by default. If it is not, enable it. Click Save to save the settings.
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3. Select File  > Exit  to close DFadmin.

Start the Acceptance Test Study Control Panel application

1. The remaining steps in this module require datafax privileges. Open the DFATK (Control Panel) login dialog.

2. Enter the name of the DFdiscover Server on which the Acceptance Test Kit has been installed. As the Acceptance Test Kit Control Panel must be run as datafax, the Username
field cannot be edited. Enter the previously specified password for datafax and click Login .
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3. In the Control Panel, confirm that Module 1. Installation and Initialization is the current module and that its status is Not yet performed. Click End to complete Module 1.
Installation and Initialization.

Module 2. DFdiscover Client Applications

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Email address configured for site_monitor

Client Tools Used: DFATK, DFexplore, DFadmin, DFsetup, DFsend

Purpose: This module tests the DFdiscover client tools to ensure that they have been properly installed and that all basic views and documentation are intact. This Module additionally
tests sending of data through DFsend to verify operation of the image router.

Tests & Requirements

1. Send PDF images to DFexplore.

2. Resetting a user login password.

3. Verify the online user documentation. Open the Image Router and verify the appearance of the Welcome Image.

4. Open the Acceptance Test Study and verify the standard DFexplore views.

5. Start DFsetup and verify version information.

6. Verify the online setup documentation. Open the Acceptance Test Study setup and verify the standard DFsetup views.

Estimate of Time Required: 20 minutes

Begin Module 2. DFdiscover Client Applications

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 2. DFdiscover Client Applications  followed by Begin  to begin this module.

Send PDF images to DFexplore

1. Click Send Welcome Image to email a copy of Welcome_Fax.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.
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NOTE: Save the Welcome_Fax.pdf file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user accounts
and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

2. Start DFsend, login as user site_monitor as described in “How to start DFsend”.

3. Click Add. From the Select PDF Files file selection dialog, locate the previously saved Welcome_Fax.pdf file. Select the file, Click Open.

NOTE: Alternatively documents can also be added by dragging-and-dropping the desired PDF files from a local file folder into the list area.

4. Click Send. In Verify Password dialog, enter site_monitor in the Username field and the previously assigned password in the Password field. Click OK.

5. In the resulting Send PDFs to DFdiscover dialog, confirm 1 success and 0 failure are shown. Click OK.

6. Click Show Log to review the DFsend transmission history.

7.  Select File  > Exit .
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NOTE: Wait 2-3 minutes prior to proceeding to DFexplore.

Resetting a user login password

1. Start DFexplore, enter data_manager in the Username field of the login dialog, and click Forgot Password?.

2. In the Reset Password dialog, enter the email address associated with the data_manager account and click Submit . A confirmation message appears: Instructions to change
your password have been emailed to you.

3. Open the password reset email from your DFdiscover server and click the provided link to reset the data_manager password.

4. Enter and confirm a new password, then click Update .

5. A message confirming Password changed successfully. is displayed in your browser, and a notification email is sent to the address associated with the data_manager account.

Verify the online user documentation. Open the Image Router and verify the appearance of the Welcome Image

1. Return to DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in How to start DFexplore.

2. Select Help > Topics  to access the documentation. In the documentation window click Preface, confirm the documentation version number matches the installed software Version
5.11.0. Select File  > Close to dismiss the documentation window.
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3.  Select File  > Close Study  to exit the study.

4. In the DFexplore login dialog, Click Image Router  to start the Image Router. Locate the Welcome image by selecting the page from the list of documents in the CRF ID panel.

NOTE: Any pages that have been received and which DFdiscover could not identify as CRFs for any of the studies registered at your site, will be found in the Image Router.
The Welcome image is added during initialization of the module. If there are more pages than the Welcome image in your Image Router window, you may need to locate the
Welcome image in the list of images in the CRF ID panel.

5. Print the Welcome image from the Image Router by selecting Page > Print . Choose your locally installed printer, choose All for Page Range, and click Print .

6. Delete the Welcome image from the Image Router by selecting Action  > Discard . Click OK to confirm the discard action.

7.  Select File  > Close Image Router  to exit the Image Router. The study selection dialog is presented.

Open the Acceptance Test Study and verify the standard DFexplore views

1. In the study selection dialog, highlight the entry for 254 Acceptance Test Study. Click Continue.
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NOTE: If this step is performed within 60 seconds of closing the Image Router window, the Username, Password and list of studies are still visible. If more than 60 seconds
have elapsed, you will first need to re-enter the Password for data_manager, and click Login  to view the study selection dialog. Then highlight the entry for 254 Acceptance
Test Study and click Continue.

2. Select File  > Preferences. In the Preferences dialog, open each panel and set the options exactly as illustrated. When finished, click OK to save the settings and close the
dialog.

3. Select View > Image to make Image view the current view. Set Quantity = 25. Do not change any other settings in the Automatic Retrieval dialog and click OK to retrieve the
new documents.

NOTE: The record retrieval dialog displays the last retrieval mode from the session preferences for each user on each computer. If data_manager previously used DFexplore
in another mode, you may not see the Automatic Retrieval dialog that is illustrated. You may see a different record retrieval dialog. When this happens, click Cancel  in that
record retrieval dialog. Then select Select  > Automatic Retrieval  and, as necessary, correct the settings in the resulting dialog so that they match the illustration.

4. Image view becomes the current view, 12 new records are displayed in the record list panel, and the first record is highlighted. The main window displays the data record in the top
pane and document image in the bottom pane.
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5. Select View > Data  to change to Data view. In the confirmation dialog, click OK to release the set of image records.

6. Double-click the entry for Site 99 - Hospital #99 in the record list panel. The site opens to display the subject list. The subject list displays all enrolled subjects and the next 5
potential subjects for the site.
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7. Double-click the entry for Subject 99004 to list all visits for that subject. Select Subject  > Expand All Visits . In the record list panel, locate the 6: Form 6 entry belonging to the 30
: Study Termination visit. Click it to make it the active page in the main data window.

8. 6: Form 6 has been defined in the study setup with colored, multi-language backgrounds as well as the default black/white English background for the data entry screen. Select
File  > Preferences. In the Preferences dialog, change:

CRF Type from Default to Dutch

Click OK to save the preferences and close the dialog. Confirm that the background CRF in the data window has refreshed to the Dutch version.

9. Re- Select File  > Preferences. Change the Background Options choice for CRF Type from Dutch to Spanish. Click OK to apply the preferences and close the dialog.
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10. Re- Select File  > Preferences. Reset the Background Options for CRF Type to Default. Click OK to save the preferences and close the dialog.

11. Double-click the entry for 99001. This closes 99004 and opens the list of visits for 99001. Select Subject  > Expand All Visits  to open all visits and pages for subject 99001. In the
record list panel, locate 1: Form 1 under 0 : Screening Visits. Click it to open the page in the main data window.

12. Select View > Queries  to switch to Queries View. Select Show > All Queries  to display all queries for the current subject.
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13. Select View > Reasons to switch to Reasons View. Select Show > All Reasons.

14. Select View > List  to switch to List View. Confirm that the Plates & Metadata tab is highlighted at the top of the record list panel. Click 001 - Blood Pressure Screening Visits
from the list of plates.
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15. Choose the Modules tab at the top of the list panel to display a list of all modules defined for the study. Click Demographics - Patient Demographics module.

16. Select View > Batch Edits  to switch to Batch Edits View.

17. Select View > Reports  to switch to Reports View. In the reports list panel, double-click DFdiscover Reports followed by Legacy Reports. Highlight the report DF_PTcrfs from
the list of Legacy Reports.
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18. In the Specify field, enter the report option -i 99001. Click Run to run the report for subject 99001. Examine the output displayed in the output window.

19. Select View > Status  to switch to Status View.
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NOTE: Any pages that have been received and which DFdiscover could not identify as study CRFs will be found in the Image Router. As a result, the number of Images
awaiting review in Image Router may differ from what is shown here.

20. Select View > Dashboard  to display the Dashboard View. Click ... , select Record status tabular view and Record status chart. Click OK.

21. Select View > Schedule  to display the Schedule View. Click Refresh to display the scheduling information.

22. Select File  > Exit  to exit DFexplore.

Start DFsetup and verify version information

1. Start DFsetup, login as data_manager as described in “How to start DFsetup”.

2. In the login dialog, click About . Confirm that the version information in the dialog matches the installed software Version 5.11.0.
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3. Choose 254 Acceptance Test Study, select View Only and click OK to continue. The main DFsetup window opens.

Verify the online setup documentation. Open the Acceptance Test Study setup and verify the standard DFsetup views

1. Select Help  > Topics  to access the documentation. In the documentation window click Preface, confirm the documentation matches the installed software Version 5.11.0. Select
File  > Close to dismiss the documentation window.

2. Select any plate entry in the Plates-Modules-Fields list panel to make that plate the active plate. The main window is refreshed with the CRF view of the plate definition, which
includes widgets for all modules and fields. Click any field widget on the current plate to make that field the active field.
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NOTE: DFsetup remembers the last active plate from your previous DFsetup session so your main DFsetup window may display a different plate as the active plate.

3. Select the 2 - Patient Entry Form entry from the list panel to make plate 2 the active plate. Click Plate View > Field List  to replace the Plate view with a listing of all plate 2 fields
and their properties. Click Field List  > Plate View to return to the Plate view of plate 2.

4. Select the entry for 6 - Patient Evaluation Report from the list panel to make plate 6 the active plate. Examine the CRF List panel displayed in the bottom-left of the screen. Each
entry represents a unique multi-language color background associated with plate 6. This study database has been defined to include colored, multi-language CRF backgrounds for
plate 6, with the default background being black/white English. The default English background and some of these multi-language backgrounds were accessed previously in Open
the Acceptance Test Study and verify the standard DFexplore views..
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5. From the CRF List panel, choose the entry 30 Dutch.

6. Select File  > Preferences. In the Preferences dialog, choose Color for Background Color. Click OK to close the Preferences dialog.

7. From the CRF List panel, choose the entry 30 Spanish.
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8. Return to the default (English) CRF background for plate 6 by choosing DEFAULT in the CRF List panel.

9. Select View > Sites  to open the Sites editor. Review the contents.
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10. Select View > Visit Map to open the Visit Map editor. Visually confirm that the expected contents are displayed. Click Done to close the editor.

11. Select File  > Exit  to close DFsetup.

End Module 2. DFdiscover Client Applications

Return to the DFATK application. Click End to confirm successful completion of Module 2. DFdiscover Client Applications.

Module 3. Study Setup

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Email address configured for site_monitor

Client Tools Used: DFATK, DFexplore, DFsetup, DFsend

Purpose: This module tests the configuration of study properties and schema information (styles, modules, fields, plates, etc.) using DFsetup as well as the ability to send study
information to the study for the purposes of data entry using DFsend.

Tests & Requirements

1. Permitted users can gain exclusive access to DFsetup to modify a study setup.

2. Define Global study preferences and apply settings to DFsetup.

3. Create and modify a new style (Comment).

4. Create and modify a new module (Death).

5. Assign Field definitions to a newly created module.

6. Assign a module's field definitions to a plate.

7. Correct field ordering on the current plate to set field traversal order for data entry.

8. Use copy and paste to create repeating module and field references on a plate.

9. Create user-defined query category codes.

10. Submit a copy of the newly defined Plate 11 into the study database and retrieve the page in DFexplore Image View.

11. Enter and save all data on the submitted plate 11.

Estimate of Time Required: 20 Minutes

Begin Module 3. Study Setup

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 3. Study Setup followed by Begin  to begin this module.
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Permitted users can gain exclusive access to DFsetup to modify a study setup

1. This module requires user data_manager to have exclusive access to the 254 Acceptance Test Study database, the Control Panel must be closed. Click Exit .

2. Start DFsetup, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”.

3. Choose Exclusive Access and click OK. Exclusive Access allows you to create and modify plates, styles and fields, and to define all setup configuration files.

4. Select File  > Preferences to open the Preferences dialog. Set:

Exit after __ minutes of inactivity = 5

Background Color = Color

Click OK to save and close the dialog.

Define Global study preferences and apply settings to DFsetup

1. Select Study > Global Settings  to open the Global Settings dialog. Click Global tab. Confirm that:

Study launched in the year = 1990

Reasons for data change are required = per field

Show next __ New Subject binders = 5

Check (enable) Enable New Subject creation

Uncheck (disable) Run Edit checks in View mode

Uncheck (disable) Show red asterisk for required and essential fields

If these options are not set this way, modify them now and click Apply .
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2. Click Help . Select HTML tab. Enter the following:

            <html>
            <center>
            <h2>Welcome to the Acceptance Test Study.</h2>
            <p>For assistance please contact <strong>1-XXX-XXX-XXXX</strong>.</p>
            </center>
            </html>
                              Click Apply .

3. Click Fields tab, and set:

Descriptions = 40 characters

Start year (for two digit years) = 1940

Imputation (for partial dates) = Never

Check (enable) Auto Generate Help

Uncheck (disable) Field Name must be unique across all module definitions

Do not edit Fill Color
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4. Click Levels tab. Confirm that the workflow labels of Level 0, Level 1, and through to Level 7 are used.

5. Click Guides tab. Confirm/change:

Check (enable) Enable Snap

Check (enable) Display CRF

Check (enable) Display Fields

Set Maximum Box Height = 25

No changes are required to Colors Fields or Foreground
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6. Click Custom tab. Confirm that all Property Values are blank.

7. Click ePRO tab. Confirm the default ePRO registration settings:

Checked (enabled) Name

Checked (enabled) Email

Checked (enabled) Verify identity check

Checked (enabled) Verify consent & eligibility check

Send Invitation: always
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8. Click OK to save changes and exit the dialog.

Create and modify a new style (Comment)

1. Select View > Styles  from the menubar.

NOTE: The style names and information appearing in your Styles dialog may be different from those shown here. You should see the standard DFdiscover Simple styles.

2. Within the DFsetup-Styles dialog, locate the style name SimpleString. Click SimpleString to select it as the current style. Click Clone to duplicate this style.

3. Provide a Style name of Comment in the Style dialog and click OK.

4. Click Comment to make it active, and confirm the Style Properties Basic tab displays the style properties as shown.
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5. Click Detail tab, Change the Store property from 1 to 200. Check (enable) the [ ] to the left of the Store property to lock this setting in the Comment style. Click Apply  to apply
the modifications. Click Done to close the Style Properties dialog.

Create and modify a new module (Death)

1. Choose 10 - Death Report entry from the Plates-Modules-Fields list panel to make plate 10 the active plate. Select View > Modules  to open the module definition dialog.

2. Click Module options New.

3. Enter a name of Death in the Add Module dialog. Click OK to save.

4. With the Death module selected as the active module, confirm that the Name Death appears in the Module Properties window. In the Description field, enter Death Report. Click
Apply .
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Assign Field definitions to a newly created module

1. Choose Death module defined in “Create and modify a new module (Death).” to make it the active module. Click Field options New.

2. To create a field definition for “Cause of Death”, choose Comment from the Style pull-down list, click OK.

3. Enter the name DEATH for the Field Name: and click OK.

4. Within the Field Properties, enter a Description of Cause of Death?. Click Apply .

5. Click Field options New. In the resulting New Field Style dialog, choose S99 NO-YES from the Styles pull-down list. Click OK.

6. Enter the name AUTOPSY for the Field Name: and click OK.
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7. Within the Field Properties, enter a Description of Was an autopsy performed?. Click Apply .

8. Click Done.

Assign a module's field definitions to a plate

1. Still with 10 - Death Report as the active plate, create the field references (layouts) for the Cause of death and autopsy fields defined in “Assign Field definitions to a newly
created module.”. First add the Death module to plate 10-Death Report by clicking Add from the Module options. Locate and choose Death module from the list of modules.

2. Click OK to add the Death module to plate 10-Death Report.

3. Click [ ] to the left of Death [1] module entry in the Plates-Modules-Fields list to show all field definitions within the Death [1] module.
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4. Create a field reference for the Cause of Death. Using the mouse, select Click the leftmost end of the second longest lines on the plate background. Holding down the left mouse
key and Control , drag up and across to the rightmost end of the line. Release the mouse key to create a string field widget.

5. Select the DEATH field in the Plates-Modules-Fields listing to assign a field definition.

DFdiscover 5.11.0 Acceptance Test Manual Page 53 of 313



6. Create a field reference for the Was an autopsy performed? field. Using the mouse, click the middle of the No box on the plate background. Next click the middle of the Yes box
on the plate background. This defines the position of each response option for the AUTOPSY field.

7. Select the AUTOPSY field in the Plates-Modules-Fields listing to assign a field definition.

Correct field ordering on the current plate to set field traversal order for data entry

1. All fields are now defined on plate 10 - Death Report. Select Field  > Order . In the dialog, sort the fields as shown, by using the arrow buttons.

2. Click OK to apply the selected field order.

DFdiscover 5.11.0 Acceptance Test Manual Page 54 of 313



3. Click [ ] to the left of 10-Death Report in the Plates-Modules-Fields list to collapse all plate 10 - Death Report modules.

Use copy and paste to create repeating module and field references on a plate

1. Click 11 - Weekly Patient Diary to make it the active plate. Scroll to view all module and field references on the plate.

2. Click [ ] to the left of 11-Weekly Patient Diary to expand the list of modules defined on the current plate. Choose Diary[6] from the list.
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3. Click Copy from the Module options.

4. Click Paste  from the Module options.

5. In the Paste Module fields dialog specify the substitution shown, which modifies the Alias and Description fields.

6. Click OK in the Paste Module fields dialog to perform the paste operation.

7. With the block of fields still highlighted, use the mouse to drag the block of field reference widgets and position them over top of their respective field outlines on the plate
background. Click anywhere on the plate background to release the pasted block.
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8. One by one select each Diary[7] field reference widget. Examine the Field Properties window for each and confirm that the Alias and Description properties contain the correct
substitution character of 7.

9. Select File  > Save [Required] . Click History . The setup change history is displayed.

10. Save the DFsetup history as module3_setuphistory.xlsx by clicking Save As… > Save. Open the saved .xlsx file and verify that its contents match the DFsetup - History output
before closing the history dialog by clicking X.

Create user-defined query category codes

1. Select View > Query Category Map.
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2. Click Add. The Code field is auto-filled with a value of 30. Press Tab to advance to the Label field. Enter Test for the Label field. Select Yes from the Auto-Resolve drop-down.
Set Sort Order to 5.

3. Click Add. The Code field is auto-filled with a value of 31. Without altering the code number, enter Monitor for the Label field. Select Yes from the Auto-Resolve drop-down. Set
Sort Order to 3.
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4. Click Add. Without altering the code number, enter Clinical QC for the Label field. Select No from the Auto-Resolve drop-down. Set Sort Order to 10.

5. Click Save followed by Done to close the dialog.

6. Select File  > Save [Required]  to save all modifications. Click Save in the warning dialog. Select File  > Exit  to close DFsetup.

Submit a copy of the newly defined Plate 11 into the study database and retrieve the page in DFexplore Image View

1. To complete the remainder of Module 3. Study Setup, the Control Panel is needed. Start the Control Panel as datafax as described in Module 1 (Installation & Initialization).
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2. Click Send ID 99006 to email a copy of ID99006.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.

NOTE: Save the ID99006.pdf file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user accounts
and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

3. Start DFsend and login as user site_monitor, as described in “How to start DFsend”.

4. Click Add. From the Select PDF Files file selection dialog, locate the previously saved ID99006.pdf file. Select the file and click Open.

NOTE: Documents can also be added by dragging-and-dropping the desired PDF files from a local file folder into the list area.

5. Click Send. In Verify Password dialog, enter site_monitor in the Username field and the previously assigned password in the Password field. Click OK.

6. In the resulting Send PDFs to DFdiscover dialog, confirm 1 success and 0 failure are shown. Click OK.
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7. Click Show Log to review the DFsend transmission history.

8. Select File  > Exit .

NOTE: Wait 2-3 minutes prior to proceeding to DFexplore.

9. Start DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”.

10. Select View > Image.

11. Do not change any settings in the Automatic Retrieval dialog, click OK to retrieve the image.
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12. Select Plate  > Show Field Properties  to display a listing of properties for all fields on the current page. Locate field numbers 46 to 51 that were created in Use copy and paste to
create repeating module and field references on a plate.. Verify the settings and click OK.

Enter and save all data on the submitted plate 11

1. Upon retrieval of plate 11-Weekly Patient Diary, the cursor is on the Study Week # field. Enter the Study Week # value as it appears on the CRF image. Note that a prefix of 2 is
hardcoded in the Study Week # field so that the resulting value will appear as 201. Press Tab to advance to the Patient Number field.

2. Enter the Patient Number as it appears on the CRF image. Press Tab to move to the Patient Initials field. Enter ANK as per the CRF image and press Tab to advance to the
next field.
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3. Starting with the Check this box... field, enter all data for 11-Weekly Diary Report as it appears on the CRF image in the lower half of the split-screen window. Press Tab to
move from field to field until field 6. My blood pressure today is the current field. Leave the field blank as per the CRF image and press Tab. The Add Query dialog is presented.

NOTE: During document submission, the ICR may fail on one or more of the fields on the Plate 11-Weekly Patient Diary page. You will need to enter values into those fields
that have been missed or misread by the ICR. To correct VAS scales, make the desired VAS scale the current field on the data record. Locate the corresponding VAS scale
on the CRF image. Using the left mouse button, select the leftmost end of the scale, followed by the intersection point, and then the rightmost end of the scale on the CRF
image. Specifically VAS scale item #4 requires modification from 70 to 71.

4. Click Cancel  in the Add Query dialog to close the dialog. The 2nd blood pressure field (diastolic) gets the focus. Leave the field blank as per the CRF image and Tab off the field.
Again, click Cancel  in the resulting Add Query dialog.

DFdiscover 5.11.0 Acceptance Test Manual Page 63 of 313



5. Enter the remaining fields on Plate 11-Weekly Patient Diary as per the CRF image. Once a value has been entered in the last VAS field (7. My energy level today), press Tab.
This makes the save buttons active at the bottom of the data record.

6. With the focus on the save buttons, click Final  to save the record to the database with the status Final.

7. Select File  > Exit  to close DFexplore.

End Module 3. Study Setup

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click End to confirm successful completion of Module 3. Study Setup.

Module 4. eCRF Creation for DFdiscover

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Client Tools Used: DFATK, DFexplore, DFsetup

Purpose: This module tests the creation of eCRF plates in DFsetup, data entry into eCRF plates in DFexplore, as well as user preferences unique to eCRF plates in DFexplore.

Tests & Requirements

1. eCRF creation in DFsetup.

2. eCRF background color preferences.

3. Entering eCRF data.

Estimate of Time Required: 20 Minutes

Introduction

This module utilizes Electronic case report forms (eCRFs) which you will create using DFsetup without a PostScript® or PDF file. eCRFs do not contain barcodes and are therefore
only suitable for entry via EDC.

Begin Module 4. eCRF Creation for DFdiscover

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 4. eCRF Creation  followed by Begin  to begin this module.

3. This module requires user data_manager to have exclusive access to the 254 Acceptance Test Study database. The Control Panel must be closed. Click Exit .

eCRF creation in DFsetup
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1. Start DFsetup, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”

2. Choose Exclusive Access and click OK. Exclusive Access allows you to create and modify plates, styles and fields, and to define all setup configuration files.

NOTE: The main DFsetup window displays the last plate to be active in the user's previous DFsetup session. For this reason, you may see a different plate from what is
displayed in the above illustration.

3. Select Study > Add eCRF Plate . In the Add eCRF Plate dialog enter a New Plate Number of 21. Click OK.

4. In the Plate Properties set:

Label = Lab Results

eCRF = Yes

Sequence is = predefined

Triggers Early Termination = No

Layout = Portrait

Eligible for Signing When = Final

Click Apply .

5. Within Plates-Modules-Fields Module options Click Add. Check (enable) Keys, LB, LB1, LB2, LB3 modules, click OK.
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6. Double-click the Keys [1] module to expand the list of fields. Using your mouse, click and drag the SUBJID and PINIT fields onto the 21: Lab Results eCRF.

7. Click LB [1] module, drag the module onto the eCRF, select LBORRES_n, LBNRIND and LBCLSIG_c fields by holding Shift  and clicking on the fields. Select Field  > Group.
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8. Click LB1 [1] Module, drag the module onto the eCRF. Select Field  > Group.

9. Click LB2 [1] Module, drag the module onto the eCRF. Select Field  > Group.

10. Click LB3 [1] Module, drag the module onto the eCRF. Select Field  > Group.
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11. Select fields 10 through 21 by holding Shift  and clicking on the fields. Select Field  > Add/Edit Table .

12. In the Add/Edit Table dialog, specify 4 rows and 3 columns. Under Rows > headers, select Field Prompt from the dropdown. Click Update Table . In column 2, select show
coding label and specify width as 35%. In column 3, select show coding label. Under DFweb, select single column on phone and tablet. Click Apply  and Done.
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13. Select field 11 LBNRIND_WBC, in the Field Properties click Detail. Modify the column display from 3 columns to 2 columns. Click Apply . Perform the same actions for field 14
LBNRIND_RBC, field 17 LBNRIND_HGB and field 20 LBNRIND_MCHC.

14. Select File  > Save [Required] . Click History . The setup change history is displayed.

15. Save the DFsetup history as module4_setuphistory.xlsx by clicking Save As… > Save. Open the saved .xlsx file and verify that its contents match the DFsetup - History output
before closing the history dialog by clicking X.

16.  Select File  > Exit  to close DFsetup.

eCRF background color preferences

1.  Start DFexplore, login as user site_monitor and choose 254 Acceptance Test Study as described in “How to start DFexplore”.

2.  Click Site 99 - Hospital #99 > 99008 > 1: Baseline > 21: Lab Results to make it the active page.

NOTE: DFexplore stores previously defined user preferences. If site_monitor previously used DFexplore and modified user preferences, you may see a different background
than what is illustrated below.
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3. Select File  > Preferences, click Background Options to expand the preferences. Click Color then OK to apply the changes.

4. Select File  > Preferences > Data Window, within eCRF background color, click  to open the Select Color window.

5. Enter HTML:#07458e.
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6. Click OK to close the Select Color window, click OK to apply your color preferences.

Entering eCRF data

1. Click  within the Patient Initials field to display the field level help. Click [ ] to close the help dialog.

2. With subject 99008 21: Lab Results as the current eCRF, click Patient Initials. The initials are pre-filled as a result of the edit check SetInitdescribed in Module 8. Image Data
Entry. Set:

Collection Date = 27-SEP-2018

White Blood Cell = 18.8, Check (enable) Abnormal.

Red Blood Cell = 4.7, Check (enable) Normal

Hemoglobin = 18.5, Check (enable) Normal
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Mean Cell Hemoglobin Conc = 40.2, Check (enable) Normal

Click Final  to save the data record.

3. Select File  > Exit  to close DFexplore.

End Module 4. eCRF Creation for DFdiscover

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click End to confirm successful completion of Module 4. eCRF Creation.

Module 5. Custom Properties

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Client Tools Used: DFATK, DFexplore, DFsetup

Purpose: This module tests the definition of custom properties defined at the study, plate, module, and field level. It additionally tests the creation of custom list views and data export
from custom lists views involving custom properties.

Tests & Requirements

1. Defining Custom Properties in DFsetup.

2. Adding Global Custom Property values.

3. Adding Plate, Module and Variable level Custom Property values

4. Exporting Custom Properties in DFsetup.

5. Edit checks execution of Custom Properties.

6. Creating subject data lists and exporting data views.

7. DFexplore Database Definition Report exporting.

Estimate of Time Required: 30 Minutes

Begin Module 5. Custom Properties

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 5. Custom Properties  followed by Begin  to begin this module.

3. This module requires user data_manager to have exclusive access to the 254 Acceptance Test Study database, the Control Panel must be closed. Click Exit .

Defining Custom Properties in DFsetup
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1. Start DFsetup, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”.

2. Choose Exclusive Access and click OK. Exclusive Access allows you to create and modify plates, styles and fields, and to define all setup configuration files.

3. Select Study > Custom Properties .

4. Click DFSTUDY tab, followed by the empty Tag cell for DFSTUDY_USER1 to make it the active field.

5. Beginning with DFSTUDY_USER1 cell. Enter the Custom Properties for DFSTUDY as follows:

DFSTUDY_USER1 = TITLE

DFSTUDY_USER2 = SPONSOR

DFSTUDY_USER3 = PLANSUBJECTS

DFSTUDY_USER4 = TRIALPHASE

DFSTUDY_USER5 = TRIALTYPE

DFSTUDY_USER6 = LENGTH

DFSTUDY_USER7 = REGID

6. Click DFPLATE tab, followed by the empty Tag cell for DFPLATE_USER1. Enter the Custom Properties for DFPLATE as follows:

DFPLATE_USER1 = V1

DFPLATE_USER2 = V2
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7. Click DFMODULE tab, followed by the empty Tag cell for DFMODULE_USER1. Enter the Custom Properties for DFMODULE as follows:

DFMODULE_USER1 = XXTEST

DFMODULE_USER2 = XXTERM

DFMODULE_USER3 = XXTRT

DFMODULE_USER4 = XXCAT

DFMODULE_USER5 = XXSCAT

DFMODULE_USER6 = XXFAST

8. Click DFVAR tab, followed by the empty cell for DFVAR_USER1. Enter the Custom Properties for DFVAR as follows:

DFVAR_USER1 = EC_PLT_ENTER

DFVAR_USER2 = EC_FLD_ENTER

DFVAR_USER3 = EC_PLT_EXIT

DFVAR_USER4 = EC_FLD_EXIT
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9. Click Apply  > Done to apply the newly defined Custom Property values.

Adding Global Custom Property values

1. Select Study > Global Settings>. Click Custom tab.

2. In the Custom tab set the following Property Values:

TITLE = DFdiscover 2026 Acceptance Test Study

SPONSOR = Pharma 123 Inc.

PLANSUBJECTS = 100

TRIALPHASE = PHASE III TRIAL

TRIALTYPE = TREATMENT

LENGTH = 4 MONTHS

REGID = NCT00000001

Click OK to save and dismiss the dialog.

Adding Plate, Module and Variable level Custom Property values

1. Click 1 - Blood Pressure Screening Visits to make it the active page. Within the Plate Properties window click Custom tab.

2. Enter the Property Value tags as follows:

V1 = 1 October 2014
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V2 = 11 November 2014 - Corrected error in Eligibility Criteria item 6.

Click Apply .

3. Select View > Plates .

4. Within row 2 Patient Entry Form navigate to the V1 Property Value cell. Enter 1 October 2014. In the V2 cell enter 11 November 2014 - Updated randomization instructions..
Click Apply , Done.

5. From the Plates-Modules-Fields window double-click 2 - Patient Entry Form. Click Keys [1] to make the module active.

6. In the Module Properties window specify PTKEYS for the XXTEST Property Value. Click Apply .
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7. Double-click Randomization [1]. In the Module Properties window specify RANDCODE for the XXTEST Property Value. Click Apply .

8. Select Medication Code # field. Click Custom from the Field Properties window.

9. Enter [MissingQC] Response is required. in the EC_FLD_EXIT Property Value.
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10. Click Edit checks tab within the Field Properties window.

11. Enter MissingQC, sdv next to Field Exit, click Apply .

12. Click Weight (lbs) field, then Custom. Enter [WeightEquiv] Weight conversion. in the EC_FLD_EXIT Property Value. Click Apply .
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13. Select File  > Save [Required] . Click History . The setup change history is displayed.

1. Save the DFsetup history as module5_setuphistory.xlsx by clicking Save As… > Save. Open the saved .xlsx file and verify that its contents match the DFsetup - History output
before closing the history dialog by clicking X.

Exporting Custom Properties in DFsetup

1. Select File  > Export Setup > Excel .

2. Click Field Properties ... .

3. In the resulting dialog, click Select none.

4. Select Name, Alias, Description, EC_PLT_ENTER, EC_FLD_ENTER, EC_PLT_EXIT and EC_FLD_EXIT. Click OK.

5. Specify module5_setup.xlsx as the Output File name, enable (check) Open output file after export.. Click Export .
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6. In the exported Excel file open the Global Settings tab to view the newly defined Global Property tags.

7. Click 2 - Patient Entry Form to view the newly defined Plate Custom Property tags. Return to DFsetup.
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8. Select File  > Exit  to close DFsetup.

Edit checks execution of Custom Properties

1. Start DFexplore, login as data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”. Upon logging in a dfmessage edit check dialog is
displayed containing the DFsetup-Global Settings Custom property tags defined in “Defining Custom Properties in DFsetup.”. Click OK to close the dialog.

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. Select File  > Preferences, click Background Options to expand the preferences. Click Color then OK to apply the changes.

3. Select Select  > Change Mode & Level . Set:

Mode = Validate

Save level = 3 - Level 3

Check (enable) Enable edit checks.

Click OK.

4. Double-click Site 99 - Hospital #99 > 99010 > 1 : Baseline > 2 : Form 2.

5. Click anywhere on the page background to make the fields active. Press Tab to advance to the Medication Code # field.

6. Press Tab to exit the field and execute the sdv edit check.
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7. Click OK to add the edit check containing the Custom Property Value's added in “Defining Custom Properties in DFsetup.”.

8. Press Tab to advance through the remainder of the fields on the Patient Entry Form page. Verify that the Save information bar at the bottom of the screen indicates that the
saved page will be assigned a record level of 3. Click Incomplete .

Creating subject data lists and exporting data views

1. Select View > List .

2. Click 002 - Patient Entry Form.

3. Select Select  > Field Selection  to show the listing of all data fields and their metadata properties defined for the plate. In the Data Fields window, click  next to fields 7:SUBJID
, 10:EXREFID , 12:WTKG , 13:WTLB.

NOTE: Alternatively fields can also be added by dragging-and-dropping the desired fields from the Data Fields or Metadata Fields windows to the Display Fields window.

4. In the Metadata Fields window, click  next to field EC_FLD_EXIT to add the field to the Display Fields window. From the drop-down select 10:EXREFID, click and drag the
field to be below the 10:EXREFID - Medication Code # field.
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5. Return to the Metadata Fields window, click  next to field EC_FLD_EXIT to add the field to the Display Fields window. From the drop-down select 13:WTLB.

6. Click Done to apply the field selection criteria and close the dialog.
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7. Select File  > Export Data  to save the data to a local file. In the dialog, set:

Format = Excel

Check (enable) Include header as the first record in output file.

8. Click ...  next to Output File. Choose a directory in the file selection dialog, enter module5_data.xlsx as the filename, and click Save. Click Save to create/write the file and close
the dialog.

DFexplore Database Definition Report exporting

1. Select View > Reports .

2. Double-click DFdiscover Reports > Study Setup > Database Definition.

3. Click Run.

4. Select File  > Save Output as  > Excel .

5. Click ...  next to Output File. Choose a directory in the file selection dialog, enter module5_definitions.xlsx as the filename and click Save. Check (enable) Open output file after
export and click Save.

End Module 5. Custom Properties

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click End to confirm successful completion of Module 5. Custom Properties.

Module 6. Subject Alias

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Email address configured for site_monitor

Client Tools Used: DFATK, DFexplore, DFsetup, DFsend
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Purpose: This module tests the definition and use of subject alias maps and related options within DFdiscover, in both live data viewing and data export scenarios.

Tests & Requirements

1. Importing and Modifying Subject Alias Map using DFsetup.

2. Subject Alias Tracking (Reports).

3. Exporting Subject Alias data.

Estimate of Time Required: 20 Minutes

Begin Module 6. Subject Alias

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 6. Subject Alias  followed by Begin  to begin this module.

3. Click Send Subject Alias Map to email a copy of subject_alias_map.csv to data_manager. Clicking more than once will result in multiple files arriving to your email inbox.

NOTE: Save the subject_alias_map.csv file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user
accounts and assigning study permissions.” as a valid email address is required for data_manager to receive the module specific files.

1. This module requires user data_manager to have exclusive access to the 254 Acceptance Test Study database, the Control Panel must be closed. Click Exit .

Importing and Modifying Subject Alias Map using DFsetup

1. Start DFsetup, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”.

2. Choose Exclusive Access and click OK. Exclusive Access allows you to edit the Subject Alias Map.

3. Select View > Subject Alias Map.

4. Click Import . From the file selection dialog, locate the previously saved subject_alias_map.csv file.
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5. Select the file, click Open, then Save.

NOTE: Clicking Save triggers the initial import of the Subject Alias Map to be logged in DFsubjectaliasmap.log which leads to the output produced in “Subject Alias Tracking
(Reports).”.

6. Modify the following Alias definitions:

99002 from S254-09-9003 to S254-09-9002

99006 from S254-09-9006-@ANK to S254-09-9006

99007 from S254-09-9007-@KFC to S254-09-9007
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7. Click Save then Done to apply the modifications to the Subject Alias Map.

8. Select File  > Exit  to close DFsetup.

Creating Subjects using Subject Alias

1. Start DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”.

2. Double-click Site 99 - Hospital #99 to open the list of available subjects.

3. Select File  > Preferences. Check (enable) Use subject alias. Click OK. The Subject ID list now displays the Subject Alias Mapping as defined in DFsetup.
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4. Click Site 99 - Hospital #99 > S254-09-9008 > 1: Baseline > 21: Lab Results to make it the active page.

5. Select Subject  > New Subject . Set:

Subject Alias = S254-09-9011

Confirm Alias = S254-09-9011

Click OK.

6. The message This subject alias does not exist is displayed. Click Cancel  to dismiss the New Subject dialog.
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NOTE:All Subject Alias definitions are required to be defined within DFsetup. Users are unable to add new Subject Alias definitions within DFexplore.

7. Double-click S254-09-9012 then entry for 0 : Screening Visits to display the list of pages belonging to the visit. Page 1 : Form 1 becomes the active page. The data window
redraws with the plate background and related data entry fields.

8. Click anywhere on the plate background - this moves the mouse and keyboard focus to the data window.

9. Beginning at the Patient Number field, press Tab to advance to the Patient Initials. Enter the initials TVM Press Tab to advance to the Age field.

10. Beginning with the Age field set the following values:

Age = 44

Sex = Female

Race = African American

Screen 1 = 26/04/20

11. As outstanding required data fields exist on the page it must be saved to the database with a status of Incomplete. Click Incomplete .
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12. Select View > List . Select 001 - Blood Pressure Screening Visits.

13. Confirm an entry exists for S254-09-9012.

Subject Alias Tracking (Reports)

1. Select View > Reports  to switch to Reports View. In the reports list panel, double-click DFdiscover Reports followed by Subject Tracking. Highlight the report Subject Alias
Map. Click Run.

2. Click History of Subject Alias Report then Run.
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Exporting Subject Alias data

1. Select View > List .

2. Confirm that 001 - Blood Pressure Screening Visits is still the active plate.

3. Select File  > Export Data .

4. In Export Data dialog set:

Format = Excel

Check (Enable) Include header as the first record in the output file.

Check (enable) Open output file after export

5. Click Output File ... . In the file selection dialog, choose a directory in which to save the Excel file. Once a directory has been chosen, append the file name 
module6_dataexport.xlsx to the directory name. Click Save.
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6. After saving, the file module6_dataexport.xlsx opens. The SUBJID displays the Subject Aliases.

7. Return to DFexplore. Select View > Data .

8. Create a task record set by selecting Select  > By Data Fields . Set:

Mode = View

Plate = 21

9. Click Done then OK.
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10. Select File  > Save as PDF.

11. In the Selection Criteria panel,

Select (enable) Data and images followed by current task set

In the Save Options panel,

Check (enable) Data records and expand text fields for plates

Check (enable) Apply field color for completed plates

12. Click Output File ... . In the file selection dialog, choose a directory in which to save the PDF. Once a directory has been chosen, append the file name subjectalias.pdf to the
directory name. Click Save.

13. Complete the specification by clicking Save. There will be a busy pause while the PDF of completed data pages and their primary images is created.
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14. Locate and open the previously saved subjectalias.pdf file. Confirm the Patient Number fields within the PDF are identical to that shown in DFexplore Data View.

15. Select File  > Preferences. Uncheck (disable) Use subject alias. Click OK.

16. Select File  > Exit  to close DFexplore.

End Module 6. Subject Alias

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click End to confirm successful completion of Module 6. Subject Alias.

Module 7. EDC Data Entry

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Email address configured for site_monitor

Client Tools Used: DFATK, DFexplore

Purpose: This module performs tests relating to electronic data capturing (EDC), as well as related functions. Data will be entered manually interactively as well as test the operations
and use of tasks, queries, and marking/unmarking data as missed.

Tests & Requirements

1. Login to DFexplore and the Acceptance Test Study and confirm the list of sites, subjects and assessments in the record list window.

2. Enter and save new data using EDC data entry for Subject 99007.

3. Add reasons to explain entered data values.

4. Enter and save Plate 3, Subject 99007 as a pending record.

5. Mark and save unavailable data as missed. Unmark available data as missed.

6. Retrieve and modify existing data using a predefined task and save modifications to the database.

7. Confirm audit trail information for entered and modified data.

Estimate of Time Required: 20 minutes

Begin Module 7. EDC Data Entry

Every module uses DFATK and must be run as datafax.

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 7. EDC Data Entry  followed by Begin  to begin this module.

3. Click Send ID 99007 to email a copy of ID99007_module7.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.
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NOTE: Refer to “Creating user accounts and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

Wait 2-3 minutes prior to proceeding to DFexplore.

Login to DFexplore and inspect the list of sites, subjects and visits in the record list window

1. Start DFexplore, login as site_monitor and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Confirm that only Site 99 - Hospital #99 is available.

3. Double-click entry for Subject 99001 to select and open the subject binder. A list of available visits is displayed.

4. Double-click entry for the highlighted 1 : Baseline visit to display the list of pages belonging to the visit.

5. Close the subject binder for Subject 99001 by double-clicking Site 99 - Hospital #99 in the record list panel.

Enter and save new data using EDC data entry for Subject 99007

1. Using the paper CRFs that were printed or emailed at the beginning of this module (Step 2). Select Select  > Change Mode & Level  to set the working mode and data entry level.
In the dialog, set:

Mode = Validate

Save level = 1 - Level 1

Check Enable edit checks

Click OK.
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2. Double-click Site 99 - Hospital #99 entry in the record list panel. Double-click Subject 99007.

3. Double-click the 0 : Screening Visits entry to display all pages belonging to the visit.

4. 1 : Form 1 becomes the active page. The data window redraws with the plate background and related data entry fields.

5. Click anywhere on the plate background - this moves the mouse and keyboard focus to the data window.

6. Beginning at the Patient Number field, press Tab to advance to the Patient Initials. Enter the initials as they appear on the printed CRF. Press Tab to advance to the next field.

DFdiscover 5.11.0 Acceptance Test Manual Page 96 of 313



7. Continuing from the Age field, press Tab to advance through the fields individually. Enter all remaining data as it appears on the printed CRF. Although leading zeros may not
always appear on the paper CRF, be sure to enter leading zeros where necessary. After entering the Eligibility Criteria #6, press Tab to make the save buttons active.

8. As no data problems exist on the entered page, the page can be saved to the database with a Final status. Click Final .

Add reasons to explain entered data values

1. To open a new visit for Subject 99007, double-click the entry labeled 1 : Baseline in the record list panel.
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2. Click anywhere on the plate background - this moves the mouse and keyboard focus to the data window.

3. With Patient Number as the active field, attempt to edit the pre-filled value, note that this is not possible. Press Tab to advance to Patient Initials. The SetInit edit check executes
upon entry to the field. If the initials are available on the 1 : Form 1 (previously entered), they are brought forward and populate the Patient Initials field.

4. Press Tab to advance through each field and enter the data as it appears on the printed CRF, up to and including Weight (lbs). Press Tab to exit the Weight (lbs) field and
execute the WeightEquiv edit check. The WeightEquiv edit check calculates and enters the equivalent value in the blank Weight (kg) field.

NOTE: Ensure the Date of Birth is entered using the dd/mm/yyyy format.
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5. The HeightEquiv edit check is similar to the WeightEquiv edit check. If only one of the two height values are entered, the edit check calculates and enters the equivalent value for
the blank field. Press Tab to exit the Height (in) field and enter the value as it appears on the printed CRF (including leading zeros). Press Tab to exit the field.

6. Enter the value of the Pulse field as it appears on the printed CRF. Press Tab to advance to the Smoking Status field.

7. Select Field  Add Reason For Data Value  or click  in the Reason for Data Value window. In the resulting dialog, choose Approved from the pull-down list.

8. Enter the text Smoking Status data will be provided once contact has been made with the patient. for the Reason property. Click OK, press Tab to advance to the Exercise field.

9.  Select Field  > Add Reason For Data Value  or click  in the Reason for Data Value window. Choose Pending from the pull-down list.

DFdiscover 5.11.0 Acceptance Test Manual Page 99 of 313



10. Enter the text Exercise data will be provided once contact has been made with patient. for the Reason property. Click OK, press Tab to advance to the Date of First Study
Follow-up Visit field.

11. Enter the Date of First Study Follow-up Visit and press Tab to advance to the save field. Verify that Final  is highlighted. Do not save the page with this status as the Smoking
Status and Exercise fields have yet to be completed. Click Pending.

Enter and save Plate 3, Subject 99007 as a pending record

1. Subject 99007 3 : Form 3 becomes the current record. Click anywhere on the page background to make the fields active for entry.

2. Starting at the Patient Number field, press Tab to advance to the Patient Initials field. The SetInit edit check executes upon entry to the field.
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3. Continuing at Patient Initials, press Tab to advance through each field and enter the data as it appears on the printed CRF. The medical conditions that appear pre-printed on the
CRF page have been defined as constant values in the study setup. As a result, these fields cannot be edited. Press Tab to advance to the save buttons. As data for Major
Surgery is not yet complete, click Pending to save the page with status Pending.

Mark and save unavailable data as missed. Unmark available data as missed

1. Baseline 4 : Form 4, Pg 1 is now the active page. As no data is available for this page, Select Plate  > Set Page Missed.

2. In the dialog, choose Data not available value from the Reason pull-down list. Enter Medication information is missing from patient's chart. as the Detail.

3. Click OK to register the page as missed.

4. Double-click Subject 99005 in the record list. From the now open list of visits for that subject, double-click the 1 : Baseline visit.

5. All pages for that visit are displayed.

6. Choose 3 : Form 3. Select Plate  > Unset Page Missed.

7. Enter the text Patient's chart has been located and Medical History is available. in the Reason field. Click Save to unset 3: Form 3 as missed.
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8. Double-click Site 99 - Hospital #99 entry in the record list. This closes all open subject binders for Site 99 - Hospital #99.

Retrieve and modify existing data using a predefined task and save modifications to the database

1.  Select Select  > By Task  to view the list of predefined data entry and data management tasks.

2. Click Screening Data Review from the list, then Select  to load the task and its selection criteria. This task is used to review all screening plate 1s that exist at level 1 or 2 and
save them to level 3. Examine the lower left of the dialog to determine the number of records that match the task search criteria. Confirm that the number is 4.

3. Click OK to bring forward all records that match the task criteria.
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4. Beginning with the first task record for Subject 99001, press Tab to advance through all fields on the page, comparing their values to those on the CRF image in the image
window. When Eligibility Criteria #5 is the current field, Select Field  > Add Query  or click  in the Query window.

5. In the Add Query dialog, set:

Category = Monitor

Use = External

Status = New query

Type = Clarification

Detail enter We have not received this patient's informed consent form. Please send it by fax or email without delay.

DFdiscover 5.11.0 Acceptance Test Manual Page 103 of 313



6. Click OK to apply the query.

7. Press Tab to advance through the remaining fields on the page. Once all fields have been traversed, press Tab to make the save buttons active.

8. Click Incomplete  to save the current task record to the database at level 3.

9. Batch validate the remaining records in the task list to raise their level to level 3. Select Select  > Batch Validate . In the dialog, set:

Move record level to = 3 - Level 3

Choose All currently selected task records

Click Batch Validate .

10. Enter Username of site_monitor and the corresponding password in the verification dialog. Click OK to batch validate the task records to level 3 and dismiss the dialog.

11. Review the details in the summary dialog. Click OK to close the summary dialog and complete the batch validation operation.

Confirm audit trail information for entered and modified data

1. Return to Subject 99001 > 0 : Screening Visits > 1 : Form 1.

2.  Select Plate  > List History of All Changes on This Page  to display the current record's history. The default page history dialog is displayed.

DFdiscover 5.11.0 Acceptance Test Manual Page 104 of 313



3. Check (Enable) Auto Load and Detailed History to enable advanced plate history.

4. Save the DFexplore - Page History as module7-edc-history.xlsx by clicking Save As Excel…, check (enable) Open output file after export.,click Save. Open (if not already
opened) the saved .xlsx file and verify that its contents match the DFexplore - Page History output before closing the history dialog by clicking Close.

5.  Select File  > Exit  menu to close and exit DFexplore.

End Module 7. EDC Data Entry

Return to the DFATK application. Click End to confirm successful completion of Module 7. EDC Data Entry.

Module 8. Image Data Entry

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
data_coordinator : data_coordinator

Email address configured for site_monitor
(Optional) - SMS or email 2-factor authentication setup with data_coordinator

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFsend
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Purpose: This module tests automated data entry and image processing in DFexplore using data sent through DFsend. Multiple records are created and modified, image-only features
testing, batch validation of records, queries, and reasons are also tested during this module.

Tests & Requirements

1. Submit PDF images to DFexplore.

2. Login to DFexplore and confirm the receipt of new pages in the Status View.

3. Login to the Image Router and route a misidentified page to the Acceptance Test Study new record queue.

4. Login to DFexplore and confirm receipt of the routed page in the Status View.

5. Retrieve new images in DFexplore Image View.

6. Enter Plate 1 (Form 1) for Subject 99002.

7. Enter Plate 2 (Form 2) for Subject 99002.

8. Enter Plate 3 (Form 3) for Subject 99002.

9. Enter Plate 4 (Form 4) for Subject 99002.

10. Compare the resolutions between Standard Definition (SD) and High Definition (HD).

11. Edit an existing query.

12. Delete an existing query.

13. Change data and record a reason for data change.

14. Batch validate all opened pages for Subject 99002 to level 2.

15. Confirm the status of entered pages in Status View.

Estimate of Time Required: 30 Minutes

Begin Module 8. Image Data Entry

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 8. Image Data Entry  followed by Begin  to begin this module.

Send PDF images to DFexplore

1. Click Send ID 99002 to email a copy of ID99002.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.

NOTE: Save the ID99002.pdf file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user accounts and
assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

2. Start DFsend as described in “How to start DFsend”.

3. Click Add. From the Select PDF Files file selection dialog. Locate the previously saved ID99002.pdf file. Select the file. Click Open.

NOTE: Documents can also be added by dragging-and-dropping the desired PDF files from a local file folder directly into the list area.

4. Click Send. In Verify Password dialog, enter site_monitor in the Username field and the previously assigned password in the Password field. Click OK.
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5. In the resulting Send PDFs to DFdiscover dialog, confirm 1 success and 0 failure are shown. Click OK.

6. Click Show Log to review the DFsend transmission history.

7. Select File  > Exit .

NOTE: Wait 2-3 minutes prior to proceeding to DFexplore.

Login to DFexplore and confirm the receipt of new pages in the Status View

1. Start DFexplore and login as data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. Select View > Status . Examine the count displayed for Images awaiting review in Image Queue.
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NOTE: Although 13 records were submitted, only 12 will be awaiting validation. The first page in the document has an unreadable barcode. As the barcode could not be
identified for the page, it has been routed to the Image Router instead of to 254 Acceptance Test Study.

3. Select File  > Close Study  to return to the login dialog and list of available studies.

Login to the Image Router and route a misidentified page to the Acceptance Test Study new record queue

1. In the DFexplore login dialog, click Image Router  to open the Image Router.

2. Locate the CRF for Subject Number 99002, Plate 1, Sequence 0 (Form 1), and select the page from the list of images in the CRF ID window.

NOTE: Any pages that have been received and which DFdiscover could not identify as CRFs for any of the studies registered at your site, will be found in the Image Router.
If there are more pages than those added by execution of the DFATK, you may need to locate the 254 Acceptance Test Study page in the listing of images.

3. Select Action  > Rotate/Shift/Identify  to correctly identify the CRF for Subject 99002, Plate 1, Sequence 0.
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4. Click leftmost end of the horizontal barcode line. Drag the cross-hairs across the solid barcode line then click rightmost end of the line.

5. Select 254 - Acceptance Test Study from the Study drop-down list. Enter Plate and Visit numbers, as illustrated. Click Identify  to identify the record.

6. Select File  > Close Image Router  to exit the Image Router and return to the DFexplore login dialog.

Login to DFexplore and confirm receipt of the routed page in the Status View

1. Choose 254 Acceptance Test Study and click Continue. If the list of studies closes before a selection is made you will need to log back into DFexplore by re-entering the
Username and Password for user data_coordinator.

2. Select View > Status  to examine the count displayed for Images awaiting review in the Image Queue. This count has increased by 1 as a result of a misidentified page being
routed.

Retrieve new images in DFexplore Image View

1. Select View > Image. In the Automatic Retrieval dialog,

Set Save level = 1 - Level 1

Check (enable) Enable Edit Checks

Select = document

By Age = oldest

Quantity __ documents = 10
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Check (enable) Repeat

2. Click OK in the Automatic Retrieval dialog to bring forward all new images awaiting data entry.

Enter Plate 1 (Form 1) for Subject 99002

1. With the first page of BLOOD PRESSURE SCREENING VISITS for Subject 99002 displayed, make the page active for data entry by clicking anywhere on the page background
using the mouse.

NOTE: In your normal image entry process, you must always pay careful attention to the accuracy of the ICR data. You will need to do the same here. It is possible that the
new pages contain ICR errors that you will need to correct during entry. In particular, it is important that you correct any key fields (visit and/or subject numbers) that may have
been misread as these are critical to the identification and storage of the data. Note that the ICR data records on your screen may not match exactly those shown in the
examples throughout this module.

2. Correctly enter Patient Number and Patient Initials as per the CRF image. Press Tab to advance to the Age field.

3. The MissingQC edit check is programmed to pop up a Query note if any of the following fields are left blank: Age, Sex, Screen 1 Date and all Screen 1 blood pressure readings.
Test this edit check on the Age field by making this field blank. Press Tab to exit the Age field. When the Add Query window pops up, click Cancel  to ignore and return to
complete the field as per the CRF image, before proceeding to the next field.
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4. Enter the Sex and Race fields as they appear on the CRF image. Press Tab to advance to the Screen 1 date field and enter its value 05/01/16 followed by all blood pressure
readings for Screen 1 date.

5. The ScreenDates edit check is executed on exit from the Screen 2 Date field. It checks that the Screen 2 Date follows the Screen 1 Date by at least one day. Enter a Screen 2
Date of 04/01/16, which precedes the Screen 1 Date of 05/01/16, then press Tab to exit the field. After verifying the message in the confirmation dialog, click OK.

6. Return to the Screen 2 date field and enter the date and all Screen 2 blood pressure values as they appears on the CRF image.

7. Step 1 to Step 6 test the entry of specific data fields. Any field that has not been correctly entered (by you or the DFdiscover ICR) is now completed by entering the values as they
appear on the CRF image. After entering the last data field Eligibility Criteria #6, press Tab to exit the field to make the Save buttons at the bottom of the data entry window
active.

8. As no data problems exist on the entered page, the page can be saved to the database with a status of Final. Do this by clicking Final  with the mouse or by pressing the space
bar.

Enter Plate 2 (Form 2) for Subject 99002
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1. Correctly enter Patient Number per the CRF image. Press Tab to advance to the Patient Initials field. The SetInitedit check automatically completes the Patient Initials field if
the initials are available on the Screening Form (Plate 1).

NOTE: The Patient Number must be entered correctly on the data record for the SetInitedit check to execute. When an edit check changes a field's value, the changed field
will automatically be assigned a default reason and the field's color will change to green to show that an approved reason exists.

2. Correctly enter the Entry Date, Medication Code # values per the CRF image and Date of Birth in dd/mm/yyyy format. The CheckAge edit check calculates the Subject's age
from the Entry Date and Date of Birth fields, and compares this value with the value entered for Age on Plate 1. If these values disagree, an error message is displayed. Press
Tab to exit Date of Birth field to execute the CheckAge edit check.

3. Click OK in the error message window to bring forward the query dialog. Click OK in the query dialog to attach a query to the Date of Birth field.

4. Press Tab to advance to the Weight (kg) field. Do not enter a value as the corresponding field on the CRF image is blank. Continue on to the Weight (lbs) field and enter the
value that appears on the CRF image. If only one of the 2 weight fields are completed, the WeightEquiv edit check calculates and enters the equivalent value for the blank Weight
field. Press Tab to exit the Weight (lbs) field executing the WeightEquiv edit check.

5. Press Tab to advance to the Height (cm) field. Do not enter a value as the corresponding field on the CRF image is blank. Continue on to the Height (in) field and enter the value
that appears on the CRF image. If only one of the 2 height fields is completed, the HeightEquiv edit check calculates and enters the equivalent value for the blank Height field.
Press Tab to exit the Height (in) field executing the HeightEquiv edit check.

6. Step 1 to Step 5 test specific data fields. Any field that has not been entered (by you or the DFdiscover ICR) is now completed by entering the values as they appear on the CRF
image. After entering the last data field (Date of First Study Follow-up Visit), press Tab to exit the field to make the save buttons active.

7. As an outstanding query exists on the Date of Birth field, the page must be saved to the database with a status of Incomplete. Click Incomplete  with the mouse or by pressing
the space bar.
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NOTE: If outstanding queries and/or illegal values exist on a data record, DFdiscover will never allow the record to be assigned the status Final.

Enter Plate 3 (Form 3) for Subject 99002

1. Plate 3 has been incorrectly identified by DFdiscover as Plate 7 (the data record and CRF image do not match). Before data entry can begin, the record must first be correctly
identified by correcting the barcode. To do this, Select Plate  > Change Barcode.

2. In the Change Barcode dialog, set the Page to 003. Do this by clicking ...  to display a listing of all defined study plates, then select the entry 003 - Medical History from the list.
Click OK to close the dialog.

3. Set the Visit by clicking ...  to display a listing of all defined study visits, select 1 - Baseline from the list. Click OK to close the visit listing dialog. Click OK.
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4. Confirm the change to the barcode by clicking OK in the warning dialog.

NOTE: When a barcode is changed, all data fields on the data record (top half of the screen), will be blanked of their previous ICR values as these are no longer correct. The
correct values must be entered manually.

5. Correctly enter Patient Number as per the CRF image. Press Tab to advance to the Patient Initials executing the SetInitedit check as in “Enter Plate 2 (Form 2) for Subject
99002.”.

6. Press Tab to advance to the 1. Hypertension No/Yes field and check the response indicated on the CRF image. Press Tab to advance to the Duration, Years field and leave it
blank as per the CRF image. Press Tab to advance to the Duration, Months field and enter the number of months 06 as they appear on the CRF image. The MedHxDuredit
check completes the Duration fields by entering zeros into the Years field if only Months are given, and zeros into the Months field if only Years are given. Press Tab to exit the
Duration, Months field to execute the MedHxDuredit check.

7. Enter the remaining values for 1. Hypertension and enter all fields for 2. Atrial Fibrillation. Press Tab to advance to the first No/Yes field for 3. Other Cardiac EG Arrhythmia.

8. A skip has been set on the No/Yes fields for each medical history item such that if "No" is selected, the remaining fields for that medical history item are skipped and the user is
taken to the next item. Enter the correct values for medical history items 3. to 6. to execute the skip.

9. Enter all values for 7. Diabetes up to and including the Currently on Treatment field. Press Tab to advance to the Resolved and/or Controlled field which has been left blank
on the CRF image. Select Field  > Add Query  or click . In the Add Query dialog, set:

Category = Missing

Status = New query

Use = External

Type = Correction

Click OK.
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NOTE: DFexplore attempts to infer the Category, Status, Use and Type information when a query is being added. It is important to verify the query settings and correct
them if necessary, before applying the query to the data field.

10. For medical history items 8. to 11., enter the appropriate values per the CRF image. Press Tab to advance to the text field for the first 12. Major surgery (specify) to make it the
current field.

11. Enter the correct values in all fields for the first Major Surgery. Input hip replacement up to and including the How long ago response. An edit check, CalcDays, attempts to read
the How long ago text field to calculate the number of days prior to study entry that surgery occurred. The calculated value automatically populates the hidden field to the right of
these text fields. Pressing Tab off the How long ago field executes CalcDaysedit check.

12. Press Tab to advance to the 2nd Major Surgery item. Input endarterectomy and perform the same steps as in Step 11. Enter the date 06/07/1995 for July 6/95 in the How long
ago field.
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13. Step 5 to Step 12 test specific data fields. Any field that has not been entered (by you or the DFdiscover ICR) is now completed by entering the values as they appear on the CRF
image. After entering the last data field, press Tab off the field to make the save buttons at the bottom of the data entry window active.

14. Click Incomplete  with the mouse or by pressing the space bar. As an outstanding query exists on the 7. Diabetes, Resolved and/or Controlled field, the page must be saved to
the database with a status of Incomplete.

Enter Plate 4 (Form 4) for Subject 99002

1. Correctly enter Patient Number, Patient Initials and both Medications Page Number fields per the CRF image. As for the previous pages, the SetInitedit check automatically
completes the Patient Initials field. Press Tab to advance to the 1. Drug Name field.

2. In 1. Drug Name type the text Inderal as it appears on the CRF image. The Drug Name fields have been mapped to lower case in their setup definitions. Therefore, all entered
text will appear as lower case regardless of the case typed.

3. Enter all data for the first 2 drugs (Inderal and ASA) as it appears on the CRF image. The CalcDaysedit check that is present on Plate 3 (Medical History) is also present on the
Start Date or Duration of Use fields. During data entry, confirm that the hidden fields contain the calculated values as shown below.
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4. Press Tab to advance to the 3. Drug Name field. An edit check, DrugLookup, has been programmed to match the entered drug text with an entry in a lookup table. Enter the 3rd
drug name 222s and press Tab to exit the field executing DrugLookup edit check. (If an entry can not be found in the lookup table, a search dialog is displayed.)

5. In the search dialog,

Check (enable) Acronym

Uncheck (disable) Result

Input (enter) 222 in the Search terms

Click Find. Once the match asa with codeine (222) is found, click OK.
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6. Enter the remaining values for the 3rd drug field and press Tab to advance to 4. Drug Name field. A skip has been set on each of the Drug Name fields such that if the field is
blank, the remaining fields for that drug are skipped. Press Tab to advance through the remaining Drug name fields, and leave them blank as per the CRF image, to execute the
skip.

7. Step 1 to Step 6 test specific data fields. Any field that has not been entered (by you or the DFdiscover ICR) is now completed by entering the values as they appear on the CRF
image. After entering the last data field, press Tab to exit the field and make the save buttons at the bottom of the data entry window active.

8. As no data problems exist on the entered page, the page can be saved to the database with a status of Final. Do this by clicking Final  or by pressing the space bar.

Compare the resolutions between Standard Definition (SD) and High Definition (HD)

1. With MONTHLY FOLLOW-UP FORM for subject 99002 as the active page, verify that the  button is shown at the bottom-right corner of the main data entry screen. Examine the
quality of the SD image.

NOTE: DFexplore remembers this setting from the last use. If module 8. Image Data Entry was previously executed, the button will already show . In this case, continue
with “Edit an existing query.”.

2. Five hidden buttons , , ,  and  can be displayed and identified at the bottom-left corner of the main data entry screen. To show these buttons, place the mouse
anywhere on the image. To identify each button, hover the mouse over top of it.

3. Click  until the image reaches its maximum size. Examine the enlarged SD image.

4. Click  at the bottom-right corner of the data entry screen, switching the label to . Confirm that the background color of  is green as shown.
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5. Examine the HD image. Verify that the HD image is clearly visible and there is a noticeable difference between the HD image and the previous SD image.

Edit an existing query

1. Select View > Queries  to change from Image View to Queries View.

2. Click OK in the confirmation dialog to release the Image View records and open Queries View.

3. In the Queries View site list, double-click icon Site 99 - Hospital #99 to list the queries for that site. Select Show > Outstanding Queries  to display all outstanding/unresolved
queries for Site 99 - Hospital #99.

4. Locate the query for Subject 99002, Baseline : Form 3. This is the query that was added to the field 7. Diabetes, Resolved and/or Controlled in “Enter Plate 3 (Form 3) for
Subject 99002.”. Double-click the query to be taken directly to the page and queried field.
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5. Select Select  > Change Mode & Level . In the dialog, set:

Mode = Validate

Save level = 2 - Level 2

Check (enable) Enable edit checks

Click OK to apply the changes.

6. Select Field  > Edit Query  or click . In the dialog, set:

Status = Resolved NA from the pull-down list.

Enter The Subject is currently on treatment. in the Detail field

Click OK to apply the edits.

Delete an existing query

1. The queried field 7. Diabetes, Resolved and/or Controlled maintains the focus. If not, make it the current field. Select Field  > Delete Query  or click .
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2. Click OK to perform the query deletion.

3. Click Delete  in the confirmation dialog.

Change data and record a reason for data change

1. With 3:Form 3, Medical History as the current page, press Tab to advance to 11. Other (specify). Change the existing data value of arthritis to arthritis (knees) and Select Field
> Add Reason for Data Value  or click .

2. In the Reason for Data Value dialog, confirm that the Old Value and New Value fields display the data values shown. Choose Pending from the status list to change the reason's
Status to Pending. Enter the text Location of arthritis (knees) was provided verbally by the site. in the Reason field. Click OK to close the dialog and save the reason for data
change to the database. Press Tab to advance to the next field.
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3. Press Tab to advance through the remaining fields on the Medical History page until the save buttons at the bottom of the screen become active. Click Final  to save the modified
page to the database at level 2.

Batch validate all opened pages for Subject 99002 to level 2

1. Still working at Save Level 2 with the pages previously opened for Subject 99002, Select Select  > Batch Validate . Confirmed credentials are needed to complete this action.

2. Choose 2-Level 2 from the Move record level to pull-down list. Choose All open pages for current subject. Click Batch Validate . Confirmed credentials are needed to
complete this action.

3. Enter data_coordinator as the Username and the previously assigned password. Click OK to batch validate the selected records.

4. Click OK to close the summary dialog and complete the batch validation operation.

Confirm the status of entered pages in Status View

1. Select View > Status  to close Image view and release all pages in the record list and open Status view.

2. Confirm that the number of images awaiting review is now 9.
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3. Select File  > Exit  to close and exit DFexplore.

End Module 8. Image Data Entry

Return to the DFATK application. Click End to confirm successful completion of Module 8. Image Data Entry.

Module 9. User-defined Query Category Types

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
data_coordinator : data_coordinator

(Optional) - SMS or email 2-factor authentication setup with data_coordinator

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFsetup

Purpose: This module tests the enabling and user-defined queries in DFdiscover, as well as confirming the correct functioning and data integrity of custom query categories whose
definitions are removed after a query is applied.

Tests & Requirements

1. Retrieve an existing data record in DFexplore.

2. Apply a user-defined Category query.

3. Add a reason for Data Value to explain entered data.

4. Edit an existing query.

5. Delete a user-defined Query Category that is used by an existing query.

6. Delete a user-defined Category query.

Estimate of Time Required: 30 Minutes

Begin Module 9. User-defined Query Category Types

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 9. User-defined Query Category  followed by Begin  to begin this module.

Retrieve an existing data record in DFexplore

1. Start DFexplore, login as data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you will may to wait for a 1-time code to arrive at the phone number as defined in DFadmin.
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2. Select Select  > Change Mode & Level . Within the dialog, set:

Mode = Validate

Save level = 1 - Level 1

Check (enable) Enable edit checks

Click OK to apply these settings.

3. Double-click the folder for Site 99 and then double-click subject 99007 to open the subject binder. Locate 0: Screening Visits in the list of visits for subject 99007, and double-
click this entry to open task records for this subject. Press Tab to advance through the fields until Screen 2, Reading 1 systolic blood pressure becomes the current field.

Apply a user-defined Category query

1. With Screen 2, Reading 1 systolic blood pressure as the current field, select Field  > Add Query  or click [ ]to open the Add Query dialog. In the dialog, confirm that Monitor,
Test and Clinical QC are present in the Category pull-down list. Set:

Category = Test

Use = External

Type = Clarification

Status = New query

Detail = This value is out of our reference range. Please review.
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2. Click OK to apply the query to the Screen 2, Reading 1 systolic blood pressure field. Note that the field becomes blue. Examine the details in the Query window that appears
near the bottom left of the screen.

3. Press Tab to advance through the remaining fields on the page without making any changes. Press Tab to advance to the save buttons at the bottom of the data screen. Click
Incomplete  to save the page.

 Add a reason for Data Value to explain entered data

1. With BLOOD PRESSURE SCREENING VISITS as the active page, press Tab to advance through the fields until Screen 2, Reading 1 systolic blood pressure becomes the
current field. Select Field  > Add Reason For Data Value  or click [ ] to open Reason for Data Value dialog.

2. In the Reason field, enter The value 180 mmHg for systolic blood pressure has been confirmed. Clinical significance is being evaluated..
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3. Click OK to apply the reason to the Screen 2, Reading 1 systolic blood pressure field. Note that this field is the current field and the field becomes orange. Examine the details
in the Reason window that appears near the bottom left of the screen.

NOTE: If a user-defined Category Code is defined with auto-resolution in DFsetup, adding a reason to a field that has a query with such a category will change the query
status from outstanding to pending.

4. From the Screen 2, Reading 1 systolic blood pressure field, press Tab to advance through the remaining fields on the page without making any changes. Press Tab to
advance to the Save buttons at the bottom of the data screen to make them active. Click Final  to save the page.

Edit an existing query

1. Select View > Queries . Select Show > Pending Queries  to display all pending queries for Site 99 - Hospital #99.

2. Double-click entry for subject 99007, Screening Visits: Form 1 to be taken directly to the page and the pending field.

3. In Data View, Select Select  > Change Mode & Level . In the dialog, set:

Mode = Validate

Save level = 2 - Level 2

Check Enable edit checks

4. Click OK to apply and close the Change Mode & Level dialog. The current field is Screen 2, Reading 1 systolic blood pressure.

5. Select Field  > Edit Query  or click [ ]. In the dialog,

Set Use as Internal

Delete the existing text in the Detail field

Enter See Reason for Data Value. in the Note field
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Click OK to apply the edits.

6. From the Screen 2, Reading 1 systolic blood pressure field, press Tab to advance through the remaining fields on the page without making any changes. Press Tab to
advance to the save buttons at the bottom of the data screen to make them active. Click Final .

7. Select File  > Exit  to close and exit DFexplore.

Delete a user-defined Query Category that is used by an existing query

1. Start DFsetup, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”.

2. Choose Normal Access and click OK.

3. Select View > Query Category Map.
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4. In the Query Category Map dialog, locate the entry that has Code 30 and Label Test. Click the entry to highlight it, then click Delete . Click Save and Done.

5. Select File  > Exit  to close DFsetup.

Delete a user-defined Category query

1. Start DFexplore, login as data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. Double-click the folder for Site 99 - Hospital #99 to display a list of available subjects. Double-click subject entry 99007 in the subject list to open the subject binder. Locate the 0:
Screening Visits visit for subject 99007 and double-click this entry. Press Tab to advance through the fields until Screen 2, Reading 1 systolic blood pressure becomes the
current field. Examine the details in the Query window. If an existing query contains a user-defined category, and that category definition has been removed from DFsetup, the
query in DFexplore displays Query Category Code 30.

3. Select Field  > Delete Query  or click [ ].

4. Click OK to perform the query deletion.
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5. Click Delete  in the confirmation dialog.

6. Press Tab to advance through the remaining fields on the Blood Pressure Screening Visits page until the save buttons at the bottom of the screen become active. Click Final .

7. Click File  > Exit  to exit DFexplore.

 End Module 9. User-defined Query Category Types

Return to the DFATK application. Click End to confirm successful completion of Module 9. User-defined Query Category.

Module 10. Multiple Queries Per Field

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
data_coordinator : data_coordinator

Email address configured for site_monitor
(Optional) - SMS or email 2-factor authentication setup with data_coordinator

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFsetup, DFsend

Purpose: This module tests the enabling of multiple queries per field options in DFsetup allowing for a single field to have more than one query applied to it at a time, the restructuring
of the Study to allow for this option, and subsequent use of multiple queries within a single field. General query functions are tested, including creation, modification, deletion, and
replying to queries, as well query resolving.

Tests & Requirements

1. Submit PDF images to DFdiscover.

2. Enable multiple queries per field in DFsetup.

3. Retrieve submitted CRF in DFexplore Image View.

4. Enter Plate 9 for Subject 99002.

5. Apply multiple queries to a field.

6. Select and edit an existing query in a field that has multiple queries.
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7. Select and reply to an existing query in a field that has multiple queries.

8. Select and delete an existing query in a field that has multiple queries.

Estimate of Time Required: 30 Minutes

Begin Module 10. Multiple Queries Per Field

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 10. Multiple Queries Per Field  followed by Begin  to begin this module.

3. Click Send ID 99002 to email a copy of ID99002-module10.pdf to site_monitor. Clicking more than once will result in multiple files arriving to your email inbox.

NOTE: Save the ID99002-module10.pdf file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user
accounts and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

4. The following steps require exclusive access to the 254 Acceptance Test Study database. To facilitate exclusive access, close DFATK by clicking Exit .

Submit PDF images to DFdiscover

1. Start DFsend, login as user site_monitor as described in “How to start DFsend”.

2. Click Add. From the Select PDF Files file selection dialog, locate the previously saved ID99002-module10.pdf file. Select the file, click Open.

3. Click Send, enter site_monitor in the Username field and the previously assigned password in the Password field. Click OK.

4. In the resulting Send PDFs to DFdiscover dialog, confirm 1 success and 0 failure are shown. Click OK.

5. Click Show Log to confirm successful transmission of the ID99002-module10.pdf file to DFdiscover.
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6. Select File  > Exit .

Enable multiple queries per field in DFsetup

1. Start DFsetup, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFsetup”.

2. Choose Developer Access in the Access mode dialog, click OK.

3. The main window for DFsetup is displayed. Select Study > Global Settings .

4. Click Global tab in the Global Settings dialog. Check (enable), if not already checked, Allow Multiple Queries per field. The warning message: This CANNOT be undone once
the Study Setup is saved is displayed.

DFdiscover 5.11.0 Acceptance Test Manual Page 131 of 313



5. Click OK to close the Global Settings dialog.

6. Select File  > Save [Required] , followed by File  > Exit .

Retrieve submitted CRF in DFexplore Image View

1. Start DFexplore, login as user data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. The main window for DFexplore is displayed. Select View > Image.

3. In the Automatic Retrieval dialog, set:

Save level = 1 - Level 1

Check (enable) Enable Edit Checks

Select = document

By Age = Oldest

Quantity __ documents = 10

Check (enable) Repeat

Confirm the settings.

Click OK.

4. The first image retrieved is the Adverse Event Report CRF.
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Enter Plate 9 for Subject 99002

1. The Adverse Event Report No. field is highlighted as the current field. Enter the value from the CRF image if it is not already correctly auto-filled. Press Tab to advance to the AE
Identifier field. The AESEQNUM2 edit check executes upon entry to the AE Identifier field. The data value in the field is updated.

2. Press Tab to advance to the Patient Number field.

3. Beginning at the Patient Number field, correctly enter the data per the CRF image, up to and including the Intensity field. Tabbing from the Intensity field, a user-defined edit
check executes and the dfaddqc: Severity dialog is displayed.
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4. Click OK to apply the edit check. The field becomes blue, and the next field Relationship to Study Drug becomes the current field.

5. Correctly enter each data field on the page per the CRF image, up to and including the Description field.

Do not enter any text in the Description field as the corresponding field on the CRF image is blank. Upon tabbing off this field, the dfaddqc: MissingQC dialog appears.

Confirm that Missing is displayed in the Category field.

6. Click OK. This applies the edit check to the Description field. The field becomes blue, and the AECOTERM becomes the current field.

7. From the AECOTERM field, press Tab through all remaining fields until the Investigator's Signature field becomes the current field.

Tabbing from the Investigator's Signature field, the DFlookup: investigators dialog appears. Highlight Dr. John Snow and click OK.
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8. Enter the Date field value. Press Tab to advance to the save status bar to make it active. Click Incomplete  to save the changes.

Apply multiple queries to a field

1. With the Adverse Event Report displayed as the current page, make the page active by clicking anywhere on the page background using the mouse. Press Tab to advance
through the fields until Description becomes the current field. Note that the Description field is blank and has an unresolved query with the category Missing (external,
correction). Enter the text Nausea, ??? and fever.

2. Select Field  > Add Query  or click . In the dialog, confirm Category type Missing is disabled. Set:

Category = Other

Use = External

Type = Correction

Status = New query

Detail = Please clarify the word after nausea. The description provided through email is 'Nausea, vamit and fever'. Do you mean Vomit instead?

NOTE: Multiple queries can be added to a single field, but each query must have a unique Query Category type. Therefore, a Category will be disabled if it has been
previously used on the same field where a new query is to be added.

3. Click OK to apply the query. Confirm that the Description field is the current field with the query count '2' displaying on the top left corner of the field widget, and the field becomes
blue.
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4. With the focus still on the Description field, examine the details in the Query window that appears at the bottom left corner of the main data entry screen.

5. Select Field  > Add Query  or click  to add the third query to the Description field. In the dialog, set:

Category = Monitor

Use = External

Type = Correction

Status = New query

Detail = Nausea and fever are two separate adverse events and should be reported in different CRFs. Please review.

6. Click OK to apply the query. Confirm that the Description field is the current field with the query count 3 displaying on the top left corner of the field widget, and the field becomes
blue.

7. With the focus still on the Description field, examine the details in the Query window that appears at the bottom left corner of the main data entry screen.

NOTE: The query list reflects the query sort order that has been defined by the user in DFsetupQuery Category Map.

8. Press Tab to exit the Description field, the DFlookup: aecodes window appears. Click Cancel  in the window to close the dialog. The next field AECOTERM becomes the current
field.

DFdiscover 5.11.0 Acceptance Test Manual Page 136 of 313



9. Press Tab to advance through the remaining fields on the page without making any changes. Press Tab to advance to the save buttons at the bottom of the data screen to make
them active. Click Incomplete .

Select and edit an existing query in a field that has multiple queries

1. With the Adverse Event Report page still active, Select View > Queries  to open the Queries View window. In the resulting confirmation dialog, click OK to release all Image
records. Select Show > All Queries . Double-click Site 99 - Hospital #99. Locate and confirm that the Queries window displays the three queries that have been applied to the AE
Description field for Subject 99002.

2. Select Show > Outstanding Queries . Locate and confirm that two unresolved queries with categories Other and Monitor on the AE Description field of Subject 99002 are
displayed.

DFdiscover 5.11.0 Acceptance Test Manual Page 137 of 313



3. Double-click entry containing the query category Other in the Description field of Subject 99002, Adverse Event 1 Page 1: Form 9, AE Report 011.

4. Select Select  > Change Mode & Level . In the dialog, set:

Mode = Validate

Save level = 2 - Level 2

Check (enable) Enable edit checks

Click OK to apply the changes.

5. Delete the text ??? in the description field and enter vomiting instead. Examine the query window. From the Query drop-down choose Other (external, correction) query in the
query list.

DFdiscover 5.11.0 Acceptance Test Manual Page 138 of 313



6. With the focus on the Other (external, correction) query Description field, select Field  > Edit Query , or click the  to open the dialog. set:

Select Pending from the Status pull-down.

Enter The correction was provided via email. in the Note field.

Click OK to apply the edits.

Select and reply to an existing query in a field that has multiple queries

1. Select Monitor (external correction) from the Query pull-down to make the query active.

2. Select Field  > Reply to Query  or click  to open the dialog. Enter Fever will be removed to a different Adverse Event Report form. in the New Reply field.

3. Click OK to close the dialog. Examine the information present in the Query window.

Select and delete an existing query in a field that has multiple queries

1. Choose Missing (external, correction) from the Query pull-down list. The query list in the query window displays the Missing (external, correction) query. Confirm that the first
query is defined with Category: Missing (external, correction) and a Status: Resolved corrected.
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2. Select Field  > Delete Query  or click  to open the Delete Query dialog.

3. Click OK to perform the query deletion.

4. Click Delete  in the Delete Query confirmation dialog. Confirm that the Description field remains as the active field and has the query count 2 displaying on the top left corner of
the field widget.

5. Press Tab to exit the Description field, and a DFlookup: aecodeswindow appears. Click Cancel  in the window to close the dialog. The next field AECOTERM becomes the
current field.

6. Press Tab to advance through the remaining fields on the Adverse Event Report page until the Incomplete  at the bottom of the screen becomes active. Click Incomplete  to save
the modified page.
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7. Select File  > Exit  to close and exit DFexplore.

End Module 10. Multiple Queries Per Field

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click End to confirm successful completion of Module 10. Multiple Queries Per Field.

Module 11. Data Review

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor

Email address configured for site_monitor

Client Tools Used: DFATK, DFexplore, DFsetup

Purpose: This module tests the processes of reviewing data in DFexplore, including queries and reasons, and validating data and queries to different levels. Included in this module is
the use of different data selection methods and data expressions in DFexplore, and the use of batch edit checks.

Tests & Requirements

1. Retrieve all data for Site 99 that exists at level 3.

2. Review and approve a pending reason for data value, and approve a selected query in a field that has multiple queries.

3. Review and move approved reasons for data values to a higher workflow level, and review queries in a field that has multiple queries.

4. Data review and add a query to inconsistent data.

5. Review and complete pending data for Subject 99007.

6. Confirm audit trail information for reviewed and modified data.

7. Run batch edit checks to verify data integrity.

8. Use a data expression to retrieve specific subject information.

9. Use cross-plate data criteria to retrieve specific subject information.

Estimate of Time Required: 20 Minutes

Begin Module 11. Data Review

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 11. Data Review followed by Begin  to begin this module.

3. Click Send ID 99007 to email a copy of ID99007_module11.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.

NOTE: Refer to “Creating user accounts and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

 Retrieve all data for Site 99 that exists at level 3

1. Start DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select Select  > By Data Fields  from the menubar to open the Select By Data Fields retrieval dialog. In the dialog, set:

Mode = Validate

Save level = 4 - Level 4

Search = Data

Level = 3

Check (enable) Enable edit checks
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3. Click Done. In the confirmation dialog, click OK to retrieve data records that match the criteria.

4. Double-click entry for Subject 99002 to open the subject binder.

Review and approve a pending reason for data value, and approve a selected query in a field that has multiple queries

1. 1: Form 1 (BLOOD PRESSURE SCREENING VISITS) for Subject 99002 is the active page. Press Tab to advance to the Sex field. Examine the information in the Reason for
Data Value window.

2. Select Field  > Approve Queries and Reasons . Examine the information in the dialog.
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3. Select Approved from the Status pull-down. Confirm that the approved reason shows .

4. Click Save and Done to close the dialog.

5. Do not make any other changes to the data on the current page and press Tab to advance to the save buttons. Click Final  to save the page and its reason at level 4.

6. Click 9: Form 9, AE Report 011.

7. Click anywhere on the page background to make the fields active. Press Tab to advance to the Description field. Examine the information displayed in this field and the
information in the corresponding Query window.

8. Select Field  > Approve Queries and Reasons . Select the Monitor query. Examine the information in the dialog.
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9. Select Resolved corrected from the Status in the Query section. Confirm that the CRF will be moved from level , and Status from Pending to Resolved corrected.

10. Click Save. The Approve Queries and Reasons dialog changes from displaying the query with category Monitor to displaying the query with category Other as shown. Click
Done.
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11. Press Tab to exit the Description field. Upon leaving the field, the DrugLookup edit check is executed and the DFlookup:AECODES dialog appears. Click Cancel .

12. Do not make any other changes to the data and press Tab to advance to the save buttons. Click Incomplete  to save the page at level 4.

Review and move approved reasons for data values to a higher workflow level, and review queries in a field that has
multiple queries

1. Double-click Subject 99002. Select entry for 2 : Form 2. Select Field  > Review Queries and Reasons  to review all queries and reasons that are present on the page.
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2. Working with the highlighted entry for Patient Initials, confirm that the Status is set to Approved and the level button displays . Click  to move the approved reason
from level 3 to level 4 without making any other modifications.

3. Select the 3rd Reason entry Weight (kg). Confirm that the Status is set to Approved and  is displayed. Click  to move the approved reason from level 3 to level 4
without making any other modifications.
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4. Select the 4th Reason entry Height (cm). Confirm that the Status is set to Approved and  is displayed. Click  to move the approved reason from level 3 to level 4
without making any other modifications.

5. Once each of the 3 approved reasons have been reviewed, click Done.

6. As an outstanding query remains on the Date of Birth field, click Incomplete  to save.

7. Continuing with the ADVERSE EVENT REPORT as the current page, click anywhere in the data entry screen to make the page active. Press Tab to advance though the fields
until the Description field becomes the current field. Select Field  > Review Queries and Reasons . Examine the information in the dialog.
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8. Click the second query with the Category type Monitor and a status of 4: External - Resolved corrected. Click Done to close the dialog.

9. Press Tab to exit the Description field. Upon leaving the Description field, the DrugLookupedit check is executed and DFlookup:aecodes dialog appears. Click Cancel .

10. Do not make any other changes to the data on the current page and press Tab to advance to the save buttons. Click Incomplete .

Data review and add a query to inconsistent data
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1. Double-click Subject 99007 entry in the record list to open task records for this subject. Press Tab to advance through the fields until Screen 1, Reading 1 systolic blood
pressure becomes the current field.

2. Select Field  > Add Query  or click  to open the Add Query dialog. In the dialog, set:

Category = Inconsistent

Use = External

Type = Clarification

Status = New query

Enter This value is inconsistent with all other BP readings. Please explain. in the Detail field.

3. Click OK to apply the query.

4. Press Tab to advance through the remaining fields on the page until the save buttons become active. Click Incomplete  to save the page.

Review and complete pending data for Subject 99007

1. Release the current task set and retrieve all pages in the database that have been saved with status Pending. Do this by selecting Select  > By Data Fields . In the dialog set:

Mode = Validate

Save level = 4 - Level 4

Search = Data

Status = Pending

Leave the retrieval Level field blank.

2. Click Done. In the confirmation dialog, click OK to retrieve data records that match the search criteria.

3. Select Subject 99007 > 1 : Baseline > 3: Form 3 from the record list and click anywhere on the page background to make it the active page. Beginning with the Patient Number
field, press Tab to advance through the fields until the first Major Surgery text field is the current field. Enter all Major Surgery information as it appears in the following image.
Press Tab to exit the last data field to make the save buttons active.

DFdiscover 5.11.0 Acceptance Test Manual Page 149 of 313



4. As there are no outstanding problems on the page and the data is now complete, click Final  to change the page status from Pending to Final at level 4.

5. Select Select  > All Records  to release all task records from the current set. Click OK in the dialog to clear the main Data View window.

Confirm audit trail information for reviewed and modified data

1. Select View > Reports , Reports View becomes the current view.

2. Click the Subject Tracking section and choose report History of Changes from the list of reports. To review all data modifications made to Subject 99002 and 99007. Enter -date 
today -subjects 99002,99007 in the Specify field.

3. Click Run to execute the History of Changes report. Examine the output.
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Run batch edit checks to verify data integrity

1. Select View > Batch Edits . Batch Edits becomes the current view.

2. With the Controls tab as the current view. Click File  > Open Control File  from the drop-down list.

3. In the Open Batch Control File dialog, select (enable) the On study server option to display a list of available control files that are located on the study server for the 254
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Acceptance Test Study. Choose ScreenDateCheck.xml from the list and click OK to load the control file.

4. Click Show Batch to ensure the settings are as shown below. Click Hide Batch  to hide the settings.

NOTE: The ScreenDateCheck.xml control file executes the edit check ScreenDates which verifies that the Screen 1 and Screen 2 dates on all plate 1s (Blood Pressure
Screening Form) are in sequential order with the Screen 1 date coming before the Screen 2 date.

5. Click Run Batchlist  to run the current batch program. Click Run in the confirmation dialog.

6. From the Summary drop-down list, choose the item identified as '(current)'.
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7. The edit check ScreenDateschecks the Screen 1 and Screen 2 dates on Form 1 (plate 1) and determines if they are out of sequence. Examine the log entry message.

8. Double click the entry to be taken to Data View. Examine the values in the Screen 1 and Screen 2 date fields.
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9. Select View > Batch Edits . With the Controls tab as the current view, click File  > Open Control File  from the drop-down list.

10. In the Open Batch Control File dialog, select (enable) the On study server option to display a list of available control files that are located on the study server for the 254
Acceptance Test Study. Choose batchSAEcheck from the list and click OK to load the control file.

11. Click Show Batch to ensure the settings are as shown below. Click Hide Batch  to hide the settings.
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NOTE: The batchSAEcheck.xml control file applies a query to Is This A Serious Event field on plate 009 when the response to this field is inconsistent with the value in the
Intensity field of the same plate.

12. Click Run Batchlist  to run the current batch program. Enter the Username and Password of the current user, click OK.

13. From the Summary drop-down list, choose the item identified as '(current)'.

14. Double-click the entry to be taken to Data View.

15. The Intensity field becomes the current field. Verify that Intensity has a value of 4 with the query count '2' displaying on the field widget and the field is blue. Continue tabbing
through the fields until the field Is This A Serious Event? has the focus. Confirm that the 'No' box is marked for this field.

16. Return back to the Intensity field by using Shift  + Tab keys. With the focus on Intensity, examine the details in the Query window, and confirm that the batch edit check with the
category Monitor has been added to this field.
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NOTE: The query list is presented in accordance with the query sort order defined in Module 3.9 Create user-defined query category codes.

17. Double-click Site 99 - Hospital #99 entry to close all subject binders.

Use a data expression to retrieve specific subject information

1. Still in Data View, determine which subjects have had adverse events. Do this by selecting Select  > By Data Fields  to open the Select by Data Fields window. In the dialog, set:

Mode = View

Plate = 5

Level = 1-4

Do not select any Status check box.

2. Click Expression ...  to open the Expression Editor dialog.

3. Do the following to build an expression that searches for the occurrence of adverse events: In the Expression Editor, select 25:AEYN from Fields. From the Symbols list choose
== equals. From the Codes list choose 2 Yes. Click OK to add the expression to the Expression field in the Select by Data Fields retrieval dialog.
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4. Click Done to apply the settings. Click OK in the confirmation dialog to retrieve the 1 data record that matches the expression and retrieval criteria.

5. Scroll down the current page for Subject 99001 to locate the adverse event question. Confirm that the Yes choice has been entered in response to the question Did the patient
report any adverse events since the last visit?.

6. Confirm that a corresponding adverse event report has been submitted for Subject 99001. Do this by clicking Show All Records for This Subject  located below the subject binder
list. Scroll through the list of assessments until the 1011 : Adverse Event 1 Page 1 entry. Select the list entry for 9: Form 9, AE Report 011.

Use cross-plate data criteria to retrieve specific subject information
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1. Select Select  > All Records  to release all task records from the previous test. Click OK in the resulting confirmation dialog. Select Select  > By Data Fields  to open the Select by
Data Fields dialog, click Clear  to clear the previous retrieval specifications and reset the dialog.

2. The steps that follow search for and retrieve all patients in the database that are >=50 years old, male and have a history of diabetes. Within the Select by Data Fields dialog,
click ...  next to the Subject field to open the Subjects dialog and then choose ALL as the value for Select subjects that match.

3. Begin by building an expression for the first subject criterion of Age. Working in the Criterion #1 block, specify Visit = 0. Click ...  next to Plate to open a list of study plates. In the
list double-click entry 001 - Blood Pressure Screening Visits to populate the Plate field (plate 1 contains the Age data field). Click ...  next to Field to get a listing of all fields
defined on the selected plate 1. Double-click AGE to populate the Field specification. Using the Condition drop-down menu, choose >= greater than or equal to assign a retrieval
Condition. Finally, specify 50 in Value.
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4. Click Retrieve  to retrieve the number of subjects that match the specified Age criterion. Click Add to add a new criterion block in preparation for the specification of the 2nd
retrieval criterion (Male).

5. Build an expression for the second subject criterion of Male. Working in the Criterion #2 block, specify Visit = 0. Click ...  next to Plate to open a list of study plates. In the list
double-click entry 001 - Blood Pressure Screening Visits to populate the Plate field (plate 1 contains the Sex data field). Click ...  next to Field to get a listing of all fields defined
on plate 1. Double-click entry SEX to populate the Field specification. Using the Condition drop-down menu, choose == equal to assign a retrieval Condition. Select 1 Male from
the Value pull-down.

6. Click Retrieve  to retrieve the number of subjects that match the specified Sex criteria. Click Add to add a new criteria block in preparation for the specification of the 3rd retrieval
criteria (history of diabetes).

7. Build an expression for the third subject criterion of diabetes history. Working in the Criterion #3 block, specify Visit = 1. Click ...  next to the Plate label to open a list of study
plates. In the list double-click entry 003 - Medical History to populate Plate (plate 3 contains the Diabetes data field). Click ...  next to Field to get a listing of all fields defined on
the selected plate 3. Double-click entry MHOCCUR (7. Diabetes: N/Y) to populate the Field specification. Using the Condition drop-down menu, choose == equal to assign a
retrieval Condition. Select 2 Yes from the Value pull-down.

8. Click Retrieve  to retrieve the number of subjects that match the specified Diabetes history criteria. Click Done to find the subjects that match ALL three of the criteria
specifications and close the Subject Criteria dialog.

9. In the Select by Data Fields dialog, set:

Mode = View

Plate = 1,3

Level = 1-7

to retrieve only those plates having the Age, Sex and Diabetes history information for the matching subjects.
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10. Click Done in the dialog to apply the settings. Click OK in the confirmation dialog to retrieve the 2 data records that match the subject, plate and level specifications.

11. With 0 : Screening Visits, 1 : Form 1 for Subject 99004 as the active page, locate the Age and Sex fields. Confirm that the subject's Age >= 50 and Sex=male.

12. Select 1: Baseline, 3: Form 3 for Subject 99004 to open the Medical History page. Scroll down the page to locate the 7. Diabetes field. Confirm that this field is checked 'Yes'.

13. Select File  > Exit  to close Data View and exit DFexplore.

End Module 11. Data Review

Return to the DFATK application. Click End to confirm successful completion of Module 11. Data Review.

Module 12. External Query Reports

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
data_coordinator : data_coordinator

(Optional) - SMS or email 2-factor authentication setup with data_coordinator

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore

Purpose: This module tests the use of various built-in DFdiscover reports to perform integrity checks and query operations on the database, including automated query creation,
creation of query reports, verifying data status with reports, as well as testing for proper authorization of report execution based on user permissions. Exporting of generated reports will
be tested, as well as testing DFdiscover’s ability to send outbound messages through the server’s email service. Results from reports are also compared to study data to ensure
consistency.
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Tests & Requirements

1. Obtain database query metrics and details using Status and List Views to review all outstanding queries prior to query report creation.

2. Run database integrity check report DF_XXkeys to export all key fields and visit dates from required plates in the database.

3. Use Data View to check, and if necessary correct, illegal visit dates by retrieving the problems keys identified by DF_XXkeys.

4. Execute DF_QCupdate to update the query database and lock all records for query report generation.

5. Execute DF_QCreports to create a standard, 3-part external query report for a study site.

6. Confirm the status of external queries following query report creation.

7. Execute DF_QCstatus to verify that a new query report was created by listing all reports in the QC/NEW directory.

8. Execute DF_QCview to display the newly created query report.

9. Execute DF_QCprint to print the query report from the QC/NEW directory.

10. Comparing several examples from the printed query report against their corresponding queries in the study database.

11. Execute DF_QCfax to email the query report to a valid email account.

12. Verify the status of the queries in the sent report.

Estimate of Time Required: 40 Minutes

Begin Module 12. External Query Reports

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 12. External Query Reports  followed by Begin  to begin this module.

Obtain database query metrics and details using Status and List Views to review all outstanding queries prior to query
report creation

1. Start DFexplore, login as user data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”

NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. Select View > Status . Examine the Queries table to view the status and count of all queries in the database.

3. Open the Graphics section and select the toggle button for by status. Confirm the count of Pending and Outstanding queries.
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4. Select View > List . Select the Plates & Metadata tab.

5. Click metadata - Queries to display information about database queries.

6. Select Select  > Search to specify query search criteria. In the search dialog, check (enable) the Usage = external, click Update  to update the dialog with details and a count of
external queries.
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7. Click Done to close the Search dialog.

Run database integrity check report DF_XXkeys to export all key fields and visit dates from required plates in the
database

1. Select View > Reports  to change from List View to Reports View.

2. Double-click DFdiscover Reports then Legacy Reports list by clicking . Select the report DF_XXkeys from the list. Click Explain  to view a detailed description of the report. As
options do not exist for this report, click Run to execute DF_XXkeys.

3. In Step 2, DF_XXkeys detected an illegal visit date. As indicated by the message in the reports window, a data retrieval file called VDillegal.drf was created. This file contains the
plate(s) on which the illegal visit date was detected, and can be reviewed and edited in Data View. Click Close Report  to close the report output window. Select View > Data  to
change to Data View.

Use Data View to check, and if necessary correct, illegal visit dates by retrieving the problems keys identified by
DF_XXkeys

1. To review the data retrieval file created in Step 2, select Select  > By Data Retrieval File . In the retrieval file dialog, set:

Mode = Validate

Save level = 1 - Level 1

Check (enable) Enable edit checks

Select file from = study server
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2. To locate the data retrieval file VDillegal.drf, click ...  next to Select file from. In the file selection dialog, choose the file VDillegal.drf, then click OK.

3. Click OK in the dialog. Click OK in the resulting confirmation dialog to retrieve all data records having illegal visit dates.

4. Click anywhere in the page to make it active for data entry. Starting with the Follow-up choice field, press Tab to advance to the Visit Date. The Visit Date value has been
entered as 04/17/97 (an illegal date), rather than 04/07/97 as shown on the CRF image. Enter the correct date and press Tab to exit the field.

5. As problems no longer exist on the corrected page, the page can be saved with a status of Final. Click Final  to save the page.

Execute DF_QCupdate to update the query database and lock all records for query report generation

1. Select Select  > All Records , click OK. Select View > Reports  to return to Reports View. Again choose the report name DF_XXkeys from the list and click Run. Confirm that the
output no longer reports illegal visit dates.
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2. Choose DF_QCupdate from the list of Legacy Reports and click Explain  to view a report description. Do not enter any options in the Specify field and click Run to update the
Query database.

3. A user requires unrestricted permissions to execute DF_QCupdate. As user data_coordinator is restricted to database Modify and Write levels of 0-4 (as set in Module 1.
Installation and Initialization), it is not possible to execute DF_QCupdate successfully. Click File  > Exit  to close DFexplore.

4. Start DFexplore, login as user data_manager as described in “Obtain database query metrics and details using Status and List Views to review all outstanding queries prior to
query report creation.”.

5. Select View > Reports .

6. Double-click DFdiscover Reports, expand Legacy Reports by clicking . Choose DF_QCupdate from the list of reports. Click Run to execute DF_QCupdate with the correct
permissions.
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Execute DF_QCreports to create a standard, 3-part external query report for a study site

1. Choose DF_QCreports from the list of Legacy Reports and click Explain  to view a report description.

2. Do not enter any options in the Specify field so that a complete query report is generated. Click Run to execute DF_QCreports.

NOTE: DFdiscover report numbers are comprised of a site number followed by the date of report creation (as yy/mm/dd). The two are separated by a hyphen. Your Query
report has been created for Site 99 and the date of creation is the date on which DF_QCreports was executed (i.e.today).

3. To print the output, select File  > Print . In the Print dialog, the Printer Name field contains the name of your printer. Click Print . Keep this printout to reference the query report
number in “Comparing several examples from the printed query report against their corresponding queries in the study database.”. Click Close Report  to close the report output
window.

Confirm the status of external queries following query report creation

1. Select View > Status . Click Refresh to update the database counts. Examine the Queries table to view the status and count of all queries in the database.

DFdiscover 5.11.0 Acceptance Test Manual Page 166 of 313



NOTE: The counts in the Queries table have changed because the query database has been updated by the running of the report DF_QCupdate in “Execute DF_QCupdate
to update the query database and lock all records for query report generation.”. If applicable, DF_QCupdate will create new queries for missing pages and overdue visits
based on the study scheduling information present in the study visit map files.

2. Select View > List .

3. Click metadata - Queries to display information about database queries.

4. Select Select  > Search to specify a set of query search criteria. In the resulting search dialog, select (enable) Usage = External and click Update  to update the dialog with details
and a count of external queries.
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5. Click Done to close the dialog.

Execute DF_QCstatus to verify that a new query report was created by listing all reports in the QC/NEW directory

1. Select View > Reports .

2. From the list of Legacy Reports, select DF_QCstatus and click Explain  to view a report description. As a query report was created but not sent, click Run to obtain the status of
all query reports currently in the study QC/NEW directory.

3. Click Close Report  to close the report output window.

Execute DF_QCview to display the newly created query report

1. To display the query report created for Site 099 - Hospital #99, choose DF_QCview. Click Explain  to view a description of the report. As the report for Site 099 - Hospital #99
still resides in the QC/NEW directory (it has not yet been sent to the site), click Run to execute DF_QCview.
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2. Click Close Report  to close the report output window.

Execute DF_QCprint to print the query report from the QC/NEW directory

1. If your DFdiscover server is connected to a printer, print a copy of the query report for Site 099 - Hospital #99 by choosing DF_QCprint. Click Explain  to view a description of the
report. Enter -u number of your query report in the Specify field. Click Run to execute DF_QCprint. If your DFdiscover server is not connected to a printer, you can instead you
can choose to print the query report displayed in the DF_QCview output window from the previous step or keep a copy of the text to use with the following steps.

2. Click Close Report  to close the report output window.

Comparing several examples from the printed query report against their corresponding queries in the study database

NOTE: For this test you will need to reference the query report printed in “Execute DF_QCprint to print the query report from the QC/NEW directory.” to verify the information
contained in the report against the study database. Three examples of queries will be verified in this test. You may choose to check the remainder of the queries yourself.

1. In the printed query report, find the entries for patients 99002 and 99004 in the FAX/REFAX section of the report. For patient 99002, locate the entry for Form 9, AE Report 011
having multiple queries in the Intensity field. For patient 99004, locate the entry for Form Number 4, Pg 1 having the category “Missing Page”. Form 4 corresponds to Plate 4 in the
database. Now locate the entry for Form Number 2, having the category “Pulse beats/minute (Missing)”. Form 2 corresponds to Plate 2 in the database.

2. Select View > Data .

3. Select Select  > By Data Fields . In the dialog, set:

Mode = View.

Subject = 99002,99004

Plate = 2,4,9

Level = 1-7

4. Click Done then OK to apply the record selection criteria and retrieve the applicable pages.
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5. Highlight the 9: Form 9, AE Report 011 page in the record list. Press Tab to advance through the fields until Intensity becomes the current field. Confirm that this field is blue and
the query count “2” is displayed on the field widget. Examine the Query window to view the details of the queries. Verify that the information in the Query window is consistent with
the corresponding printed Query report.

6. In the record list, double-click entry for subject 99004.

7. Press Tab to advance to the Pulse field to make it the current field. Verify that the field is blue (indicating that an outstanding query exists). Examine the Query to view the details
of the query.

8. Examine the record list for the entry for Form 4 for Subject 99004 (identified as a Missing Page on the query report).

9. Select Select  > All Records . Confirm the settings:

Mode = Modify

Save level= 1 - Level 1
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Enable (check) edit checks

Click OK to release the task set and display all records in the database.

Execute DF_QCfax to email the query report to a valid email account

1. Select View > Reports .

2. Choose DF_QCfax and click Explain  to view a description of the report. Send the query report generated in “Execute DF_QCreports to create a standard, 3-part external query
report for a study site.” to a valid email address. Enter -f mailto:user@localhost in the Specify field, substituting “user@localhost” with your email address as defined on your mail
system. Click Run to execute DF_QCfax.

3. Wait for several minutes, then check the recipient's email account for the arrival of the query report emailed in Step 2. Once the report has arrived, click Close Report  to close the
report output window.

Verify the status of the queries in the sent report

1. Select View > Status . Click Refresh to update the database counts. Examine the Queries table to view the status and count of all queries in the database.

NOTE: The counts in the Queries table are the same as those in Step 1 because queries have been sent to the site but not resolved.

2. Select View > List , and click Plates & Metadata.

3. Select File  > Preferences. Click List View to expand that sub-panel and enable Label for Display coded field as. Click OK. To display information about database queries, click
metadata - Queries.

4. Select Select  > Search to specify a set of query search criteria. In the resulting search dialog, select (enable) Usage = external. Click Update  to update the dialog with details and
a count of external queries.

DFdiscover 5.11.0 Acceptance Test Manual Page 171 of 313



5. Click Done to close the Search dialog.

6. Select File  > Exit  to close and exit DFexplore.

End Module 12. External Query Reports

Return to the DFATK application. Click End to confirm successful completion of Module 12. External Query Reports.

Module 13. Replying to EDC Queries, eSignatures

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
site_invest : site_investigator

Email address configured for site_monitor
(Optional) SMS or email 2-factor authentication configuration for site_invest

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFsetup

Purpose: This module tests replying to EDC queries within DFexplore. Furthermore, it serves as the primary test for DFexplore’s eSignature module, testing the application, removal
and re-application of eSignatures.

Tests & Requirements

1. Determine a count of outstanding/outstanding queries in Status View.

2. Review outstanding queries in Queries View.

3. Using EDC, locate and reply to outstanding clarification queries.

4. Add an Electronic Signature (eSign) to a set of completed subject records.

5. Verify removal and re-applicaton of eSignatures.

Estimate of Time Required: 30 Minutes

Begin Module 13. Replying to EDC Queries, eSignatures

1. Start DFATK as described in Module 1 (Installation & Initialization) .

2. Click 13. Replying to EDC Queries  followed by Begin  to begin this module.

Determine a count of outstanding queries in Status View

1. Start DFexplore, login as site_monitor and choose 254 Acceptance Test Study as described in “How to start DFexplore”.

2. Select View > Status . Examine the Queries table to view the status and count of all queries.
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3. Locate the Outstanding column that displays a count of 17 in the Total row. Double-click 17 to retrieve the records containing the 17 outstanding queries.

4. In the Database Status task Specification dialog set:

Mode = Validate

Save level = 1 - Level 1

Check (enable) Enable Edit checks

Search queries and open check (enable) Queries View?

Click Yes to display a dialog confirming the retrieval. In the confirmation dialog, click OK to open Queries View .

Review outstanding queries in Queries View

1. Select Show > Outstanding Queries  to verify that you are seeing only outstanding queries for subjects in Site 99 - Hospital #99.
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2. Examine Queries View to confirm:

The Status & Replies column displays Outstanding (New, in report and sent) for all queries.

An entry exists for Subject 99001 , Screening Visits Form 1, 5. Patient has signed informed consent.

An entry exists for Subject 99007 , Screening Visits Form 1, Screen 1 Reading 1 systolic.

Using EDC, locate and reply to outstanding clarification queries

1. Locate the entry for Subject 99001, Screening Visits Form 1, 5. Patient has signed informed consent. Double-click the query to switch to Data View and make the queried
page and field active. Examine the information present in the Query window.

2. Select Field  > Reply to Query  or click  . In the dialog, enter Informed consent was sent to study coordinator by email on March 20. in the New Reply field.

DFdiscover 5.11.0 Acceptance Test Manual Page 174 of 313



3. Click OK to apply the reply to the queried field. Examine the information present in the Query window.

4. Do not enter or change data in any of the remaining fields on the current page. Click Final  to save the current page and the query reply to the database.

5. From the record list window, click Return to Queries View. Examine the list of queries.

6. Locate the entry for Subject 99007, Screening Visits: Form 1, Screen 1: Reading 1 systolic. Double-click the systolic blood pressure query to switch to Data View and make
the queried page and field active. Examine the information present in the Query window.
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7. Select Field  > Reply to Query  or click  in the dialog, enter Systolic reading was entered incorrectly. It should be 170. in the New Reply field.

8. Click OK in the Reply to Query dialog to apply the reply to the queried field. Examine the information present in the Query window.

9. Click Final  to save the current page and the query reply to the database.

10. Select File  > Exit  to close and exit DFexplore.

Add an Electronic Signature (eSign) to a set of completed subject records

NOTE: eSignatures require password permission to be set in the user role at the DFadmin level. The Password permission must be granted for the specific eSignature plate.

1. Start DFexplore, login as user site_invest and open the 254 Acceptance Test Study as described in ( “How to start DFexplore”).

2. As user site_invest has 2FA enabled, enter security code received by email or SMS as previously defined.
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NOTE: Refer to “Creating user accounts and assigning study permissions.” as a valid email address or phone number is required for site_invest to receive 2FA codes.

3. Select File  > Preferences , click Background Options to expand the preferences. Click Color > OK to apply the changes.

4. Locate subject 99003 , double-click its entry to expand a list of visits for Subject 99003.

5. Double-click 30 : Study Termination . Select 7: Form 7 to open a new STUDY TERMINATION form.
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6. Click anywhere in the screen background to begin data entry. Enter the form data as shown below:

7. Press Tab to advance to the eSignature Reason field. This field and the remaining fields on the page are used to capture eSignature reason, name, date and time, respectively.
Press Tab, attempt to enter any name in the Investigator's Signature field.

8. Press Tab to advance to the remaining 2 eSignature fields. Again attempt to manually enter data into each of these fields. Press Tab to exit the last field on the page ( eSignature
Time ) to make the save buttons active.

9. Click Final  to save and eSign the STUDY TERMINATION form.

10. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password used for login in “Add an Electronic Signature (eSign) to a set of
completed subject records.” . Click Sign to apply the electronic signature to the current STUDY TERMINATION page.

11. In the DFexplore - eSignature Reason dialog select Approved from the dropdown, click OK.
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12. Examine the 4 eSignature fields at the bottom of the page.

13. Select File  > Exit  to close and exit DFexplore.

Verify removal and Re-applicaton of eSignatures

1. Start DFexplore, login as user site_monitor and open the 254 Acceptance Test Study as described in ( “How to start DFexplore”).

2. Locate subject 99003 , double-click its entry to expand a list of visits for Subject 99003 .

3. Double-click 30 : Study Termination . Select 7: Form 7 to open the STUDY TERMINATION form.

4. Click 2. Last dose of study medication was taken on field. Select Field  > Add Query  or click  to open the Add Query dialog. In the dialog, set:

Category = Monitor

Use = External

Type = Clarification

Status = New query

Enter Investigator to confirm last dose taken with subject during clinic visit. in the Note field.

5. Click OK to apply the query.

6. Press Tab to advance to the Unknown field. Un-check (disable) the checkbox.
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7. Press Tab to advance through the remaining fields on the page until the save buttons become active. Click Incomplete  to save the page.

8. Select File  > Exit  to close and exit DFexplore.

9. Start DFexplore, login as user site_invest and open the 254 Acceptance Test Study as described in ( “How to start DFexplore”).

10. Locate subject 99003 , double-click its entry to expand a list of visits for Subject 99003 .

11. Double-click 30 : Study Termination . Select 7: Form 7 to open the STUDY TERMINATION form.

12. Press Tab to advance to 2. Last dose of study medication was taken on field. Select Field  > Edit Query  or click  to open the Edit Query dialog. Select Resolved
Corrected. Enter Confirmed date of last medication dose verbally with subject during clinic visit. in the Note field.
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13. Click OK to close the dialog.

14. Enter the 2. Last dose of study medication was taken on date as 02/06/16 .

15. Press Tab to advance to the eSignature Reason field. This field and the remaining fields on the page are used to capture eSignature reason, name, date and time, respectively.
Press Tab, attempt to enter any name in the Investigator's Signature field.

16. Press Tab to advance to the remaining 2 eSignature fields. Again attempt to manually enter data into each of these fields. Press Tab to exit the last field on the page (eSignature
Time) to make the save buttons active.

17. Click Final  to save and eSign the STUDY TERMINATION form.

18. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password used for login in “Add an Electronic Signature (eSign) to a set of
completed subject records.”. Click Sign to apply the electronic signature to the current STUDY TERMINATION page.

19. In the DFexplore - eSignature Reason dialog select Reviewed from the dropdown, click OK.

DFdiscover 5.11.0 Acceptance Test Manual Page 181 of 313



20. Examine the 4 eSignature fields at the bottom of the page.

21. Select File  > Exit  to close and exit DFexplore.

End Module 13. Replying to EDC Queries, eSignatures

Return to the DFATK application. Click End to confirm successful completion of Module 13. Replying to EDC Queries, eSignatures.

Module 14. Re-submitting Query Corrections

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
site_monitor : site_monitor
data_coordinator : data_coordinator

Email address configured for site_monitor
(Optional) SMS or email 2-factor authentication configuration for data_coordinator

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFsend

Purpose: This module tests the resolution and update of queries in DFexplore from CRF images submitted through DFsend.

Tests & Requirements

1. Submit PDF images to DFdiscover.

2. Verify that all CRFs have arrived successfully in Image view.

3. Retrieve submitted CRFs using DFexplore Image View.

4. Enter Form 2, Subject 99001, resolve outstanding queries, and save the corrected CRF to the database.

5. Enter Form 2, Subject 99002, resolve outstanding queries, and save the corrected CRF to the database.

6. Enter Form 4, Subject 99004.

7. Enter Form 2, Subject 99004, resolve outstanding queries, and save the corrected CRF to the database.

8. Select and resolve a query in a field that has multiple queries.

9. Review and approve a pending query reply for Form 1 for Subject 99002.

10. Review, correct and approve a pending query reply for Form 1, Subject 99007.

11. Confirm query resolution by examining the database status.

Estimate of Time Required: 30 Minutes

Begin Module 14. Re-submitting Query Corrections

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 14. Re-submitting Query Corrections  followed by Begin  to begin this module.

Submit PDF images to DFdiscover

1. Click Send Query Corrections  to email a copy of QC_corrections.pdf to site_monitor. Clicking more than once will result in multiple pages arriving to your email inbox.

NOTE: Save the QC_corrections.pdf file received via email to your local computer. This file is required to complete the remainder of this module. Refer to “Creating user accounts
and assigning study permissions.” as a valid email address is required for site_monitor to receive the module specific PDF files.

2. Start DFsend, login as user site_monitor as described in “How to start DFsend”.

3. Click Add. From the Select PDF Files file selection dialog, locate the previously saved QC_corrections.pdf file. Select the file, Click Open.
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NOTE: Documents can also be added by dragging-and-dropping the desired PDF files from a local file folder directly into the list area.

4. Click Send, enter site_monitor in the Username field and the previously assigned password in the Password field. Click OK.

5. In the resulting Send PDFs to DFdiscover dialog, confirm 1 success and 0 failure are shown. Click OK.

6. Click Show Log to confirm successful transmission of the QC_corrections.pdf file to DFdiscover.

7. Select File  > Exit .

NOTE: Wait 2-3 minutes prior to proceeding to DFexplore.

Verify that all CRFs have arrived successfully in Image view

1. Start DFexplore, login as user data_coordinator and choose 254 Acceptance Test Study as described in “How to start DFexplore”
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NOTE: If data_coordinator has been set up for 2-factor authentication with Azure SMS, you may need to wait for a 1-time code to arrive at the phone number as defined in
DFadmin.

2. Select File  > Preferences. In the Preferences dialog, click  from Image View section. Select (enable) When the revised record is saved. Click OK to save and close the
Preferences dialog.

3. Select View > Status . Examine the information displayed for the Images awaiting review in Image Queue, Data Records and Queries tables.

NOTE: The number of pages awaiting review in the Image Router may be different from that shown here as this number includes pages for all studies on the DFdiscover
server, not only those that belong to the 254 Acceptance Test Study.

Retrieve submitted CRFs using DFexplore Image View

1. Select View > Image, in the resulting Automatic Retrieval dialog set:

Check (enable) Enable Edit Checks

Save level = 1 - Level 1

Select = document

By Age = oldest

Quantity = 10
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2. Click OK to bring forward all new images awaiting data entry.

Enter Form 2, Subject 99001, resolve outstanding queries, and save the corrected CRF to the database

1. With PATIENT ENTRY FORM for Subject 99001 as the current page, click anywhere on the page background to make the page active for data entry. Beginning with the Patient
Number field, verify that the correct Subject 99001 is displayed. If the Patient Number is incorrect, correct it by selecting Plate  > Change Barcode, specify a Subject of 99001.
Click OK. Press Tab to exit the field.

NOTE: In your normal image entry process, you must always pay careful attention to the accuracy of the ICR data. You will need to do the same here. It is possible that the
new pages contain ICR errors that you will need to correct during entry. In particular, it is important that you correct any key fields (visit and/or subject numbers) that may have
been misread as these are critical to the identification and storage of the data. Note that the ICR data records on your screen may not match exactly those shown in the
examples throughout this module.

2. Click OK to load the data from the existing subject 99001, PATIENT ENTRY FORM.
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3. Press Tab to advance from field to field, and verify that data is the same as that found on the CRF image. Note that some fields may contain values that have been assigned by
edit checks. Stop when the Smoking Status field becomes the current field. Examine the details in the Query window. Enter the data as it appears on the image.

NOTE: When data is entered into a field that contains an outstanding missing value query of type Correction, the query is automatically resolved by DFdiscover as the
missing data has now been provided. The color green indicates that the query has been resolved.

4. Continue tabbing through the remaining fields on the page to verify that the data in the fields is the same as the CRF image. Once the save buttons become active at the bottom of
the record, click Final  to save the corrected page.

5. Using the scroll bars, examine the primary image and locate the corrected Smoking Status field to verify that this is the same image that was saved with the corrected data record
in “Enter Form 2, Subject 99001, resolve outstanding queries, and save the corrected CRF to the database.”. Click Cancel  to exit the Review Images dialog.
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6. Return to the saved page for Subject 99001 by selecting it from the Image Queue list. Examine the bottom right corner of the main data entry screen.

Enter Form 2, Subject 99002, resolve outstanding queries, and save the corrected CRF to the database

1. From the new Image Queue, click the 2nd entry in the list (Subject 99002) to make it the current page. Click anywhere on the page background to make the page active for data
entry. Beginning with the Patient Number field, enter the correct subject 99002 and press Tab to exit the field.

2. Click OK to load the data from the existing Subject 99002, PATIENT ENTRY FORM.

3. Press Tab to advance from field to field, and verify that data is the same as that found on the CRF image. Stop when the Date of Birth field becomes the current field. Examine
the details in the Query window.

4. Enter the corrected date value 05/12/1951, as it appears on the image of the CRF. With Date of Birth as the current field, select Field  > Edit Query  or click .

5. Select Resolved corrected from the Status pull-down. Click OK to apply the change to the query status. Examine the Query window.
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6. Continue tabbing through the remaining fields on the page to verify that the data in the fields is the same as the CRF image. Note that some fields may contain values assigned by
edit checks. Once the save buttons at bottom of the record become active click Final  to save the corrected page.

7. Using the scroll bars, examine the primary image and locate the corrected Date of Birth field to verify that this is the same image as was saved with the corrected data record in
“Enter Form 2, Subject 99002, resolve outstanding queries, and save the corrected CRF to the database.”. Click Cancel  to close the Review Images dialog.

Enter Form 4, Subject 99004

1. Click anywhere on the page background to make the page active for data entry. Beginning with the Medications Page Number field, enter 1 as shown on the CRF image. Press
Tab to exit the field and move to the Patient Number. Enter the number shown on the CRF image and leave the field.

NOTE: The CURRENT MEDICATIONS form for Subject 99004 has been flagged as Missing in the Query report of Module 12. As a result, arrival of this plate will not trigger the
Duplicate Record warning because the page does not currently exist in the study database.

2. Enter all fields on the data record as they appear on the CRF image. Once the save buttons at bottom of the record become active, click Final  to save the entered page.
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NOTE: The Review Images window does not appear upon saving Form 4, Subject 99004 because a duplicate page does not exist for this set of keys.

Enter Form 2, Subject 99004, resolve outstanding queries, and save the corrected CRF to the database

1. Click anywhere on the page background to make the page active for data entry. Beginning with the Patient Number, enter 99004 as shown on the CRF image. Press Tab to exit
the field.

2. Click OK to load the data from the existing Subject 99004, PATIENT ENTRY FORM.

3. Press Tab to advance from field to field, and verify that data is the same as that found on the CRF image. Note that some fields may contain values assigned by edit checks. Stop
when the queried Pulse field becomes the current field. Examine the details in the Query window.

4. Enter the correct response as it appears on the image of the corrected CRF. Examine the details in the Query window and press Tab to exit the corrected Pulse field.
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5. Continue tabbing through the remaining fields on the page to verify that the data in the fields is the same as the CRF image. Once the save buttons at the bottom become active,
click Final  to save the corrected page to the database.

6. Using the scroll bars, examine the primary image and locate the corrected Pulse field to verify that this is the same image as was saved with the corrected data record in Step 3.
Click Cancel  to close the Review Images window.

Select and resolve a query in a field that has multiple queries

1. With the ADVERSE EVENT REPORT Form for Patient Number 99002 as the current plate, click anywhere on the page background to make the page active. Beginning with the
Adverse Event Report No. field, enter the value as shown on the CRF image. Press Tab to exit this field and advance to the AE Identifier field. Upon entering the AE Identifier
field, the edit check AESEQNUM2 automatically complete this field. Press Tab to exit the AE Identifier field to advance to the Patient Number field. Verify that the correct Subject
99002 is displayed for the Patient Number field. If the number is incorrect, correct it and press Tab to exit the field.

2. Click OK to load the data from the existing Subject 99002, ADVERSE EVENT REPORT FORM.
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3. Correctly enter each data field on the page per the CRF image, up to the Intensity field. Confirm that the Intensity field has a value of 4, and contains 2 unresolved queries.

4. Enter the correct value 2 for Intensity field per the CRF image. Examine the details in the Query window.

5. Select Field  > Edit Query  or click . Choose Resolved corrected from the Status pull-down. Click OK to apply the edits.

6. With the focus still on the Intensity field, examine the details in the Query window. Select the Clinical QC query from the Query drop-down, and examine its details.

7. Select Field  > Edit Query  or click  in the dialog, choose Resolved corrected from the Status pull-down. Click OK to apply the edits.
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8. Press Tab to advance through the fields, and verify that the data is the same as that found on the CRF image. Note that upon leaving the Description field, an edit check is
executed and DFlookup:aecodes dialog appears. Click Cancel  to close the DFlookup:aecodes dialog.

9. Continue tabbing through the remaining fields on the page and verify that the data in the fields is the same as the CRF image. Once the save buttons become active at the bottom
of the record, click Incomplete  to save the corrected page to the database. Upon clicking Incomplete , the Review Images dialog appears. Click Cancel  to close the Review
Images window.
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Review and approve a pending query reply for Form 1 for Subject 99002

1. Select View > Queries .

2. Click OK in the confirmation dialog to release the Image View records and open Queries View.

3. Select Show > Pending Queries  to display only queries for which a resolution is pending. Double-click Site 99 - Hospital #99 entry to display all pending queries.

4. Locate the pending query for Subject 99001, 5. Patient has signed informed consent. Double-click the query to make the queried field and page the current page. Examine the
information in the Query window.

5. Select Field  > Approve Queries and Reasons  to review all queries and reasons that are present on the current page.
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6. Choose Resolved corrected from the Status pull-down. Enter Signed informed consent was received March 20, 2009. in the Note field.

7. Click Save to apply the Resolved corrected status to the query. Click Done to close the Approve Queries and Reasons dialog.

8. Do not change any other data or metadata on the 0 : Screening Visits page for Subject 99001. Make the save buttons at the bottom of the screen active and click Final  to save
the data record and query to the database.

9. In the record list window, click Return to Queries View to return to Queries View to process the pending query for Subject 99007.
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Review, correct and approve a pending query reply for Form 1, Subject 99007

1. Locate the pending query for Subject 99007, Screen 1: Reading 1 systolic. Double-click the query to make the queried field and page current. Examine the information in the
Query window.

2. Select Field  > Approve Queries and Reasons  to review all queries and reasons that are present on the current page.
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3. Choose Resolved corrected from the Status pull-down.

4. Click Save to apply the Resolved corrected status to the query. Click Done to close the Approve Queries and Reasons dialog.

5. The query reply indicates that the Screen 1: Reading 1 systolic value should be 170. With the focus still on the Screen 1: Reading 1 systolic field on the page, change the
value to 170.

6. Click Final  to save the data record and query to the database.

7. In the record list window, click Return to Queries View to return to Queries View.
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Confirm query resolution by examining the database status

1. Select View > Status . Examine the information displayed for the Image Queue, Data Records and Queries tables.

2. Select File  > Exit  to close Status View and exit DFexplore.

End Module 14. Re-submitting Query Corrections

Return to the DFATK application. Click End to confirm successful completion of Module 14. Re-submitting Query Corrections.

Module 15. Data Export and DFsas

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted

Email configured for data_manager

Client Tools Used: DFATK, DFexplore

Purpose: This module tests DFexplore’s ability to export data using the DFsas utility.

Tests & Requirements
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1. Export date values in calender format and save the exported data to a file on the local computer.

2. Export date values from the database and save the exported data to a file on the local computer.

3. Examining data values according to user-specified criteria.

4. Query the database for specific data values.

5. Create a DFsas job file according to user-specified criteria.

6. Create a SAS job file and data files using the DFsas job file criteria.

7. Compare the contents of SAS data files with the actual data in the database.

Estimate of Time Required: 30 Minutes

Begin Module 15. Data Export and DFsas

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 15. Data Export and DFsas  followed by Begin  to begin this module.

3. Click Send ID 99006 to email a copy of ID99006_diary.pdf to data_manager. Clicking more than once will result in multiple pages arriving to your email inbox.

NOTE: Refer to “Creating user accounts and assigning study permissions.” as a valid email address is required for data_manager to receive the module specific PDF files. 
Wait 2-3 minutes prior to proceeding to DFexplore.

Export date values in calender format and save the exported data to a file on the local computer

All data exported in the following tests will be output to the DFexplore List View screen rather than saved to a file. List View does have 3 save options: Export Data, Save Data
Retrieval File and Save As PDF.

1. Start DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select View > List .

3. Select File  > Preferences. In the dialog, locate the List View panel. Click [ ] and enter the List View settings as follows:

Display field name as = alias

Display coded field as = label

Display date field as = calendar

Check (enable) apply imputation rule

Display missed code as = default

Check (enable) Fill cell with field color

Uncheck (disable) Expand text fields
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4. Click OK to close the dialog.

5. In the main List View window, Plates & Metadata panel, click 011 - Weekly Patient Diary.

6. Select Select  > Field Selection  to show the listing of all data fields and their metadata properties defined for the plate. In the Data Fields window, click [ ] next to fields
7:SUBJID011,10:DDATE1,16:DDATE2,22:DDATE3,28:DDATE4,34:DDATE5,40:DDATE6 and 46:DDATE7. The fields are added to the Display Fields window.

NOTE: Alternatively fields can also be added by dragging-and-dropping the desired fields from the Data Fields or Metadata Fields windows to the Display Fields window.

7. Click Done to apply the field selection criteria and close the dialog.
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8. Examine each of the exported date fields. Locate the field column for DDATE1 in the table. This is field 10, 1. Date on the WEEKLY PATIENT DIARY page. In “Submit a copy of
the newly defined Plate 11 into the study database and retrieve the page in DFexplore Image View.” this field was defined with the format dd/mm/yy (a 2-digit year). Verify that
field 10 has been correctly exported in calendar (4-digit year) format.

9. Double-click DDATE1 cell for ID 99006 in the table. This takes you to the corresponding date field in the WEEKLY PATIENT DIARY page in Data View. Confirm that the date
values are the same as those on the printed WEEKLY PATIENT DIARY for Subject 99006.

10. In the record list, click Return to List View to be taken back to the date fields in List View. Confirm that the date values displayed are the same as those on the printed WEEKLY
PATIENT DIARY, except now in calendar (4-digit year) format.

Export date values from the database and save the exported data to a file on the local computer

1. Select File  > Preferences. In the List View panel, choose julian as the value of Display date field as. Click OK to apply the settings and close the dialog. Confirm that the
exported date values are now in julian format.
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2. Select File  > Export Data  to save the dates to a local file. In the dialog, set:

Format = Excel

Check (enable) Include header as the first record in output file

Check (enable) Open output file after export

3. Click ...  next to Output File. Choose a directory in the file selection dialog, enter module15_dates.xlsx as the filename, and click Save. Click Save to create/write the file and
close the dialog.

4. The file module15_dates.xlsx opens. Confirm the contents and then close the file.

Examining data values according to user-specified criteria

1. From the list of plates, select plate 001 - Blood Pressure Screening Visits to make it current.

2. Select Select  > Field Selection . In the Data Fields window, click [ ] next to fields 7:SUBJID001,8:PINIT001,9:AGE,10:SEX. The fields are added to the Display Fields window.

NOTE: Fields can also be added by dragging-and-dropping the desired fields from the Data Fields or Metadata Fields windows to the Display Fields window.
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3. Click Done to apply the field selection criteria and close the dialog. Examine each of the data fields.

4. To search for specific subject data, Select Select  > Search. Enter 99003 in the Subject field.

5. Click Find to start the search. Examine the message in the bottom-left corner of the dialog as well as the highlighted entry in the List View table.

6. Click Find Next  to locate a 2nd match (if one exists) in the List View table.

7. Click New Task  to create a task set of records that match the search criteria. In the resulting dialog, change the Mode to View.

8. Click Yes in the Data List dialog to create the task set. Examine the message in the bottom-left corner of the Search dialog, then click Done to close the dialog.

9. Click Switch to Data View to open Data View and review the List View task record. Examine the Data View record list and confirm that only the task record for Subject 99003 is
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displayed. Click Return to List View.

 Query the database for specific data values

1. Select File  > Preferences. In the dialog, locate the List View panel. Choose default for Display date field as. Click OK to save the setting and close the dialog.

2. Click 007 - Study Termination to make it the current page. Select Select  > Search to open the Search dialog.

3. Click Reset  and Reset  in the resulting dialogs to clear all previously specified search criteria.

4. Click ...  next to the Expression field. The Expression Editor opens.

5. For the first part of the query, select 9:FINALDAT from the Fields table. Next, click >= in the Symbols list. Choose julian from the Functions list. In the Expression field, enter the
date "1997/01/01" (including the quotes). Close the parentheses. To build the second part of the query, click && From the Symbols list, followed by field 9:FINALDAT from the
Fields table. Next, click <= in the Symbols list. Choose julian from the Functions list. In the Expression field, enter the date "1997/06/30" (including the quotes). Close the
parentheses. Click OK.

6. Click Find to locate all subjects that have study termination dates that match the specified search expression.

7. Click Find Next  to locate the next match.

8. Do not continue the search and click Done to close the Search dialog.

Create a DFsas job file according to user-specified criteria

1. Select File  > DFsas. The DFsas dialog opens.
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NOTE: If you have previously executed this module as data_manager, the DFsas Jobs panel may display jobfile1 and possibly other files. If jobfile1 is already in the list, highlight
jobfile1 and click Delete  before continuing with this module.

2. Click Add to create a new DFsas job.

3. Enter SASJOB = jobfile1. Click RUNDIR ...  to display the file selection dialog. Choose a directory to save "jobfile1" and click Open.

NOTE: The RUNDIR directory was specified as C:\Users\Public\ in this example. Given the directory structure on your local computer, you may have chosen a different value for
RUNDIR.

4. Click PLATES ...  to view all defined study plates. From the list, hold Control  key (Command on macOS) and click the entries for 002 - Patient Entry Form and 009 - Adverse
Event Report to highlight them. Click OK. Choose FIELDS = include all.
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5. In the Optional panel set:

Check (enable) only calendar for Date Formats

String Size = as is

Field = use alias

Click OK to create and add jobfile1.

6. Click OK in the summary confirmation dialog.

7. Edit the SUBJECTS global specification in the new jobfile1 by selecting it from DFsas Jobs panel. In the main window, change the text SUBJECTS all to SUBJECTS 
99001,99002. This will limit the created SAS data files to subjects 99001 and 99002 only.
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8. Locate the global specifications for CHECK and CHOICE. Change CHECK codes to CHECK labels and CHOICE codes to CHOICE labels.

9. Click Save to save the changes. In the resulting confirmation dialog, choose replace existing job and click OK.

Create a SAS job file and data files using the DFsas job file criteria

1. In the DFsas window, highlight jobfile1. Click Run to create SAS job and data files.
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2. In the confirmation dialog, do not check Force DFsas to include all specified plates. The SAS job and data files will not include empty plates. Click OK to continue and run the
DFsas job. After a pause while the job runs, the results dialog appears. Click OK to close the dialog.

3. Using the file explorer, locate the directory previously specified as the value of RUNDIR. Confirm that jobfile1.zip is present. Double-click jobfile1.zip to unzip the file. Open the 
jobfile1 folder and confirm that the files jobfile1, jobfile1.sas, jobfile1.d01 and jobfile1.d02 are present.

4. With a text editor, open the data file jobfile1.d01. Examine the contents and confirm that it contains 2 data records - one for each of subjects 99001 and 99002. Print the file (you
will need to reference this printed output in “Compare the contents of SAS data files with the actual data in the database.” and then close the text editor application.

5. With the same text editor, open the data file jobfile1.d02. Examine the contents and confirm that it contains 1 data record. Print the file (you will need to reference this printed
output in “Compare the contents of SAS data files with the actual data in the database.” and then close the text editor application.

Compare the contents of SAS data files with the actual data in the database

1. Click Cancel  to dismiss the DFsas dialog. Select Select  > All Records . Without changing any settings, click OK.

2. Select View > Data  to change from List View to Data View. In the record list, double-click icon for the open Subject 99003 to close the subject binder. The list now displays all
subjects for Site 99 - Hospital #99.

3. Double-click Subject 99001. Select Subject  > Expand All Visits . Locate the entry for 2: Form 2 within the 1 : Baseline visit and select it from the list to open the data record.
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4. Compare the values in each field of the data record with those values in the printout of the data file jobfile1.d01.

5. Double-click Subject 99002 from the record list. Select Subject  > Expand All Visits . Locate the entry for 2: Form 2 within the 1 : Baseline visit and select it from the list to open
the data record.

6. Beginning with Subject 99002, Baseline, Form 2, compare the values in each field of the data record with those values in the printout of the data file jobfile1.d01.

7. Double-click Subject 99001 to re-open the subject binder. Select Subject  > Expand All Visits . Locate the entry for 9: form 9, AE Report 011 within the 1011: Adverse Event 1
Page 1 visit and select it from the list to open the data record.
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8. Compare the values in each field of the data record in DFexplore with those values in the printout of the data file jobfile1.d02.

9. Select File  > Exit  to close DFexplore.

End Module 15. Data Export and DFsas

Return to the DFATK application. Click End to confirm successful completion of Module 15. Data Export and DFsas.

Module 16. PDF File Creation

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
User accounts and roles:

datafax : Unrestricted
data_manager : Unrestricted

Client Tools Used: DFATK, DFexplore

Purpose: This module tests PDF file creation in DFexplore, including standard, bookmarked, and encrypted CRFs; blank CRFs; and complete subject packages.

Tests & Requirements

1. Retrieve existing data according to user-specified criteria.

2. Saving DFexplore data to a standard PDF document.

3. Saving DFexplore blank CRF books to a standard PDF document.

4. Viewing a standard PDF data file using a PDF viewer application.

5. Saving DFexplore data to an encrypted bookmarked PDF file.

6. Open and view an encrypted bookmarked PDF file using a PDF viewer application.

7. Create a complete subject package PDF file that includes data records, CRF images and audit trail.

8. Open and view a PDF subject package using a PDF viewer application.

Estimate of Time Required: 30 Minutes

Begin Module 16. PDF File Creation

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 16. PDF File Creation  followed by Begin  to begin this module.

Retrieve existing data according to user-specified criteria

1. Start DFexplore, login as user data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select Select  > By Data Fields . Set retrieval criteria as follows:

Mode = Validate
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Save level = 1 - Level 1

Search = Data

Subject = 99001,99002

Level = 1-4

3. Click Build Set  to retrieve all data records that match the specified criteria. Click OK in the confirmation dialog, and finally click Done to create a task set of the retrieved data.

4. Scroll the record list panel to confirm that 2 subjects, 99001 and 99002, have been retrieved. Double-click the entry for Subject 99002 to open and lock all records for the subject.

Saving DFexplore data to a standard PDF document

1. Select File  > Save as PDF.
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2. In the Selection Criteria panel,

Select (enable) Data and images followed by current task set

In the Save Options panel,

Check (enable) Data records and data + primary image (side by side)

Check (enable) Apply field color for completed plates

3. Click Output File ... . In the file selection dialog, choose a directory in which to save the PDF file. Once a directory has been chosen, append the file name subjects.pdf to the
directory name. Click Save.

4. Complete the specification by clicking Save. There will be a busy pause while the PDF file of completed data pages and their primary images is created.

NOTE: The save directory in this test was chosen to be C:\Users\Public. Your save directory may be different.

Saving DFexplore blank CRF books to a standard PDF document

1. Select File  > Save as PDF.
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2. In the Selection Criteria panel,

Select (enable) Blank CRF books, followed by all visits, all plates.

Un-check (disable) print subject id

Check (enable) print visit numbers

3. Click Output File ... . In the file selection dialog, choose a directory in which to save the PDF file.

Once a directory has been chosen, append the file name blanksubject.pdf to the directory name. Click Save.

4. Complete the specification by clicking Save followed by Yes in the resulting dialog. There will be a busy pause while the PDF file is created.

NOTE: The save directory in this test was chosen to be C:\Users\Public. Your save directory may be different.

Viewing a standard PDF data file using a PDF viewer application

1. A PDF viewer application, such as Acrobat Reader, is required for this step. Start the PDF viewer application. Locate the directory in which the PDF file subjects.pdf was saved in
“Saving DFexplore data to a standard PDF document.”. Open subjects.pdf.

NOTE: All PDF files opened in this test and in the remainder of this module are illustrated using Acrobat Reader. If you are using a different PDF viewer application, the
appearance of your document may differ from that shown here. It may also be necessary to rotate the PDF image so that it is displayed in landscape format.

2. Examine the PDF document.
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3. Locate the directory in which the PDF file blanksubject.pdf was saved in “Saving DFexplore blank CRF books to a standard PDF document.”. Open blanksubject.pdf.

4. Examine the PDF document. Confirm the PDF document was printed without the presence of Subject ID numbers.

5. Exit the PDF viewer application.

Saving DFexplore data to an encrypted bookmarked PDF file

1. With the task set of records from “Retrieve existing data according to user-specified criteria.” (Subjects 99001 and 99002) still the current set, click the record for Subject 99002,
Form 1 to set it as the current page. Select File  > Save As Bookmarked PDF to open the dialog.
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2. In the Selection Criteria panel,

Select (enable) Current subject

In the Resources panel,

Enter a Title of Bookmarked Subject 99002

Use the default Nesting plates within visits

In the PDF Options panel,

Check (enable) Data records

Check (enable) Missed records

Check (enable) Images and select (enable) primary only

Check (enable) Apply field color for data records

In the PDF Output panel,

Select an Output File directory using the file selection dialog and set the file name to subject99002.pdf.

3. Enter module16 as the value for Password.
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4. Click Save to create a password encrypted PDF file of completed data pages and primary images for Subject 99002.

5. Click OK to close the dialog.

Open and view an encrypted bookmarked PDF file using a PDF viewer application

1. A PDF viewer application is required for this test. Start the PDF viewer application. Locate the directory created in “Saving DFexplore data to an encrypted bookmarked PDF file.”.
Locate and open subject99002.pdf.

2. In the Password dialog enter module16 as the password. This matches the password that was specified at file creation in “Saving DFexplore data to an encrypted bookmarked
PDF file.”. Once the password has been entered, the PDF file opens.
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3. Open all bookmarks for Subject 99002.

4. In the bookmark panel, each data record is represented by the suffix (data) to distinguish it from the primary CRF image. Click entry Form 2 (data) to make the Form 2 data record
the active page. Click entry Form 2 to make the Form 2 primary CRF image the active page.

5. Exit the PDF viewer application. In DFexplore, select View > Data . Then, select Select  > All Records . This will release the task set of records for Subjects 99001 and 99002.
Click OK in the resulting dialog to retain the default settings.

Create a complete subject package PDF file that includes data records, CRF images and audit trail

1. Select File  > Create Subject Packages .
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2. In the Subject Selection section, choose Subjects from the drop-down and enter 99001,99002,99003 to create complete subject packages for Subjects 99001, 99002 and 99003.

3. In the remainder of the dialog specify the following settings:

Title = Site 99 Subject Packages

Check (enable) Data records

Check (enable) Missed records

Check (enable) Images

Check (enable) primary only

Check (enable) Include subject history in format and simplified

Check (enable) Apply field color for data records
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4. Specify a PDF output folder by first clicking Output folder ...  to view the directory structure for the local computer. Select a directory in which to save the subject package PDF
files.

5. Specify a file prefix to be prepended to each subject package created. Enter Site99_ in the File prefix field.

6. Do not encrypt the subject packages to be generated by leaving the Password field empty. Click Start  to begin generating a complete subject package for each of the specified
subjects 99001, 99002 and 99003.

7. Verify that the output in the confirmation dialog specifies packages for subjects 99001, 99002 and 99003. Click Start  to start package creation.
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8. In the confirmation dialog, click View Log. Review the output. Click OK to close the log.

9. The main Create Subject Packages dialog is displayed. Click Cancel  to close this dialog.

Open and view a PDF subject package using a PDF viewer application

1. A PDF viewer application is required for this test. Start the PDF viewer program. Locate and open the directory in which the PDF subject packages were saved in Step 7. Locate
files Site99_99001.pdf, Site99_99002.pdf and Site99_99003.pdf.

2. Open the subject package for Site99_99001.pdf.

3. Open all bookmarks for Subject 99001.

4. In the record list, each data record is represented by the term (data) to distinguish it from its primary CRF image. Click entry Form 2 (data) to make the Form 2 data record the
active page. Click entry Form 2 to make the Form 2 primary CRF image the active page.

5. In the bookmark list click the entry for Data and Metadata Change History to display the complete audit trail report for Subject 99001.

6. Exit the PDF viewer application to close both the file Site99_99001.pdf and PDF viewer.

7. Select File  > Exit  to close and exit DFexplore.

End Module 16. PDF File Creation

Return to the DFATK application. Click End to confirm successful completion of Module 16. PDF File Creation.

Module 17. DFweb Data Entry

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
DFws 5.11.0 installed and properly configured on DFws server
DFweb 5.11.0 installed and properly configured on DFweb server
DFdiscover license with DFWS license feature on the DFdiscover server
DFweb compatible browser installed on local test device

Mozilla Firefox
Google Chrome
Apple Safari
Microsoft Edge

User accounts and roles:
datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
site_invest : site_investigator

Email configured for site_monitor
(Optional) SMS or email 2-factor authentication configuration for site_invest

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFweb
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Purpose: This module tests all main DFdiscover functionality with respect to DFweb. Data capture, review, document management, and eSignature functionality. The module
additionally uses DFexplore to verify save data levels of data entered using DFweb.

Tests & Requirements

1. Verify DFweb version information, logging into DFweb and DFweb site certificate verification.

2. Resetting a user login password.

3. Copying URL and changing user passwords.

4. Creating a new subject, entering subject data.

5. Adding, modifying and resolving queries.

6. Adding, reviewing and downloading subject documents.

7. Add an Electronic Signature (eSign) to a set of completed subject records.

8. Verify removal and re-application of eSignatures.

9. Verify DFweb saves eSignature task data to the specified save level.

Estimate of Time Required: 25 Minutes

Begin Module 17. DFweb Data Entry

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 17. DFweb Data Entry  followed by Begin  to begin this module. Click Send ID 99008.

NOTE: Save the labreport99008_module17.pdf file received via email to your local computer. This file is required to complete Adding, reviewing and downloading subject
documents.. Refer to Creating user accounts and assigning study permissions. as a valid email address is required for data_coordinator, data_manager, site_monitor or site_invest
to receive the module specific PDF files.

Resetting a user login password

NOTE: All remaining tests performed in this module have been completed using Google Chrome. Results and/or test steps may vary with other browsers.

1. Open a web browser and navigate to https://dfweb.dfdiscover.com/login or the DFweb URL provided by your administrator, In the DFweb login dialog, enter the DFdiscover
Server name that has been provided by your administrator. Click Continue. enter site_monitor in the Username field of the login dialog, and click Forgot Password?.

2. In the Reset Password dialog, enter the username and email address associated with the site_monitor account and click Send Email . A confirmation message appears: Mail Sent
Successfully.

3. Open the password reset email from your DFdiscover server and click the provided link to reset the site_monitor password.

4. Enter and confirm a new password, then click Update .
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5. A message confirming Password changed successfully. is displayed in your browser, and a notification email is sent to the address associated with the site_monitor account.

Verify DFweb version information, logging into DFweb and DFweb site certificate verification

1. Open a web browser and navigate to https://dfweb.dfdiscover.com/login or the DFweb URL provided by your administrator, Click  Settings, verify the version information:
DFweb Version 5.11.0 is displayed.

2. Enter site_monitor in the Username field and the previously assigned password in the Password field. Click Login  to login.
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3. A list of subjects for Hospital #99 is displayed.

4. Click the View Site Information icon from the web browser address bar. Select Connection is secure > Certificate is valid. The website trust certificate is displayed for the
current DFweb address, click OK or X to close the window.
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Copying URL and changing user passwords

1. From the Subjects list, click Subject 99002 to open the 0: Screening Visits 1:Form 1 page.

2. Copy the DFweb URL by clicking  > Copy URL.

3. Open a new browser tab, paste the copied URL into the new browser tab, click Enter . The pasted URL in the new tab re-directs you to the DFweb login page. Login again using 
site_monitor credentials, upon logging in confirm you are taken to the same subject data record as the previous web browser tab. Close the web browser tab.

4. Click  > User Profile  > Change Password  to view the Change Password window. Click Cancel .

Creating a new subject, entering subject data

1. Click  Subjects , select 99010 to open the 0: Screening Visits 1:Form 1 page.

2. Click Patient Initials enter ARX, Set:

Age (years) = 49

Sex = male

Race = caucasian

Screen 1 Date = Click  icon, select 11-Nov-2018

Click .
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3. Select 1:Baseline > 21:Lab Results page. Click Patient Initials field.

NOTE: The SetInitedit check executes upon entry to the field. If the initials are available on 1 : Form 1 (previously entered), they are retrieved and populate the Patient
Initials field.

4. Set the remaining fields within the 21: Lab Results form as follows:

Collection Date = 13-NOV-2018

White Blood Cell = 15.3, Check (enable) NORMAL

Red Blood Cell = 04.3, Check (enable) NORMAL

Hemoglobin = 14.2, Check (enable) NORMAL

Mean Cell Hemoglobin Conc = 46.5, Check (enable) ABNORMAL
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5. Click  to open the Reason for Data Value dialog. Click ...  next to Reason. The DFlookup: REASON dialog is displayed.

6. Select the Result of Confirmed, this value is correct as entered., Click OK, followed by Apply  then .

7. Select 51: Medication Log Page 1 > 8: Form 8, Pg 51 page. Click Patient Initials field.

NOTE: The SetInitedit check executes upon entry to the field. If the initials are available on 1 : Form 1 (previously entered), they are retrieved and populate the Patient Initials
field.
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8. Press Tab. In the Medication Log Page Number field, enter values 1 of 1.

9. Press Tab to advance to 1. Drug Name field. Enter Vitamin B-12 in the 1. Drug Name text field, press Tab. Upon leaving the field, an edit check is executed and DFlookup:
drugs dialog appears.
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10. Enter vitamin b12 in the Search Terms, Check Match ALL terms and click  to filter the results.

11. Select the result of vitamin b12 from the table. Click OK. The 1. Drug Name field becomes auto-populated with vitamin b12 result.

12. Beginning with the Type of Change field complete the remaining data fields as follows:

Type of Change = Select New Drug

Date of Change = Select 15/11/18

Current Total Dose Per Day = 250

Reason for Change = Increased Mean Cell Hemoglobin Conc.

Click .
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13. Select 1: Baseline > 4 : Form 4, Pg 1. Click  > Set Page Missed to open the Set Page Missed dialog.

14. In the dialog, choose Other Reason value from the Reason pull-down list. Enter Medication information provided on the Medication Log Page. as the Detail.
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15. Click Apply  to register the page as missed.

16. Click  Subjects , select 99009 > 1: Baseline > 2: Form 2. Click  > Unset Page Missed to open the Unset Missed Page dialog.

17. Enter a reason of Data to be captured during chart review.. Click Apply
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Adding, modifying and resolving queries

1. From the sidebar bar, Click . Locate and select the outstanding query for Subject 99008 > 0:Screening Visits > 1:Form 1.

2. Change 6. Systolic and diastolic BP criteria from 'Yes' to 'No', Click  then , select Resolved from the Status drop-down list. Click Apply  > Close and  to save the
data record changes.
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3. Click 99008 > 1:Baseline > 2: Form 2. Select Date of Birth (dd/mm/yyyy) query. Correct Date of Birth (dd/mm/yyyy) to 14/01/1968.

4. Click  then , select Resolved from the Status drop-down list. Click Apply  > Close to save the query changes. Click .
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5. Click 21: Lab Results, select the outstanding query. Click . Enter Lab value confirmed as out of range. in the Reason field. Click Apply , followed by .

6. Click .

7. Within the Queries Overview dashboard, click Outstanding (Red portion) under the All Queries by Status pie chart. The Queries Overview table is displayed showing all
outstanding queries for the site.

8. In the Queries Overview table locate and select the outstanding query for subject 99009.

9. Select Asian in the Race field. Click Save.
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10. Return to the Dashboard page by Clicking .

11. Click , within the Queries Overview dashboard, click Outstanding under the All Queries by Status pie chart. The Queries Overview table is displayed showing all
outstanding queries for the site. Confirm the outstanding query for subject 99009 is no longer present.

Adding, reviewing and downloading subject documents

1. From the sidebar, select Subjects > 99008 > 1: Baseline > 21: Lab Results. Click  > Manage documents to open the Manage documents window.
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2. Click Choose Files , select the previously saved labreport99008_module17.pdf (Refer to Step 2). Click Open > Upload to upload the document.

3. Click  to view the newly uploaded document.
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4. The document can be zoomed in/out by using the navigation buttons within the document window.

5. Click Close to close the Manage Documents window. Notice the  icon has now changed to  indicating the data record now has associated documents.

6. Click  > Logout  to exit DFweb.

Add an Electronic Signature (eSign) to a set of completed subject records

NOTE: eSignatures require password permission to be set in the user role at the DFadmin level. The Password permission must be granted for the specific eSignature plate.

1. In the DFweb login dialog, enter site_invest in the Username field and the previously assigned password in the Password field. Click Login  to login.

2. As user site_invest has 2FA enabled, enter security code received by email or SMS as previously defined.

NOTE: Refer to Creating user accounts and assigning study permissions. as a valid email address or phone number is required for site_invest to receive 2FA codes.

3. From the Subjects list, click Subject 99011 > 30: Study Termination > 7: Form 7.

4. Click Patient Initials enter SIG, Set:

Final Visit Date = 03/06/22

1. Did the patient complete the entire 16 week study? = No

Check (enable) Moved away

2. Last dose of study medication was taken on = Check (enable) Unknown

Click  to save and eSign the Study Termination form.
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5. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password. Click Sign to apply the electronic signature to the current page.

6. In the DFexplore - eSignature Reason dialog select Approved from the dropdown, click OK.

7. Examine the 4 eSignature fields at the bottom of the page.

8. Click  > Logout  to exit DFweb.

 Verify removal and Re-application of eSignatures

1. In the DFweb login dialog, enter site_monitor in the Username field and the previously assigned password in the Password field. Click Login  to login.

2. From the Subjects list, click Subject 99011 > 30: Study Termination > 7: Form 7.

3. Click 2. Last dose of study medication was taken on field. Click  to open the Add Query dialog. In the dialog, set:

Category = Monitor

Enter Investigator to confirm last dose taken with subject during clinic visit. in the Note field.

Click Apply  > Close.

4. Press Tab to advance to the Unknown field. Un-check (disable) the checkbox. Click .
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5. Click  > Logout  to exit DFweb.

6. In the DFweb login dialog, enter site_invest in the Username field and the previously assigned password in the Password field. Click Login  to login.

7. From the sidebar, Click Tasks.

8. Locate the eSignatures - Study Termination - eSignatures task. Click Start .
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9. From the Subjects list, click Subject 99011 > 30: Study Termination > 7: Form 7.

10. Click the 2. Last dose of study medication was taken on field. Click  then . Select Resolved from the Status drop-down list. Enter Confirmed date of last medication dose 
verbally with subject during clinic visit. in the Note field. Click Apply  > Close.

11. Enter the 2. Last dose of study medication was taken on date as 02/06/22. Click .

12. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password used for login in Add an Electronic Signature (eSign) to a set of completed
subject records.. Click Sign to apply the electronic signature to the current page.

13. In the DFexplore - eSignature Reason dialog select Reviewed from the dropdown, click OK.
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14. Examine the 4 eSignature fields at the bottom of the page.

15. Click Close x  to close Tasks view. In the resulting warning dialog click Continue.

16. Click  > View Page History  to open the Page History window. The Page History is displayed, Click OK to close the window.

17. Click , enable (toggle on) Grouped View.
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18. Select History of Changes under the Subject Tracking reports list.

19. Enter 99011 in the Subject field, click Date Range in the resulting dialog select the current date and click OK > Run. The History of Changes report updates to display the
requested data. Click X to close the report.
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20. Click  > Logout  to exit DFweb.

Verify DFweb saves eSignature task data to the specified save level

1. Start DFexplore, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select View List . Click 007 - Study Termination. Confirm DFVALID displays as "4" for subject 99011.

3. Select File Exit  to close DFexplore.

End Module 17. DFweb Data Entry

Return to the DFATK application. Click End to confirm successful completion of Module 17. DFweb.

Module 18. DFcollect Mobile Data Collection

Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
DFws 5.11.0 installed and properly configured on DFws server
Valid DFdiscover license with DFWS and DFCOLLECT license features on DFdiscover server
Mobile Device with DFcollect 5.11.0 installed from the Google Play Store or Apple App Store

Mobile Device requires Android™ 10 or later, or iOS®/iPadOS® 16 or greater
Mobile Device will also need to have access to network to send live data to DFdiscover

User accounts and roles:
datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
site_invest : site_investigator

(Optional) SMS or email 2-factor authentication configuration for site_invest

NOTE: For configuration of 2-factor authentication, see Module 1(Installation & Initialization) test step 6 for details on configuring accounts with 2-factor authentication

Client Tools Used: DFATK, DFexplore, DFcollect

Purpose: This module tests the functionality of DFcollect to test online and offline data entry, data review, query resolution, document management, and eSignatures. Data entered
with DFcollect is then verified with DFexplore.

Tests & Requirements

1. Installation and App preferences.

2. Resetting a user login password.

3. Online data record creation.

4. Download subject data for offline use.

5. Create data records in offline mode, query resolution and adding reasons for data values.

6. Sync data collected offline to your DFdiscover server.

7. Clearing DFcollect cache.
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8. Adding, reviewing and downloading subject documents.

9. Confirming data sent to the server using DFexplore.

10. Add an Electronic Signature (eSign) to a set of completed subject records.

11. Verify removal and re-application of eSignatures.

12. Verify DFcollect saves eSignature task data to the specified level.

13. Verify no saved data remains upon uninstallation and reinstallation of DFcollect.

Estimate of Time Required: 35 Minutes

Begin Module 18. DFcollect Mobile Data Collection

1. Start DFATK as described in Module 1 (Installation & Initialization).

2. Click 18. DFcollect Mobile Data Collection  followed by Begin  to begin this module.

Installation, App preferences

1. Download and install DFcollect from Google Play™ or Apple® App Store® to your mobile device or tablet, or use the link provided by your administrator.

2. Open DFcollect.

3. Click  > Preferences. Set:

System Setting

API Server = your API servername

Offline Only = Disabled (greyed out)

Click Close to apply settings.
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4. Click  > About DFcollect  Confirm that the version information in the about dialog matches the installed DFcollect Version 5.11.0. Click Close to return to the DFcollect login
screen.

Resetting a user login password

1. Click  > Forgot Password?.

2. In the Forgot Password dialog, enter the DFdiscover Server name that has been provided by your administrator, enter site_monitor in the Username field and enter the email
address associated with the site_monitor account and click OK. A confirmation message appears: A password reset link has been sent to your email account.
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3. Open the password reset email from your DFdiscover server and click the provided link to reset the site_monitor password.

4. Enter and confirm a new password, then click Update .

5. A message confirming Password changed successfully. is displayed in your browser, and a notification email is sent to the address associated with the site_monitor account.

Online data record creation

1. Return to DFcollect. In the DFcollect login dialog, enter the name for DFdiscover Server that has been provided by your administrator. Enter site_monitor in the Username field
and the previously assigned password in the Password field. Click Login  to login.
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2. From the list of available studies, click 254 Acceptance Test Study, if not already opened.

3. Click 99: Hospital #99 to display a list of available subjects.

4. Click  > Study Help  to view any study related help messages. Click Close to close the Study Help  window.
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5. Click  to open Dashboard view.

6. Click View Outstanding Queries located underOutstanding Queries by Type to view all outstanding queries.
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7. Click Close to return to the subject listing.

8. Click  to search for a subject ID number, enter 99010. Click , subject 99010 : (Final) gains the focus.

9. Click subject 99010 : (Final) to view the list of study visits.

10. Click 1: Baseline > 2: Form 2. Plate Form 2 becomes the active page.
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11. Click Patient Initials. The initials automatically populate this field as a result of the edit check SetInitdescribed in Module 8. Image Data Entry. Set:

Entry Date = Click , select 14/11/18.

Medication Code # = 2524

Date of Birth = Click , select 11/05/1969.

Click .

12. Click  >  > 99009 : (Incomplete) > 21: 1 Month Follow-up > 5: Form 5, 1 Month.
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13. Click Patient Initials. The initials automatically populate this field as a result of the edit check SetInitdescribed in Module 8. Image Data Entry. Set:

Visit Date = Click , select 14/11/18.

Click .

14. Click  >  > 99010 : (Incomplete) 51: Medication Log Page 1 > 8: Form 8, Pg 51.

DFdiscover 5.11.0 Acceptance Test Manual Page 249 of 313



15. Enter Pred in the 2. Drug Name text field, select the Type of Change field. Upon leaving the field, an edit check is executed and DFlookup: drugs dialog appears.

16. Enter prednisone in the Search Terms, Check Match ANY terms. Click Search to filter results.
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17. Locate the entry for prednisone in the results table. Double-click the entry to auto-populate the field. The 2. Drug Name field is auto-populated with prednisone, the field contains
a Reason for Data Value and Type of Change field gains focus.

18. Beginning with the Type of Change field complete the remaining data fields as follows:

Type of Change = Select New Drug

Date of Change = Select 22/11/18

Current Total Dose Per Day = 250

Click .

 Download subject data for offline use

1. Click  > Storage & Syncing .
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2. Click  to show the subject listing for 99: Hospital #99.

3. Check (enable) subjects 99008: 0 visits, 99009: 0 visits and 99010: 0 visits.
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4. Click  to download the subjects. After completion, click OK to dismiss the Download Progress: Data window. Upon successful download there is an  icon showing the date
and time the download was performed.

5. Click  > Logout  to logout of DFcollect.

Create data records in offline mode, query resolution and adding reasons for data values

1. Click  > Preferences > Offline Only toggle button to enable Offline Only mode (becomes green). Click Close.

2. In the DFcollect login dialog, enter the name for DFdiscover Server that has been provided by your administrator. Enter site_monitor in the Username field and the previously
assigned password in the Password field. Click Login  to login.
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3. Click 99: Hospital #99 > 99009 : (incomplete) > 21: 1 Month Follow-up > 5: Form 5, 1 Month. Set:

Blood Pressure: Reading 1: systolic = 142, diastolic = 097

Blood Pressure: Reading 2: systolic = 134, diastolic = 091

Blood Pressure: Arm = Right

Weight (lbs) = Click , select Missing Value from the Code drop-down list. Click Apply .

Click . Click Cancel  in the resulting Add Query dialog.

4. Click  > 21: Lab Results.
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5. Click Patient Initials. The initials automatically populate this field as a result of the edit check SetInitdescribed in Module 8. Image Data Entry, Set:

Collection Date = Click , select 11-NOV-2018.

White Blood Cell = 07.8, check (enable) NORMAL

Red Blood Cell = 02.9 check (enable) NORMAL

Hemoglobin = 06.5, check (enable) ABNORMAL

Mean Cell Hemoglobin Conc = 14.1, check (enable) NORMAL

6. Click , to the right of the Hemoglobin “[ABNORMAL/NORMAL]” field.

7. Click ...  next to Reason. The DFlookup: REASON dialog is displayed.
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8. Select the Result of Confirmed, this value is correct as entered., Click OK, followed by Apply  then Click .

9. Return to the subject listing for 99: Hospital #99 by clicking  > .
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10. Click  > Query View to view outstanding queries.

11. Locate and select the outstanding query for subject 99009 > Pulse(beats/min) field. Click Open. The Pulse(beats/min) field gains focus.

12. Click  next to the Pulse field. In the Reason field specify Value of 95 for pulse is confirmed.. Click Apply  > .

13. Click  to return to Query View. Confirm the outstanding query for 99009 > Pulse(beats/min) field is no longer present. Click Close.
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14. Click 99008 : (Final) > 1: Baseline > 2: Form 2. In the Date of First Study Follow-up field click , select 14/11/18.

15. Click . In the Reason field specify Subject has to reschedule due to conflict.. Click Apply  > .
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16. Return to the subject listing for 99: Hospital #99 by clicking  > . Re-open Query View by clicking  > Query View.

17. Locate and select the outstanding query for subject 99009 > Age (years). Click Open. The Age (years) field gains focus.

18. Correct Age (years) from 44 to 68. Click  > , select Resolved from the Status drop-down list. Click Apply  > Close.
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19. Click Race. Select african american, the query box changes from outstanding to resolved. Click .

20. Click  to return to Query View. Confirm the outstanding query for 99009 > Age (years) and Race fields are no longer present. Click Close.
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21. Click 99010 : (Incomplete) > 1: Baseline > 2: Form 2. Set:

Weight (lbs) = 267.0, click OK in the resulting dialog.

Height (in) = 072.8

Pulse = click , select Missing Value from the Code drop-down list.

Smoking Status = Never smoked

Date of First Study Follow-up = Click , select 05/12/18.

Click .

NOTE: The Weight (kgs) and Height (cm) fields are auto-populated as a result of edit checks.

22. Click  > Logout , to logout of DFcollect.

Sync data collected offline to your DFdiscover server

1. Click  > Preferences > Offline Only toggle button to disable the Offline Only mode (becomes greyed out). Click Close.

2. In the DFcollect login dialog, enter the name for DFdiscover Server that has been provided by your administrator. Enter site_monitor in the Username field and the previously
assigned password in the Password field. Click Login  to login.
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3. Upon logging into DFcollect, the  icon is displayed next to 99: Hospital #99 indicating there are cached changes in DFcollect that have not been saved to the database.

4. Click  > Storage & Syncing .
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5. Click  to expand list of subjects. Check (enable) subjects 99008: 2 Visits, 99009: 3 visits and 99010: 3 visits.

6. Click  to upload the previously entered subject data. When the upload is complete, click OK to dismiss the Upload Progress window. The  icon shows the date and time of
successful upload.

Clearing DFcollect cache

1. Check (enable) subjects 99008: 2 visits , 99009: 3 visits and 99010: 3 visits.
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2. Click  then Apply  within the Delete Records from Storage dialog. The  icon showing the date and time are cleared.

Adding, reviewing and downloading subject documents

1. Click  > 99008 : (Final) > 1: Baseline > 21: Lab Results.
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2. Click  to view the attached documents.

3. Click  > Logout .

Confirming data sent to the server using DFexplore

1. Start DFexplore, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select Site 99: Hospital #99 > subject 99009 > 0: Screening Visits > 1: Form 1. Verify and review the data uploaded is correct.

Age (years) = 68 with a resolved corrected query.

Race = 2 (african american) with a resolved corrected query.

3. Select File > Exit  to close DFexplore.

Add an Electronic Signature (eSign) to a set of completed subject records

NOTE: eSignatures require password permission to be set in the user role at the DFadmin level. The Password permission must be granted for the specific eSignature plate.

1. In the DFcollect; login dialog, enter the DFdiscover Server name that has been provided by your administrator. Enter site_invest in the Username field and the previously
assigned password in the Password field. Click Login  to login.

2. As user site_invest has 2FA enabled, enter security code received by email or SMS as previously defined.

NOTE: Refer to “Creating user accounts and assigning study permissions.” as a valid email address or cell phone number is required for site_invest to receive 2FA codes.

3. From the Subjects list, click Subject 99011 > 30: Study Termination > 7: Form 7.
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4. Click Patient Initials enter SIG, Set:

Final Visit Date = 03/06/22

1. Did patient complete the entire study? = No

Check (enable) Why? Moved away

Check (enable) 2. Last dose of study medication: Unknown

Click . to save and eSign the Study Termination form.

5. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password. Click Sign to apply the electronic signature to the current page.

6. In the DFcollect - eSignature Reason dialog select Approved from the dropdown, click OK.

7. Examine the 4 eSignature fields at the bottom of the page.

8. Click  > Logout  to exit DFcollect.

Verify removal and re-application of eSignatures

1. In the DFcollect login dialog, enter the DFdiscover Server name that has been provided by your administrator. Enter site_monitor in the Username field and the previously
assigned password in the Password field. Click Login  to login.

2. From the Subjects list, click Subject 99011 > 30: Study Termination > 7: Form 7.

3. Click 2. Last dose of study medication: Date field. Click  to open the Add Query dialog. In the dialog, set:

Category = Monitor

Enter Investigator to confirm last dose taken with subject during clinic visit. in the Note field.
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Click Apply  > Close to apply the query.

4. Advance to the 2. Last dose of study med: Unknown field. Un-check (disable) the checkbox. Click .

5. Click  > Logout  to exit DFcollect.

6. In the DFcollect login dialog, enter the DFdiscover Server name that has been provided by your administrator. Enter site_invest in the Username field and the previously
assigned password in the Password field. Click Login  to login.

7. Click  > Task listing .

8. Locate the eSignatures - Study Termination - eSignatures task. Click Open.
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9. From the Subjects list, select subject 99011 > 30: Study Termination > 7: Form 7. Click Open

10. Click the 2. Last dose of study medication: Date field. Click  then . Select Resolved from the Status drop-down list. Enter Confirmed date of last medication dose verbally 
with subject during clinic visit. in the Note field. Click Apply , Close.

11. Enter the 2. Last dose of study medication: Date as 02/06/22. Click .

12. In the dfpassword confirmation dialog enter the user name site_invest and the corresponding password used for login in “Add an Electronic Signature (eSign) to a set of
completed subject records.”. Click Sign to apply the electronic signature to the current page.

13. In the DFcollect - eSignature Reason dialog select Reviewed from the dropdown, click OK.
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14. Examine the 4 eSignature fields at the bottom of the page.

15. Click  > Page History  to open the Page History window. The Page History is displayed, Click OK to close the window.

16. Click  > Logout  to exit DFcollect.

Verify DFcollect saves eSignature task data to the specified level

1. Start DFexplore, login as data_manager and choose 254 Acceptance Test Study as described in “How to start DFexplore”

2. Select View > List . Click 007 - Study Termination. Confirm DFVALID displays as "4" for subject 99011.

3. Select File  > Exit  to close DFexplore.

Verify no saved data remains upon uninstallation and reinstallation of DFcollect.

1. In the DFcollect login dialog, enter the name for DFdiscover Server that has been provided by your administrator. Enter site_monitor in the Username field and the previously
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assigned password in the Password field. Click Login  to login.

2. Click  > Storage & Syncing .

3. Click  to show the subject listing for 99: Hospital #99.

4. Select at least one subject id that contains data, and click  to download the subject(s). After completion, click OK to dismiss the Download Progress: Data window. Upon
successful download there is an  icon showing the date and time the download was performed.

5. Click  > Logout  to logout of DFcollect. Then, close the application.

6. Using your mobile device’s normal unistallation tools, uninstall/remove DFcollect from the device.

7. Using the same steps from the Installation, App Preferences section of this chapter, re-install DFcollect on your device. Once done, re-open the application and log in as 
site_monitor.

8. Click  > Storage & Syncing , then  to show the subject listing for 99: Hospital #99.

9. Check the subjects that you had previously downloaded in step 4, verify that there is no existing data downloaded for this subject. There should be no  icon indicating that the
subject has stored data, and the option to delete the subject data should not be present.

10. Logout of DFcollect and close the application as in step 5

End Module 18. DFcollect Mobile Data Collection

1. Return to the DFATK application. Click End to confirm successful completion of Module 18. DFcollect.

Module 19. DFengage ePRO Data Entry
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Overview

Prerequisites:

Completion of module 1 of Acceptance Test Kit
DFws 5.11.0 installed and properly configured on DFws server
DFweb 5.11.0 installed and properly configured on DFweb server
DFengage 2.5 installed and properly configured on DFengage server
Valid DFdiscover license with DFWS and DFENGAGE features on DFdiscover server
Mobile Device with DFengage installed from the Google Play Store or Apple App Store

Mobile Device requires Android Version 8.0 or higher, or iOS version 14.4 or higher
Mobile Device will also need to have access to network to send live data to DFdiscover

User accounts and roles:
datafax : Unrestricted
data_manager : Unrestricted
site_monitor : site_monitor
dfeproagent created according to System Administrator User Guide

Client Tools Used: DFATK, DFexplore, DFadmin, DFsetup, DFweb, DFengage

Purpose: This module tests all functionality related to the DFengage mobile and web applications for ePRO data capture from study participants. It includes the creation of ePRO user
accounts in DFadmin and the management of ePRO users in DFweb as well as verification of data submitted from DFengage in DFexplore.

Tests & Requirements

1. Create DFengage users role in DFadmin

2. Add bulk DFengage users accounts to DFadmin

3. Installation and initial DFengage login.

4. Complete a task in online mode.

5. Complete a task in offline mode.

6. Sync data collected offline to your DFdiscover server.

7. Resetting a user login password.

8. Enter data in DFengage web.

9. Configure and receive DFengage notifications.

10. Confirm data sent to the server using DFexplore.

Estimate of Time Required: 35 Minutes

Begin Module 19. DFengage ePRO Data Entry

1. Start DFATK as described in Module 1 (Installation & Initialization).

2.  Click 19. DFengage ePRO Data Entry  followed by Begin  to begin this module.

Create DFengage users role in DFadmin

1. Start DFadmin. Login to your DFdiscover Server as datafax.

2. Specify a Username and datafax, and the assigned user password in the Password field. Click Login . to complete login and continue.

3. Create a role for DFengage users. Begin this task by clicking the Roles tab.

4. Within the list of studies, locate and choose the entry for 254 Acceptance Test Study. Click New to add a new user role. In the dialog, enter the role name ePROdata.

5. Click Create  to create the new role ePROdata.

6. Define Tools & Reports permissions for the ePROdata role. Highlight ePROdata in the Roles list to make it the active role. Enter ePROdata user permissions in the Description
field.

7. Click Tools & Reports tab below the Description field. Set each of the following:

In the DFexplore & API Clients panel,

Check (Enable) Data within DFexplore Views

Check (Enable) DFengage and DFweb within API Clients

In the Server & DFsetup panel,

Check (Enable) View within Setup
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8. Click Permissions tab.

9. Set plates 31-34 data permissions as follows:

Visits = 301-303,310-319

Plates = 31-34

Levels = ALL

Modify = 1-5

Write Levels = 1

Data = Check (enable) CM (Create, Modify)

Reasons = Check (enable) M (Modify)

10. Set plate 30 data permissions as follows:

Visits = 300

Plates = 30

Levels = ALL

Modify = 1

Write Levels = 1

11. Select File  > Save or click Save to save settings for role ePROdata.

12.  Select site_monitor to make it the active user. Click ePRO Admin Permissions.

13. To assign a study to site_monitor, click the blank area below the Study heading. Select 254 Acceptance Test Study from the Study drop-down. Set:

Type = Admin

Sites = 99

Select File  > Save or click Save.

14.  Select dfeproagent to make it the active user. Click the Permissions tab and assign add a row for the ATK study:

Study = 254 Acceptance Test Study
Sites = ALL
Subjects = ALL
Role Name = ePROdata

Select File  > Save or click Save.

Add bulk DFengage users accounts to DFadmin

1. Still as datafax and with the DFadmin application open, click Users tab to open the user definition window.

2. Click Add Bulk Users .

3. In the resulting Add Bulk Users dialog, set:

Study = Select 254 Acceptance Test Study - Role = Select ePROdata

Username Prefix = atk_

Subjects Range = 99001-99015

Check (enable) Preview usernames
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Set an Initial Password by entering a password of your choice.

Click Add 15 user accounts , in the resulting confirmation dialog click Yes to add the defined user accounts.

Click Close.

IMPORTANT: Remember the password assigned in this step as it is needed in future tests.

4. Choose the atk_99015 entry from the list of users. Click Permissions tab. Confirm the following permissions are set:

Study = Select 254 Acceptance Test Study

Sites = 99

Subjects = 99015

Role Name = ePROdata

5. Select File  > Save > Exit  to close DFadmin.

6. Open a web browser and navigate to. https://dfweb.dfdiscover.com/?server=explore.dfdiscover.com&api=dfws.dfdiscover.com or the DFweb URL provided by your administrator,
enter site_monitor in the Username field of the login dialog, and the previously assigned password in the Password field. Click Login  to login.

7. From the sidebar, Click  ePRO. Locate the subject 99015 with username atk_99015, click Register.

8. In the resulting ePRO Subject Registration dialog set:

Name = yourname

Email = youremail

Language = default

Timezone = Your local timezone

Confirm Subject ID = 99015

Toggle (enable) = Send invite via email

Toggle (enable) = I verify the name and contact information above is correct and belongs to the specified participant.

Toggle (enable) = I verify the participant has provided informed consent and is eligible to participate

Click Register  > OK.

DFdiscover 5.11.0 Acceptance Test Manual Page 273 of 313

https://dfweb.dfdiscover.com/?server=explore.dfdiscover.com&api=dfws.dfdiscover.com


9. Click View invitation , confirm the displayed invite is the same as the one received to your email address specified in the previous step. Click Click here to activate your account.

10. Enter the email address specified during the ePRO Subject Registration process. Click Confirm Email . A confirmation dialog is displayed presenting the information below.

11. Close the DFengage web browser window.

Installation and initial DFengage login

1. Open a web browser and navigate to. https://dfweb.dfdiscover.com/?server=explore.dfdiscover.com&api=dfws.dfdiscover.com or the DFengage web URL provided by your
administrator, enter site_monitor in the Username field of the login dialog, and the previously assigned password in the Password field. Click Login  to login.

2. From the sidebar, Click  ePRO. Select subject 99015 with username atk_99015 to open the ePRO Subject Details dialog.

3. Click Get link/QR code and under the Login Link section use the link or QR code to install DFengage, and then once it’s installed click the link or scan the QR code again to auto-
fill the server, API, and username

4. Open DFengage.

5.  Click Get Started.

6. Enter the previously assigned password in the Password field. Click Login  to login. The change password dialog is presented. Enter a password of your choice, click Set new
password .

7. The Pincode setup dialog is presented. Enter any 4-digit numeric pincode. Click Continue.

8. DFengage may ask to enable notifications. Click Allow or follow your device’s instructions to enable notifications. If no such prompt appears, proceed to step 11
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10. DFengage may ask to run in the background. Click Allow Background Running  and follow any steps needed to enable background running. If no such prompt appears, proceed to
step 11.

11. Select default from the Pick Your Language dropdown, click Continue. The DFengage training prompt is displayed. Click Learn about DFengage now.
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12. Proceed through the tutorial by clicking Next  until you reach the end of the first section. Click Learn More About DFengage to continue to the second section of the tutorial.

13. Click Next  to proceed until all training slides are complete. Click See Today’s Activities  to proceed to the main activity page.

Complete a task in online mode

1. Click Start  next to eDiary Day 1.

2. Click Today's date, Select a date of 01 Jun 2023. Click OK, the date field is displayed as 01/06/2023. Click Next .
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3. Complete the remaining eDiary Day 1 questions by entering the following and clicking Next  on each screen:

What time is it? = 14:45, the time field is displayed as 14:45:00. Click OK

The first set of questions relate to reactions at or around the site of vaccination.

Is there redness? = Y

Maximum severity of redness = Does not interfere with activity.

Medication taken for redness? = N

Check the box next to each symptom you have experienced today:

Nausea = Checked (enabled)

Headache = Unchecked (disabled)

Fatigue = Checked (enabled)

Joint Aches = Unchecked (disabled)

Muscle Aches = Unchecked (disabled)

No Symptoms = Unchecked (disabled)

On a scale of 1 to 10, with 1 being the least and 10 being the worst pain imaginable , how severe were your symptoms today? = 7

Please take your temperature using the provided thermometer. Record your temperature here (degrees F) = 98.4

Click Finish .

4. Click Yes to confirm your submission.

5. Click the History  button to open the history page. The completed eDiary Day 1 displays as Sent with the date and time sent.
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6. Click View for the sent eDiary Day 1 entry. Confirm that the fields are unable to be changed.

7. Close the DFengage application.

Complete a task in offline mode

1. Switch your device to airplane mode or otherwise disconnect from the internet.

2. Open DFengage, login with your pincode. Click Start  next to eDiary Day 2 (plate 32).
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3. Click Today's date, Select a date of 02 Jun 2023. Click OK, the date is displayed as 02/06/2023. Click Next .

4. What time is it? enter 17:30, click OK, the time field shows as 17:30:00. Click Next .

5. Confirm you have reviewed the instructions by checking (enabling) Read and Understood (Continue to next screen). Complete the remaining eDiary Day 2 questions by
entering the following and clicking Next  on each screen:

Pain = Quite a bit

Redness = Not at all

Swelling = A little bit

Itching = A little bit

Nausea/Vomiting = Not at all

Headache = Not at all

Fatigue = Very Much

General feeling unwell = Quite a bit

Joint aches = Not at all

Muscle aches = A little bit

Other Symptoms? = N

Did you take medication for any of these symptoms? = N

6. Click Finish  > Yes to save the questionnaire.

7. Click History , confirm eDiary Day 2 as Pending with the current date and time of completion, and eDiary day 1 is synced (displayed as Sent).
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8. Close DFengage application.

Sync data collected offline to your DFdiscover server

1. Switch off airplane mode on your device or otherwise re-connect to the internet.

2. Open DFengage, login with your pin code. Go to History  and confirm you are shown as online. If the eDiary Day 2 questionnaire is still shown as Pending, click Sync to send the
questionnaire to the server. Once complete, confirm that eDiary Day 2 is shown as sent with the expected date and time.

3. Close DFengage application.

Resetting a user login password

1. Open a web browser and navigate to. https://dfengage.dfdiscover.com/?server=explore.dfdiscover.com&api=dfws.dfdiscover.com or the DFengage web URL provided by your
administrator.

2. Enter a Username of atk_99015. Click the Forgot Password  link on the login page. In the Forgot Password dialog:

Enter the email address associated with the atk_99015 account

Click OK.

You should see a confirmation message: Email Sent.

3. Open the password reset email from your DFdiscover server and click the provided link to reset the atk_99015 password.

4. The DFengage web Set New Password page is opened. Enter and confirm a new password, then click Create Password .
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5. A message confirming Password set. Logging in. is displayed in your browser, and a notification email is sent to the address associated with the atk_99015 account. You are
logged into DFengage web.

6. Return to DFweb login as user site_monitor and Click  ePRO. Select subject 99015 with username atk_99015 to open the details dialog.

7. Under View logs:

Click ePRO account log to verify registration audit trail, Click Back.

Click ePRO access log to verify login, start and submit activity, Click Back.

Click Get link/QR code under Login Link, then click Copy Link.

Enter data in DFengage Web

1. Open a web browser and paste the previously copied login link into the address bar. Confirm that the DFengage 2.5.0 version is displayed, and that the Username and Server
Name fields are auto-populated.

2. In the DFengage login dialog, enter the assigned password in the Password field. Click Login .

3. Select default from the list of Available Languages, click Continue.

4. Click Next  to proceed through all training slides. Once complete, click See Today’s Activities  to continue to the main activity page. From there, open the activity labeled eDiary
Day 7.

5.  Click the date selector icon, verify that a future date cannot be selected and select a date of 10 Oct 2025. Click OK, the date field is displayed as 10/10/2025. Click Next .

6. Complete the remaining eDiary Day 7 questions by entering the following values and clicking Next  on each screen:

What time is it? = 13:20, the time field is displayed as 13:20:00. Click OK

The first set of questions relate to reactions at or around the site of vaccination.

Is there redness? = Y

Maximum severity of redness = Does not interfere with activity.

Medication taken for redness? = N

Any pain or discomfort around the vaccine site? = Y

On a scale of 1 to 99, with 1 being the least and 99 being the worst pain imaginable, how severe were your symptoms today? = Enter 100 to verify the warning
message shown, then correct the number to 49.

Medication taken for pain? = Y

List medication taken for pain = Tylenol 500mg

Any itching around the vaccine site? = N

How hot does the vaccine site feel? = Not hot at all

This next set of questions relate to general symptoms. Enter your temperature this evening = 34.7

Medication taken for fever? = N

Have you experienced joint aches? = N

Any Muscle aches? = N

Have you felt hot, flushed or sweaty? = N

Any headaches = N
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Have you felt more tired than normal? = N

Have you felt nauseous? = N

Have you felt generally unwell? = N

Have you experienced any other symptoms = N

Click Finish  > Yes to save the questionnaire.

7. Click History  to open the history page. Confirm that eDiary Day 7 is marked as Sent with correct date and time.

8. Click Logout  to exit the DFengage web application.

Configure and receive DFengage notifications

1. Start DFsetup, login as data_manager, and choose 254 Acceptance Test Study in normal acccess mode as described in “How to start DFsetup”

2. Click View > ePRO Notifications  in the file menu to open the ePRO Notifications dialog.

3. Select the Generic New Activity Reminder notification entry with ID 1. Confirm the following properties are defined for this notification:

Days = 0
Hours = 0
Minutes = 0
Direction = After
Title = New Activity
Message = It's time for your next activity. Please open the app to complete it now.

4. Click the Generic Overdue Activity Reminder notification with ID 2. Confirm the following properties are defined for this notification:

Days = 0
Hours = 0
Minutes = 0
Direction = After
Title = Overdue Activity
Message = Oops, you missed your last activity. Let's get back on track now.

DFdiscover 5.11.0 Acceptance Test Manual Page 282 of 313



5. Click Add to add a new notification with ID 3. Enter the information for the new notification as follows and click Save to add the new notification to the study.

Label = Upcoming Survey 9am
Active = Checked (enabled)
Notification Type = Due - Sent at scheduled time
Visit Reference = Visit 315 - ePRO Day 2 Survey T-09:00
Notification Timing

Offset from Visit = Checked (selected)
Days = 0
Hours = 0
Minutes = 5
Direction = Before

Title = {{PARTICIPANT_NAME}}, a new survey is coming!
Message = A new survey for {{STUDY_NAME}} will be available in 5 minutes. We would greatly appreciate your feedback.

6. For each of the remaining ePRO Day 2 Survey visits outlined in the visit map:

Visit 316 - ePRO Day 2 Survey T-10:00
Visit 317 - ePRO Day 2 Survey T-12:00
Visit 318 - ePRO Day 2 Survey T-14:00
Visit 319 - ePRO Day 2 Survey T-16:00

With notification ID 3 selected, click Duplicate  to create a new notification for each of the above visits, substituting the Visit Reference field for the appropriate visit and Label
value to reflect the corresponding time (10am, 12pm, 2pm, 4pm).
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7. Click Save to save changes to the notifications and then Done to close the ePRO notifications dialog. Then Click File  > Exit  to quit DFsetup.

8. Open a web browser and navigate to https://dfweb.dfdiscover.com/?server=explore.dfdiscover.com&api=dfws.dfdiscover.com or the DFweb URL provided by your administrator,
enter site_monitor in the Username field of the login dialog, and the previously assigned password in the Password field. Click Login  to login.

9. Click  Subjects , select 99014 > 300: Study Injection 1 to open the 30: Study Injection page.

10. Click Date of Injection, set:

Date of Injection = Yesterday's date
Time of Injection = 10:00:00
Surveys required? = Check (enable) Additional surveys required

Click Save. Click  > Logout  to exit DFweb.

11. Open the DFengage mobile application. Login as user atk_99014 (See: DFengage Login). Select default from the Pick Your Language dropdown, click Continue.

12. Close DFengage on the device and await the time designated for one of the custom notifications defined in step 5 and step 6(9am, 10am, 12pm, 2pm, 4pm). 5 minutes before the
generic notification arrives, confirm that the expected custom nofication arrives.

NOTE: as the date of injection was already set to Yesterday's date in step 10, the notification system may send additional notifications prior to the scheduled notifications
outlined in this step and the following steps, as prior defualt notification times may have already passed.

13. Wait for an additional 5 minutes until scheduled notification time. Verify that two notifications are received at the expected time: one for the overdue survey on Day 1, one for
the new survey on Day 2.

14. Click either of the notifications to open DFengage and enter PIN to login.

15. Click Start  next to the Survey Day 1 @9am set:

Click Today's date, Select a date of 04 Nov 2025. Click OK
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Please indicate on the scale how your health is TODAY. = 74

How would you rate your pain on average = 6

Click Finish , then Yes to submit the Survey Day 1 @9am survey.

16. Click History and Confirm the entry for Survey Day 1 @9am.

17. Click Settings > Logout  > Logout .

18. Login again as user atk_99014 (See: DFengage Login). This time selecting French from the Pick Your Language dropdown, click Continue.

19. Verify the questionnaire descriptions are in French. Locate Journal électronique Jour 1, click Start , verify Today’s date is displayed as Date du jour :.

Confirm logout of DFengage application clears data history

1. Still logged into DFengage, click History.

2. In the History Page, confirm that no entries exist.

3. Click Settings > Logout  > Logout .

Confirm data sent to the server using DFexplore

1. Login to DFexplore, Open subject 99015 > 301: ePRO Date of Injection > 31: eDiary Day 1. Confirm the data previously entered now appears in DFexplore.

2. Select Page > List History of Changes on This Page, check (enable) Detailed History. Confirm the audit trail is present.

End Module 19. DFengage ePRO Data Entry

1. Return to the DFATK application. Click End to confirm successful completion of Module 19. DFengage ePRO Data Entry.
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ATK Worksheet

Using the Worksheet

As you work through the ATK, you may find it beneficial to have a worksheet to keep track of which modules you have completed.

For that purpose, print this chapter and mark the steps and modules as you progress.

After completion of the ATK, keep the printed worksheet together with your installation and qualification materials.

Module 1. Installation and Initialization

Pass/Fail Testing step

 Pass  Fail 1. Confirm version information can be obtained for DFdiscover.

 Pass  Fail 2. Obtain super-user privileges and remove older Acceptance Test Study, if one exists.

 Pass  Fail 3. Install the Acceptance Test Study.

 Pass  Fail 4. Define Acceptance Test Study to the DFdiscover server.

 Pass  Fail 5. Create a role and permissions for datafax.

 Pass  Fail 6. Creating study roles and permissions.

 Pass  Fail 7. Creating user accounts and assigning study permissions.

 Pass  Fail 8. Enable high definition imaging.

 Pass  Fail 9. Start the Acceptance Test Study Control Panel application.

DFdiscover RPM & Build Date

Server FQDN & OS

Server Azure SMS Config &
Region

DFdiscover Tools Build Version
& Date

Completed By (Print name)

Title

Date

Signature
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Module 2. DFdiscover Client Applications

Pass/Fail Testing step

 Pass  Fail 1. Send PDF images to DFexplore

 Pass  Fail 2. Resetting a user login password.

 Pass  Fail 3. Verify the online user documentation. Open the Image Router and verify the appearance of the Welcome Image.

 Pass  Fail 4. Open the Acceptance Test Study and verify the standard DFexplore views.

 Pass  Fail 5. Start DFsetup and verify version information.

 Pass  Fail 6. Verify the online setup documentation. Open the Acceptance Test Study setup and verify the standard DFsetup views.

DFdiscover Tools Build Version
& Date

Completed By (Print name)

Title

Date

Signature
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Module 3. Study Setup

Pass/Fail Testing step

 Pass  Fail 1. Permitted users can gain exclusive access to DFsetup to modify a study setup.

 Pass  Fail 2. Define Global study preferences and apply settings to DFsetup.

 Pass  Fail 3. Create and modify a new style (Comment).

 Pass  Fail 4. Create and modify a new module (Death).

 Pass  Fail 5. Assign Field definitions to a newly created module.

 Pass  Fail 6. Assign a module's field definitions to a plate.

 Pass  Fail 7. Correct field ordering on the current plate to set field traversal order for data entry.

 Pass  Fail 8. Use copy and paste to create repeating module and field references on a plate.

 Pass  Fail 9. Create user-defined query category codes.

 Pass  Fail 10. Submit a copy of the newly defined Plate 11 into the study database and retrieve the page in DFexplore Image View.

 Pass  Fail 11. Enter and save all data on the submitted plate 11.

Completed By (Print name)

Title

Date

Signature
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Module 4. eCRF Creation for DFdiscover

Pass/Fail Testing step

 Pass  Fail 1. eCRF creation in DFsetup.

 Pass  Fail 2. eCRF background color preferences.

 Pass  Fail 3. Entering eCRF data.

Completed By (Print name)

Title

Date

Signature
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Module 5. Custom Properties

Pass/Fail Testing step

 Pass  Fail 1. Defining Custom Properties in DFsetup.

 Pass  Fail 2. Adding Global Custom Property values.

 Pass  Fail 3. Adding Plate, Module and Variable level Custom Property values.

 Pass  Fail 4. Exporting Custom Properties in DFsetup.

 Pass  Fail 5. Edit checks execution of Custom Properties.

 Pass  Fail 6. Creating subject data lists and exporting data views.

 Pass  Fail 7. DFexplore Database Definition Report exporting.

Completed By (Print name)

Title

Date

Signature
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Module 6. Subject Alias

Pass/Fail Testing step

 Pass  Fail 1. Importing and Modifying Subject Alias Map using DFsetup.

 Pass  Fail 2. Creating Subjects using Subject Alias.

 Pass  Fail 3. Subject Alias Tracking (Reports).

 Pass  Fail 4. Exporting Subject Alias data.

Completed By (Print name)

Title

Date

Signature
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Module 7. EDC Data Entry

Pass/Fail Testing step

 Pass  Fail 1. Login to DFexplore and the Acceptance Test Study and confirm the list of sites, subjects and assessments in the record list window.

 Pass  Fail 2. Enter and save new data using EDC data entry for Subject 99007.

 Pass  Fail 3. Add reasons to explain entered data values.

 Pass  Fail 4. Enter and save Plate 3, Subject 99007 as a pending record.

 Pass  Fail 5. Mark and save unavailable data as missed. Unmark available data as missed.

 Pass  Fail 6. Retrieve and modify existing data using a predefined task and save modifications to the database.

 Pass  Fail 7. Confirm audit trail information for entered and modified data.

Completed By (Print name)

Title

Date

Signature
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Module 8. Image Data Entry

Pass/Fail Testing step

 Pass  Fail 1. Submit PDF images to DFexplore.

 Pass  Fail 2. Login to DFexplore and confirm the receipt of new pages in the Status View.

 Pass  Fail 3. Login to the Image Router and route a misidentified page to the Acceptance Test Study new record queue.

 Pass  Fail 4. Login to DFexplore and confirm receipt of the routed page in the Status View.

 Pass  Fail 5. Retrieve new images in DFexplore Image View.

 Pass  Fail 6. Enter Plate 1 (Form 1) for Subject 99002.

 Pass  Fail 7. Enter Plate 2 (Form 2) for Subject 99002.

 Pass  Fail 8. Enter Plate 3 (Form 3) for Subject 99002.

 Pass  Fail 9. Enter Plate 4 (Form 4) for Subject 99002.

 Pass  Fail 10. Compare the resolutions between Standard Definition (SD) and High Definition (HD).

 Pass  Fail 11. Edit an existing query.

 Pass  Fail 12. Delete an existing query.

 Pass  Fail 13. Change data and record a reason for data change.

 Pass  Fail 14. Batch validate all opened pages for Subject 99002 to level 2.

 Pass  Fail 15. Confirm the status of entered pages in Status View.

Completed By (Print name)

Title

Date

Signature
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Module 9. User-defined Query Category Types

Pass/Fail Testing step

 Pass  Fail 1. Retrieve an existing data record in DFexplore.

 Pass  Fail 2. Apply a user-defined Category query.

 Pass  Fail 3. Add a reason for Data Value to explain entered data.

 Pass  Fail 4. Edit an existing query.

 Pass  Fail 5. Delete a user-defined Query Category that is used by an existing query.

 Pass  Fail 6. Delete a user-defined Category query.

Completed By (Print name)

Title

Date

Signature
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Module 10. Multiple Queries Per Field

Pass/Fail Testing step

 Pass  Fail 1. Submit PDF images to DFdiscover.

 Pass  Fail 2. Enable multiple queries per field in DFsetup.

 Pass  Fail 3. Retrieve submitted CRF in DFexplore Image View.

 Pass  Fail 4. Enter Plate 9 for Subject 99002.

 Pass  Fail 5. Apply multiple queries to a field.

 Pass  Fail 6. Select and edit an existing query in a field that has multiple queries.

 Pass  Fail 7. Select and reply to an existing query in a field that has multiple queries.

 Pass  Fail 8. Select and delete an existing query in a field that has multiple queries.

Completed By (Print name)

Title

Date

Signature
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Module 11. Data Review

Pass/Fail Testing step

 Pass  Fail 1. Retrieve all data for Site 99 that exists at level 3.

 Pass  Fail 2. Review and approve a pending reason for data value, and approve a selected query in a field that has multiple queries.

 Pass  Fail 3. Review and move approved reasons for data values to a higher workflow level, and review queries in a field that has multiple queries.

 Pass  Fail 4. Data review and add a query to inconsistent data.

 Pass  Fail 5. Review and complete pending data for Subject 99007.

 Pass  Fail 6. Confirm audit trail information for reviewed and modified data.

 Pass  Fail 7. Run batch edit checks to verify data integrity.

 Pass  Fail 8. Use a data expression to retrieve specific subject information.

 Pass  Fail 9. Use cross-plate data criteria to retrieve specific subject information.

Completed By (Print name)

Title

Date

Signature
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Module 12. External Query Reports

Pass/Fail Testing step

 Pass  Fail 1. Obtain database query metrics and details using Status and List Views to review all outstanding queries prior to query report creation.

 Pass  Fail 2. Run database integrity check report DF_XXkeys to export all key fields and visit dates from required plates in the database.

 Pass  Fail 3. Use Data View to check, and if necessary correct, illegal visit dates by retrieving the problems keys identified by DF_XXkeys.

 Pass  Fail 4. Execute DF_QCupdate to update the query database and lock all records for query report generation.

 Pass  Fail 5. Execute DF_QCreports to create a standard, 3-part external query report for a study site.

 Pass  Fail 6. Confirm the status of external queries following query report creation.

 Pass  Fail 7. Execute DF_QCstatus to verify that a new query report was created by listing all reports in the QC/NEW directory.

 Pass  Fail 8. Execute DF_QCview to display the newly created query report.

 Pass  Fail 9. Execute DF_QCprint to print the query report from the QC/NEW directory.

 Pass  Fail 10. Comparing several examples from the printed query report against their corresponding queries in the study database.

 Pass  Fail 11. Execute DF_QCfax to email the query report to a valid email account.

 Pass  Fail 12. Verify the status of the queries in the sent report.

Completed By (Print name)

Title

Date

Signature
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Module 13. Replying to EDC Queries, eSignatures

Pass/Fail Testing step

 Pass  Fail 1. Determine a count of outstanding/outstanding queries in Status View.

 Pass  Fail 2. Review outstanding queries in Queries View.

 Pass  Fail 3. Using EDC, locate and reply to outstanding clarification queries.

 Pass  Fail 4. Add an Electronic Signature (eSign) to a set of completed subject records.

 Pass  Fail 5. Verify removal and Re-applicaton of eSignatures.

Completed By (Print name)

Title

Date

Signature
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Module 14. Re-submitting Query Corrections

Pass/Fail Testing step

 Pass  Fail 1. Submit PDF images to DFdiscover.

 Pass  Fail 2. Verify that all CRFs have arrived successfully in Image view.

 Pass  Fail 3. Retrieve submitted CRFs using DFexplore Image View.

 Pass  Fail 4. Enter Form 2, Subject 99001, resolve outstanding queries, and save the corrected CRF to the database.

 Pass  Fail 5. Enter Form 2, Subject 99002, resolve outstanding queries, and save the corrected CRF to the database.

 Pass  Fail 6. Enter Form 4, Subject 99004.

 Pass  Fail 7. Enter Form 2, Subject 99004, resolve outstanding queries, and save the corrected CRF to the database.

 Pass  Fail 8. Select and resolve a query in a field that has multiple queries.

 Pass  Fail 9. Review and approve a pending query reply for Form 1 for Subject 99002.

 Pass  Fail 10. Review, correct and approve a pending query reply for Form 1, Subject 99007.

 Pass  Fail 11. Confirm query resolution by examining the database status.

Completed By (Print name)

Title

Date

Signature
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Module 15. Data Export and DFsas

Pass/Fail Testing step

 Pass  Fail 1. Export date values in calender format and save the exported data to a file on the local computer.

 Pass  Fail 2. Export date values from the database and save the exported data to a file on the local computer.

 Pass  Fail 3. Examining data values according to user-specified criteria.

 Pass  Fail 4. Query the database for specific data values.

 Pass  Fail 5. Create a DFsas job file according to user-specified criteria.

 Pass  Fail 6. Create a SAS job file and data files using the DFsas job file criteria.

 Pass  Fail 7. Compare the contents of SAS data files with the actual data in the database.

Completed By (Print name)

Title

Date

Signature
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Module 16. PDF File Creation

Pass/Fail Testing step

 Pass  Fail 1. Retrieve existing data according to user-specified criteria.

 Pass  Fail 2. Saving DFexplore data to a standard PDF document.

 Pass  Fail 3. Saving DFexplore blank CRF books to a standard PDF document.

 Pass  Fail 4. Viewing a standard PDF data file using a PDF viewer application.

 Pass  Fail 5. Saving DFexplore data to an encrypted bookmarked PDF file.

 Pass  Fail 6. Open and view an encrypted bookmarked PDF file using a PDF viewer application.

 Pass  Fail 7. Create a complete subject package PDF file that includes data records, CRF images and audit trail.

 Pass  Fail 8. Open and view a PDF subject package using a PDF viewer application.

Completed By (Print name)

Title

Date

Signature
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 Module 17. DFweb Data Entry

Pass/Fail Testing step

 Pass  Fail 1. Verify DFweb version information, logging into DFweb and DFweb site certificate verification.

 Pass  Fail 2. Resetting a user login password.

 Pass  Fail 3. Copying URL and changing user passwords.

 Pass  Fail 4. Creating a new subject, entering subject data.

 Pass  Fail 5. Adding, modifying and resolving queries.

 Pass  Fail 6. Adding, reviewing and downloading subject documents.

 Pass  Fail 6. Add an Electronic Signature (eSign) to a set of completed subject records.

 Pass  Fail 8. Verify removal and Re-applicaton of eSignatures.

 Pass  Fail 9. Verify DFweb saves eSignature task data to the specified save level.

DFweb URL used for testing

DFweb Version & Build Date

Completed By (Print name)
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Date
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Module 18. DFcollect Mobile Data Collection

Pass/Fail Testing step

 Pass  Fail 1. Installation and App preferences.

 Pass  Fail 2. Resetting a user login password.

 Pass  Fail 3. Online data record creation.

 Pass  Fail 4. Download subject data for offline use.

 Pass  Fail 5. Create data records in offline mode, query resolution and adding reasons for data values.

 Pass  Fail 6. Sync data collected offline to your DFdiscover server.

 Pass  Fail 7. Clearing DFcollect cache.

 Pass  Fail 8. Adding, reviewing and downloading subject documents.

 Pass  Fail 9. Confirming data sent to the server using DFexplore.

 Pass  Fail 10. Add an Electronic Signature (eSign) to a set of completed subject records.

 Pass  Fail 11. Verify removal and Re-applicaton of eSignatures.

 Pass  Fail 12. Verify DFcollect saves eSignature task data to the specified level.

 Pass  Fail 13. Verify no saved data remains upon uninstallation and reinstallation of DFcollect.

DFws API used for testing

DFcollect Version & Build Date

Completed By (Print name)
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Date
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Module 19. DFengage ePRO Data Entry Data Entry

Pass/Fail Testing step

 Pass  Fail 1. Create DFengage users role in DFadmin.

 Pass  Fail 2. Add bulk DFengage users accounts to DFadmin.

 Pass  Fail 3. Installation and initial DFengage login.

 Pass  Fail 4. Complete a task in online mode.

 Pass  Fail 5. Complete a task in offline mode.

 Pass  Fail 6. Sync data collected offline to your DFdiscover server.

 Pass  Fail 7. Resetting a user login password.

 Pass  Fail 8. Enter data in DFengage web.

 Pass  Fail 9. Configure and receive DFengage notifications.

 Pass  Fail 10. Confirm Logout of DFengage application clears data history.

 Pass  Fail 11. Confirm data sent to the server using DFexplore.

DFws API used for testing

DFengage Web URL used for
testing

DFengage Version & Build
Date

Completed By (Print name)
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Date
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Discrepancy Report
Discrepancy Reports should be completed whenever an unexpected result is obtained during the execution of the ATK. A discrepancy may be a difference in the actual result from the
expected result, a system malfunction, an error in the ATK documentation, or an error in the ATK Control Panel or study setup. Complete one report per incident.

Assign each report a unique Discrepancy Report Number. You may want to simply sequentially number the reports starting at 1, or you may want to use a more elaborate
numbering system.

Record the particulars about your system. This includes the DFdiscover Release being tested at your site (e.g., 5.11.0 ), the Server Operating System and Version.

Record the Test Number that you were executing when the problem occurred. This is the number that identifies the current step in the plan (e.g., 6.4.5).

Describe, as accurately and as completely as possible, the problem that occurred. Include any error messages that appeared on screen. Can someone who was not sitting at the
computer when the problem occurred understand your description?

If you were able to work around the problem and continue, describe the workaround that was used.

Record your name, title, signature and the current date on the report. Sign it.

If the discrepancy appears to be an error that needs resolution by DFnet, forward the report to DFnet via email to help@dfnetresearch.com. Record that a copy of the report has
been sent to DFnet and the date that it was sent.

If a resolution to the problem becomes available, either internally, or from DFnet provide a description of that resolution and the date.

Discrepancy Information

Discrepancy Report Number

DFdiscover Release

Server Operating System and
Version

Problem

Immediate Workaround

Problem Resolution

Signature and Date

Completed By
(Print name)

Title

Date

Signature
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Copyrights

External Software Copyrights

DFdiscover software uses several third-party software components as part of its server side and/or client tools.

The copyright information for each is provided below. If you would like to receive source codes of these third-party components, please send us your request at
help@dfnetresearch.com.

DCMTK software package

Copyright© 1994-2011, OFFIS e.V. All rights reserved.

This software and supporting documentation were developed by

OFFIS e.V. R&D Division Health Eschereg 2, 26121 Oldenburg, Germany

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided
with the distribution.

Neither the name of OFFIS nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Jansson

Copyright© 2009-2014 Petri Lehtinen <petri&digip.org>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Mimencode

Copyright© 1991 Bell Communications Research, Inc. (Bellcore)

Permission to use, copy, modify, and distribute this material for any purpose and without fee is hereby granted, provided that the above copyright notice and this permission notice
appear in all copies, and that the name of Bellcore not be used in advertising or publicity pertaining to this material without the specific, prior written permission of an authorized
representative of Bellcore. BELLCORE MAKES NO REPRESENTATIONS ABOUT THE ACCURACY OR SUITABILITY OF THIS MATERIAL FOR ANY PURPOSE. IT IS PROVIDED
"AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES.

RSA Data Security, Inc., MD5 message-digest algorithm

Copyright© 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved. License to copy and use this software is granted provided that it is identified as the "RSA Data Security,
Inc. MD5 Message-Digest Algorithm" in all material mentioning or referencing this software or this function. License is also granted to make and use derivative works provided that such
works are identified as "derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm" in all material mentioning or referencing the derived work. RSA Data Security,
Inc. makes no representations concerning either the merchantability of this software or the suitability of this software for any particular purpose. It is provided "as is" without express or
implied warranty of any kind. These notices must be retained in any copies of any part of this documentation and/or software.

mpack/munpack

Copyright© 1993,1994 by Carnegie Mellon University All Rights Reserved.

Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that the above copyright notice appear
in all copies and that both that copyright notice and this permission notice appear in supporting documentation, and that the name of Carnegie Mellon University not be used in
advertising or publicity pertaining to distribution of the software without specific, written prior permission. Carnegie Mellon University makes no representations about the suitability of
this software for any purpose. It is provided "as is" without express or implied warranty.

CARNEGIE MELLON UNIVERSITY DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS, IN NO EVENT SHALL CARNEGIE MELLON UNIVERSITY BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

TIFF

Copyright© 1988-1997 Sam Leffler Copyright© 1991-1997 Silicon Graphics, Inc.
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Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and
this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or
publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY
SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
PERFORMANCE OF THIS SOFTWARE.

PostgreSQL

Portions© 1996-2019, PostgreSQL Global Development Group Portions© 1994, The Regents of the University of California

Permission to use, copy, modify, and distribute this software and its documentation for any purpose, without fee, and without a written agreement is hereby granted, provided that the
above copyright notice and this paragraph and the following two paragraphs appear in all copies.

IN NO EVENT SHALL THE UNIVERSITY OF CALIFORNIA BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES,
INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION, EVEN IF THE UNIVERSITY OF CALIFORNIA HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

THE UNIVERSITY OF CALIFORNIA SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS ON AN "AS IS" BASIS, AND THE UNIVERSITY OF CALIFORNIA HAS NO
OBLIGATIONS TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.

OpenSSL License

Copyright© 1998-2019 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided
with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment: "This product includes software developed by the OpenSSL
Project for use in .the OpenSSL Toolkit." (https://www.openssl.org/)

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written
permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment: "This product includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit. (https://www.openssl.org)

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License

Copyright© 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com). The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to. The following conditions apply to all code found in this distribution, be it
the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is
Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the
author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided
with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes cryptographic software written by Eric
Young (eay@cryptsoft.com)" The word "cryptographic" can be left out if the routines from the library being used are not cryptographic related :-).

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: "This product includes
software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another
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distribution licence [including the GNU Public Licence.]

gawk

GNU GENERAL PUBLIC LICENSE Version 2, June 1991

https://www.gnu.org/licenses/gpl-2.0.html

Copyright© 1989, 1991 Free Software Foundation, Inc.

        51 Franklin Street, Fifth Floor, 
        Boston, MA  02110-1301, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to
share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any
other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Lesser General Public License instead.) You can apply it to
your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free
software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and
that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain
responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive
or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone
else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect
making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

1. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public
License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that
is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without
limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the
output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true
depends on what the Program does.

2. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each
copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other
recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

3. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the
terms of Section 1 above, provided that you also meet all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no
charge to all third parties under the terms of this License.

c. If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or
display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may
redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally
print such an announcement, your work based on the Program is not required to print an announcement.) These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and
its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on
the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every
part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of
derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution
medium does not bring the other work under the scope of this License.

4. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you
also do one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium
customarily used for software interchange; or,

b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a
complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software
interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and
only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.) The source code for a work means the preferred
form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated
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interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not
include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the
executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same
place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

5. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute
the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have
their licenses terminated so long as such parties remain in full compliance.

6. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works.
These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your
acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

7. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify
the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for
enforcing compliance by third parties to this License.

8. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court
order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy
simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent
license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and
this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is
intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of
protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range
of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software
through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

9. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program
under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded.
In such case, this License incorporates the limitation as if written in the body of this License.

10. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present
version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of
following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this
License, you may choose any version ever published by the Free Software Foundation.

11. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is
copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of
preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally. NO WARRANTY

12. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE
DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

13. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY
AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING
RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Ghostscript

The files in the base, psi, lib, toolbin, examples, doc and man directories (folders) and any subdirectories (sub-folders) thereof are part of GPL Ghostscript.

The files in the Resource directory and any subdirectories thereof are also part of GPL Ghostscript, with the explicit exception of the files in the CMap subdirectory (except "Identity-
UTF16-H", which is part of GPL Ghostscript). The CMap files are copyright Adobe Systems Incorporated and covered by a separate, GPL compatible license.

The files under the jpegxr directory and any subdirectories thereof are distributed under a no cost, open source license granted by the ITU/ISO/IEC but it is not GPL compatible - see
jpegxr/COPYRIGHT.txt for details.

GPL Ghostscript is free software; you can redistribute it and/or modify it under the terms the GNU General Public License as published by the Free Software Foundation, either version
3 of the License, or (at your option) any later version.

GPL Ghostscript is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program so you can know your rights and responsibilities. It should be in a file named
doc/COPYING. If not, write to the

    Free Software Foundation, Inc.,
59 Temple Place Suite 330, 
Boston, MA, 02111-1307, USA.

GPL Ghostscript contains an implementation of techniques covered by US Patents 5,055,942 and 5,917,614, and corresponding international patents. These patents are licensed for
use with GPL Ghostscript under the following grant:

Whereas, Raph Levien (hereinafter "Inventor") has obtained patent protection for related technology (hereinafter "Patented Technology"), Inventor wishes to aid the the GNU free
software project in achieving its goals, and Inventor also wishes to increase public awareness of Patented Technology, Inventor hereby grants a fully paid up, nonexclusive, royalty free
license to practice the patents listed below ("the Patents") if and only if practiced in conjunction with software distributed under the terms of any version of the GNU General Public
License as published by the
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Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111. 

Inventor reserves all other rights, including without limitation, licensing for software not distributed under the GNU General Public License.

5055942 Photographic image reproduction device using digital halftoning to para images allowing adjustable coarseness 5917614 Method and apparatus for error diffusion paraing of
images with improved smoothness in highlight and shadow regions

MariaDB and FreeTDS

GNU LESSER GENERAL PUBLIC LICENSE Version 2.1, February 1999 https://www.gnu.org/licenses/lgpl-2.1.html

Copyright© 1991, 1999

    Free Software Foundation, Inc.
    51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, hence the version number 2.1.]

Preamble The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses are intended to guarantee
your freedom to share and change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of the Free Software Foundation and other authors who
decide to use it. You can use it too, but we suggest you first think carefully about whether this license or the ordinary General Public License is the better strategy to use in any
particular case, based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of
free software (and charge for this service if you wish); that you receive source code or can get it if you want it; that you can change the software and use pieces of it in new free
programs; and that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender these rights. These restrictions translate to certain
responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you. You must make sure that they, too, receive or
can get the source code. If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with the library after making changes
to the library and recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method:

1. we copyright the library, and

2. we offer you this license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by someone else and passed on, the recipients
should know that what they have is not the original version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot effectively restrict the users of a free program by
obtaining a restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of use
specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General Public License, applies to certain
designated libraries, and is quite different from the ordinary General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free
programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a combined work, a derivative of the original library.
The ordinary General Public License therefore permits such linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria
for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public License. It also provides other free
software developers Less of an advantage over competing non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries.
However, the Lesser license provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a de-facto standard. To achieve this, non-free
programs must be allowed to use the library. A more frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting
the free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free software. For example, permission to use the
GNU C Library in non-free programs enables many more people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked with the Library has the freedom and the
wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work based on the library" and a "work that uses the
library". The former contains code derived from the library, whereas the latter must be combined with the library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

1. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or other authorized party saying it may be
distributed under the terms of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which use some of those functions and data) to
form executables.

The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the Library" means either the Library or any
derivative work under copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into
another language. (Hereinafter, translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means all the source code for all modules it
contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a program using the Library is not
restricted, and output from such a program is covered only if its contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it).
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Whether that is true depends on what the Library does and what the program that uses the Library does.

2. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on
each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy
of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

3. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and distribute such modifications or work under the
terms of Section 1 above, provided that you also meet all of these conditions:

a. The modified work must itself be a software library.

b. You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.

c. You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.

d. If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the facility, other than as an argument passed when
the facility is invoked, then you must make a good faith effort to ensure that, in the event an application does not supply such function or table, the facility still operates, and
performs whatever part of its purpose remains meaningful. (For example, a function in a library to compute square roots has a purpose that is entirely well-defined
independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the application does
not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and can be reasonably considered
independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you
distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for
other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of
derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or distribution medium
does not bring the other work under the scope of this License.

4. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do this, you must alter all the notices that
refer to this License, so that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU
General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent copies and derivative works made
from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

5. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that
you accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily
used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place satisfies the
requirement to distribute the source code, even though third parties are not compelled to copy the source along with the object code.

6. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or linked with it, is called a "work that uses the
Library". Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a
"work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a derivative work of the Library even though the
source code is not. Whether this is true is especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not
precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten lines or less in length), then the use of
the object file is unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any executables containing that work also fall
under Section 6, whether or not they are linked directly with the Library itself.

7. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work containing portions of the Library, and
distribute that work under terms of your choice, provided that the terms permit modification of the work for the customer's own use and reverse engineering for debugging such
modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this License. You must supply a copy of this
License. If the work during execution displays copyright notices, you must include the copyright notice for the Library among them, as well as a reference directing the user to the
copy of this License.

Also, you must do one of these things:

a. Accompany the work with the complete corresponding machine-readable source code for the Library including whatever changes were used in the work (which must be
distributed under Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-readable "work that uses the Library", as object
code and/or source code, so that the user can modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood that the
user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application to use the modified definitions.)

b. Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that

i. uses at run time a copy of the library already present on the user's computer system, rather than copying library functions into the executable, and

ii. will operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-compatible with the version that the work
was made with.

c. Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in Subsection 6a, above, for a charge no more than the
cost of performing this distribution.

d. If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the above specified materials from the same place.

e. Verify that the user has already received a copy of these materials or that you have already sent this user a copy. For an executable, the required form of the "work that uses
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the Library" must include any data and utility programs needed for reproducing the executable from it. However, as a special exception, the materials to be distributed need
not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the
executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally accompany the operating system. Such a
contradiction means you cannot use both them and the Library together in an executable that you distribute.

f. You may place library facilities that are a work based on the Library side-by-side in a single library together with other library facilities not covered by this License, and
distribute such a combined library, provided that the separate distribution of the work based on the Library and of the other library facilities is otherwise permitted, and
provided that you do these two things:

a. Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities. This must be distributed under the
terms of the Sections above.

b. Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form
of the same work.

g. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense,
link with, or distribute the Library is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such parties remain in full compliance.

h. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Library or its derivative
works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you
indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

i. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the original licensor to copy, distribute, link with
or modify the Library subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not
responsible for enforcing compliance by third parties with this License.

j. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by
court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to
satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if
a patent license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy
both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a whole is
intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole
purpose of protecting the integrity of the free software distribution system which is implemented by public license practices. Many people have made generous contributions
to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to
distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

k. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Library
under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus
excluded. In such case, this License incorporates the limitation as if written in the body of this License.

l. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such new versions will be similar in spirit to
the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any later version", you have the option
of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Library does not specify a license version
number, you may choose any version ever published by the Free Software Foundation.

m. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these, write to the author to ask for permission. For
software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided
by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

n. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY
OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE
DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

o. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY
MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL
OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA
BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER
SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

QtAV

© Wang Bin wbsecg1@gmail.com Shanghai University->S3 Graphics->Deepin, Shanghai, China 2013-01-21

QtAV is free software licensed under the term of LGPL v2.1. The player example is licensed under GPL v3. If you use QtAV or its constituent libraries, you must adhere to
the terms of the license in question.

Rather than repeating the text of the LGPL v2.1, the original text can be found in GNU LESSER GENERAL PUBLIC LICENSE, Version 2.1.

FFmpeg

Most files in FFmpeg are under the GNU Lesser General Public License version 2.1 or later (LGPL v2.1+). Read the file `COPYING.LGPLv2.1` for details. Some other files have
MIT/X11/BSD-style licenses. In combination the LGPL v2.1+ applies to FFmpeg.

Rather than repeating the text of the LGPL v2.1, the original text can be found in GNU LESSER GENERAL PUBLIC LICENSE, Version 2.1.
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c3.js

The MIT License (MIT) © 2013 Masayuki Tanaka

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

d3.js

Copyright© 2010-2017 Mike Bostock All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: * Redistributions of source code must retain
the above copyright notice, this list of conditions and the following disclaimer. * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution. * Neither the name of the author nor the names of contributors may be used to endorse
or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

jwt-cpp

MIT License

Copyright © 2018 Dominik Thalhammer

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

QXlsx

The MIT License

Copyright © 2017-, https://github.com/j2doll/QXlsx

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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